File python3-qscintilla.spec of Package python-qscintilla

#
# spec file for package python3-qscintilla
#
# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           python3-qscintilla
Url:            http://www.riverbankcomputing.co.uk/software/qscintilla/intro
Summary:        Python 3 Bindings for the C++ Editor Class Library
License:        GPL-2.0+
Group:          Development/Libraries/C and C++
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
Version:        2.7.2
Release:        0
%define scintilla_version %version
Source:         http://downloads.sourceforge.net/project/pyqt/QScintilla2/QScintilla-%{version}/QScintilla-gpl-%{version}.tar.gz
Requires:       python3-qt4 >= %( echo `rpm -q --queryformat '%{VERSION}' python3-qt4`)

BuildRequires:  libqscintilla-devel
BuildRequires:  libqscintilla2-9
BuildRequires:  python3-devel
BuildRequires:  python3-qt4-devel
BuildRequires:  python3-sip-devel

Requires:       python(abi) = %{py3_ver}
%requires_ge    python3-sip
%requires_ge    libqt4-x11

%description
QScintilla is a Qt port of Neil Hodgson's Scintilla C++ editor class.

This is a Qt port from the original Scintilla class
(http://www.scintilla.org/).

This package is mainly used by eric, the Python IDE.

%prep
%setup -q -n QScintilla-gpl-%scintilla_version

%build
pushd Python
python3 configure-old.py
make %{?_smp_mflags}
popd

%install
pushd Python
%makeinstall
rm -rf $RPM_BUILD_ROOT/usr/share/sip/PyQt4/Qsci
mv $RPM_BUILD_ROOT/usr/share/qt4/qsci/api/python $RPM_BUILD_ROOT/usr/share/qt4/qsci/api/python3
popd

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-,root,root)
%doc NEWS README LICENSE.GPL2 LICENSE.GPL3
%{python3_sitearch}/PyQt4/Qsci.so
/usr/share/qt4/qsci/api/python3/QScintilla2.api

%changelog
openSUSE Build Service is sponsored by