File WindowMaker.spec of Package WindowMaker

#
# spec file for package WindowMaker
#
# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           WindowMaker
Summary:        A Colorful and Flexible Window Manager
License:        GPL-2.0+ and LGPL-2.1+ and SUSE-Public-Domain
Group:          System/GUI/Other
Version:        0.95.5
Release:        0
# 81eefca4ef70414d73048300058e5007f402dd7f
# f846b7cdd39749b5291d4559185a229b752b4fed
#Version:        0.95.3.99.2
Url:            http://windowmaker.org/
Source:         http://windowmaker.org/pub/source/release/%{name}-%{version}.tar.gz
Source1:        %{name}-extra-0.1.tar.bz2
Source2:        SuSE-theme.tar.bz2
Source4:        README.SuSE
Source5:        %{name}.desktop
Source6:        windowmaker
Source7:        %{name}-rpmlintrc
Patch1:         %{name}-config.patch
Patch2:         %{name}-menu.patch
Patch3:         fix_wmgenmenu_paths.patch
#
Patch101:       wm-giflib.patch
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildRequires:  fontconfig-devel
BuildRequires:  freetype2-devel
BuildRequires:  gcc-c++
BuildRequires:  giflib-devel
BuildRequires:  libjpeg-devel
BuildRequires:  libpng-devel
BuildRequires:  libtiff-devel
BuildRequires:  libtool
%if 0%{?suse_version} > 1210
BuildRequires:  libXft-devel
%endif
BuildRequires:  update-desktop-files
BuildRequires:  xorg-x11-devel
Provides:       windowmanager
Provides:       wmaker
Requires:       xdg-menu

%description
Window Maker is an X11 window manager originally designed to provide
integration support for the GNUstep Desktop Environment. In every way
possible, it reproduces the elegant look and feel of the NEXTSTEP user
interface. It is fast, feature rich, easy to configure, and easy to
use. It is also free software, with contributions being made by
programmers from around the world.

Window Maker has a stable user interface since many years and comes
with a powerful GUI configuration editor called WPrefs, which removes
the need to edit text-based config files by hand. It supports running
dockapps which make everyday tasks such as monitoring system 
performance and battery usage, mounting devices or connecting to the
internet very easy. Please see the features section for more specifics
on what Window Maker can do, and how it compares with other popular
window managers.

%package devel
Summary:        Development files for WindowMaker
License:        GPL-2.0+
Group:          Development/Libraries/X11
Requires:       %{name} = %{version}
Requires:       giflib-devel
Requires:       libjpeg-devel
Requires:       libpng-devel
Requires:       libtiff-devel
Requires:       xorg-x11-devel
Requires:       zlib-devel

%description devel
This package contains the header files and libraries necessary for
developing applications which use WindowMaker.

%prep
%setup -q -n %{name}-%{version} -a 1
mkdir menu_orig
cp %{name}/{menu.*,plmenu.*} menu_orig
%patch1
%patch2 -p1
%patch3 -p1
%patch101 -p1
cp %{S:4} .
cp %{S:6} .
%if 0%{?suse_version} < 1140
rename no nb po/no.*
%endif
(cd %{name}; rm -f *.orig; ./mkMakefile )
# ---------------------------------------------------------------------------

%build
./autogen.sh
#autoreconf --force --install
%if 0%{?suse_version} >= 1140
export LINGUAS="be bg bs ca cs da de el es et fi fr gl hr hu hy it ja ko ms nl no pl pt ro ru sk sv tr zh_CN zh_TW"
%else
export LINGUAS="be bg bs ca cs da de el es et fi fr gl hr hu hy it ja ko ms nl nb pl pt ro ru sk sv tr zh_CN zh_TW"
%endif
export CFLAGS="$RPM_OPT_FLAGS $(freetype-config --cflags)"
%configure \
  --prefix=/usr \
  --datadir=/usr/share \
  --disable-static \
  --with-pic\
  --sysconfdir=/etc/X11 \
  --enable-xinerama \
  --with-nlsdir=/usr/share/locale \
  --with-pixmapdir=/usr/share/%{name}/Pixmaps \
  --with-gnustepdir=/usr/lib/GNUstep

(cd %{name}/Defaults; make clean; make %{?_smp_mflags})
make %{?_smp_mflags}
(cd %{name}-extra-0.1
%configure \
  --prefix=/usr \
  --disable-static \
  --with-pic\
  --with-pixmapdir=/usr/share/%{name}/Pixmaps

make %{?_smp_mflags}
)
# ---------------------------------------------------------------------------

%install
make DESTDIR=$RPM_BUILD_ROOT install
install -m 755 dockit $RPM_BUILD_ROOT/usr/bin/dockit
install -m 755 windowmaker $RPM_BUILD_ROOT/usr/bin/windowmaker
cd %{name}-extra-0.1
make DESTDIR=$RPM_BUILD_ROOT install
tar -xvjf %SOURCE2 -C $RPM_BUILD_ROOT/usr/share/%{name}/Themes/
find $RPM_BUILD_ROOT/usr/share/%{name}/Themes -type f -exec chmod 644 {} \;
find $RPM_BUILD_ROOT/usr/share/%{name}/Themes -type d -exec chmod 755 {} \;
#----------------------------------------------------------------------
# not packaged
rm -f $RPM_BUILD_ROOT/%{_mandir}/{cs,ru,sk}/man1/*
rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
# install kdm/gdm entry
install -m 0755 -d $RPM_BUILD_ROOT/usr/share/xsessions/
install -m 0644 %SOURCE5 $RPM_BUILD_ROOT/usr/share/xsessions/
%suse_update_desktop_file $RPM_BUILD_ROOT/usr/share/xsessions/%{name}.desktop
cd ..
%find_lang %{name}
%find_lang WINGs %{name}.lang
%find_lang WPrefs %{name}.lang
%find_lang wmgenmenu %{name}.lang

%post -p /sbin/ldconfig

%postun -p /sbin/ldconfig

%files -f %{name}.lang
%defattr(-,root,root)
%doc AUTHORS BUGFORM BUGS COPYING COPYING.WTFPL ChangeLog FAQ FAQ.I18N
%doc NEWS README* TODO
%doc menu_orig
%dir /etc/X11/%{name}
%config /etc/X11/%{name}/*
/usr/lib/GNUstep
/usr/bin/*
%{_libdir}/*.so.*
%{_mandir}/man1/*
%{_mandir}/man8/*
/usr/share/WINGs
/usr/share/%{name}
/usr/share/xsessions/*
#/usr/X11R6/share/%{name}
#/usr/X11R6/GNUstep

%files devel
%defattr(-,root,root)
%{_includedir}/*
%{_libdir}/pkgconfig/*.pc
%{_libdir}/*.so

%changelog
openSUSE Build Service is sponsored by