File arandr.spec of Package arandr
# vim: set sw=4 ts=4 et nu:
# Copyright (c) 2012 Pascal Bleser <pascal.bleser@opensuse.org>
# Copyright (c) 2013 B1 Systems GmbH, Vohburg, Germany <seife+obs@b1-systems.com>
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
Name: arandr
Version: 0.1.7.1
Release: 0
Summary: Visual Front End for XRandR
Source: http://christian.amsuess.com/tools/arandr/files/arandr-%{version}.tar.gz
Patch1: arandr-fix_desktop_icon.patch
URL: http://christian.amsuess.com/tools/arandr/
Group: System/X11/Utilities
License: GPL-3.0
BuildRoot: %{_tmppath}/build-%{name}-%{version}
BuildRequires: python-devel
%if 0%{?suse_version} >= 1140
BuildRequires: python-gtk-devel
%else
BuildRequires: python-gtk
%endif
%if 0%{?suse_version} >= 1210
BuildRequires: python-docutils
%else
BuildRequires: docutils
%endif
BuildRequires: make
BuildRequires: update-desktop-files
BuildRequires: hicolor-icon-theme
BuildRequires: desktop-data-openSUSE
BuildArch: noarch
%if 0%{?suse_version} >= 1220
Requires: xrandr
%else
Requires: xorg-x11
%endif
Requires: python-gtk
%description
ARandR is designed to provide a simple visual front end for XRandR. Relative
monitor positions are shown graphically and can be changed in a drag-and-drop
way.
%prep
%setup -q
%patch1
%build
%__python ./setup.py build
%install
%__python ./setup.py install \
--prefix="%{_prefix}" \
--root="%{buildroot}" \
--record-rpm=files.lst
%__perl -n -i -e 'print unless m,%{_datadir}/(locale|applications),' files.lst
%__perl -n -i -e 'print unless m,%{_bindir},' files.lst
%suse_update_desktop_file -r "%{name}" Settings DesktopSettings
%find_lang "%{name}"
%__chmod 0755 "%{buildroot}%{_bindir}"/*
%clean
%{?buildroot:%__rm -rf "%{buildroot}"}
%files -f "%{name}.lang" -f files.lst
%defattr(-,root,root)
%doc ChangeLog COPYING NEWS README TODO
%{_bindir}/arandr
%{_bindir}/unxrandr
%{_datadir}/applications/%{name}.desktop
%doc %{_mandir}/man1/arandr.1*
%doc %{_mandir}/man1/unxrandr.1*
%changelog