File cppunit.spec of Package cppunit
#
# spec file for package cppunit
#
# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%define libname libcppunit-1_13-0
Name: cppunit
Version: 1.13.2
Release: 0
Summary: C++ Port of the JUnit Testing Framework
License: LGPL-2.1+
Group: Development/Libraries/C and C++
Url: http://www.freedesktop.org/wiki/Software/cppunit
Source: http://dev-www.libreoffice.org/src/%name-%version.tar.gz
Source1: cppunit-devel.desktop
BuildRequires: doxygen
BuildRequires: gcc-c++
BuildRequires: libtool
BuildRequires: pkgconfig
BuildRequires: update-desktop-files
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%description
CppUnit is the C++ port of the famous JUnit framework for unit testing.
Test output is in XML for automatic testing and GUI based for
supervised tests.
%package -n %{libname}
Summary: Include Files and Libraries mandatory for Development
Group: Development/Libraries/C and C++
%description -n %{libname}
This package contains all necessary include files and libraries needed
to develop applications that require these.
%package devel
Summary: Include Files and Libraries mandatory for Development
Group: Development/Libraries/C and C++
Requires: %{libname} = %{version}
Suggests: devel-doc = %{version}
Provides: libcppunit-devel = %{version}
Obsoletes: libcppunit-devel < %{version}
%description devel
This package contains all necessary include files and libraries needed
to develop applications that require these.
%package devel-doc
Summary: Documentation for the cppunit API
Group: Documentation/HTML
Conflicts: libcppunit-devel < 1.13.2
%if 0%{?suse_version} > 1200
BuildArch: noarch
%endif
%description devel-doc
This package contains documentation for the cppunit API.
%prep
%setup -q
%build
export CXXFLAGS="%{optflags}"
%configure \
--disable-static \
--enable-doxygen
make %{?_smp_mflags} V=1
%install
make DESTDIR=%{buildroot} install
# remove la archive
rm %{buildroot}%{_libdir}/*.la
# this got also installed to _defaultdocdir
rm -rf %{buildroot}%{_datadir}/cppunit/html/
find %{buildroot}%{_includedir} -type f | xargs chmod a-x
# install susehelp file
mkdir -p %{buildroot}%{_datadir}/susehelp/meta/Development/Libraries/
install %{SOURCE1} %{buildroot}%{_datadir}/susehelp/meta/Development/Libraries/
%suse_update_desktop_file %{buildroot}%{_datadir}/susehelp/meta/Development/Libraries/cppunit-devel.desktop
%check
make check %{?_smp_mflags} V=1
%post -n %{libname} -p /sbin/ldconfig
%postun -n %{libname} -p /sbin/ldconfig
%files -n %{libname}
%defattr(-,root,root)
%doc AUTHORS COPYING
%{_libdir}/libcppunit*.so.*
%{_datadir}/cppunit
%files devel
%defattr(-,root,root)
%doc NEWS README THANKS ChangeLog
%{_bindir}/DllPlugInTester
%{_bindir}/cppunit-config
%{_libdir}/libcppunit*.so
%{_libdir}/pkgconfig/cppunit.pc
%{_includedir}/*
%{_mandir}/*/*
%{_datadir}/aclocal/cppunit.m4
%files devel-doc
%defattr(-,root,root)
%doc doc/html/*
%{_datadir}/susehelp
%changelog