File go-web.go.spec of Package go-web.go
#
# spec file for package go-web.go
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
# Copyright (c) 2011 Sascha Peilicke <saschpe@gmx.de>
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: go-web.go
Version: 0.0.0+git20120217
Release: 0
Summary: A simple framework to write webapps in Go
License: MIT
Group: Development/Languages/Other
Url: http://github.com/hoisie/web.go
# see also http://github.com/ganderson/web.go weekly branch for upstreamed pull request
Source0: web.go-%{version}.tar.bz2
Patch0: weekly-build-fix.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-build
BuildRequires: go-devel
ExclusiveArch: %ix86 x86_64 %arm
%if 0%{?suse_version} >= 1100
Recommends: go-web.go-doc
%endif
%{go_provides}
%{go_requires}
%description
Web.go is the simplest way to write web applications in the Go programming
language. It's ideal for writing simple, performant backend web services.
%package doc
Summary: API documenation
Group: Documentation/Other
Requires: %{name} = %{version}
%description doc
API, examples and documentation.
%prep
%setup -q -n web.go
%patch0 -p1
%build
%goprep github.com/hoisie/web.go/
%gobuild
%install
%{go_disable_brp_strip_static_archive}
%goinstall
%godoc
%check
# couple of tests currently fail for json parser
#%%gotest github.com/hoisie/web.go
%files
%defattr(-,root,root,-)
%doc LICENSE Readme.md examples
%{go_contribdir}/*
%files doc
%defattr(-,root,root,-)
%{go_contribsrcdir}/*
%changelog