File libcdio.spec of Package libcdio

#
# spec file for package libcdio
#
# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%define cdioutils 0
%define build_paranoia 0
%define cdio_soname 14

Name:           libcdio
Version:        0.90
Release:        0
BuildRequires:  fdupes
BuildRequires:  gcc-c++
BuildRequires:  help2man
BuildRequires:  libtool
BuildRequires:  ncurses-devel
BuildRequires:  pkg-config
BuildRequires:  popt-devel
BuildRequires:  pkgconfig(libcddb)
%if 0%{suse_version} > 1220
BuildRequires:  makeinfo
%endif
Url:            http://savannah.gnu.org/projects/libcdio
Summary:        CD-ROM Access Library
License:        GPL-3.0+
Group:          Productivity/Multimedia/Other
Source0:        http://ftp.gnu.org/gnu/libcdio/%{name}-%{version}.tar.gz
Source1:        baselibs.conf
# bug437293
%ifarch ppc64
Obsoletes:      libcdio-64bit
%endif
#
BuildRoot:      %{_tmppath}/%{name}-%{version}-build

%description
This library encapsulates CD-ROM reading and control. Applications
wanting to be oblivious to the OS and device-dependent properties of a
CD-ROM can use this library.


%package -n libcdio%{cdio_soname}
Summary:        CD-ROM Access Library
Group:          Productivity/Multimedia/Other
# bug437293
%ifarch ppc64
Obsoletes:      libcdio-64bit
%endif
#
# Name for <= 10.2
Obsoletes:      libcdio <= 0.78.2
Provides:       libcdio = %{version}

%description -n libcdio%{cdio_soname}
This library encapsulates CD-ROM reading and control. Applications
wanting to be oblivious to the OS and device-dependent properties of a
CD-ROM can use this library.


%if %{build_paranoia} == 1
%package -n libcdio_cdda1
Summary:        CD-ROM Access Library
Group:          Productivity/Multimedia/Other
# bug437293
%ifarch ppc64
Obsoletes:      libcdio-64bit
%endif
#

%description -n libcdio_cdda1
This library encapsulates CD-ROM reading and control. Applications
wanting to be oblivious to the OS and device-dependent properties of a
CD-ROM can use this library.


%package -n libcdio_paranoia1
Summary:        CD-ROM Access Library
Group:          Productivity/Multimedia/Other
# bug437293
%ifarch ppc64
Obsoletes:      libcdio-64bit
%endif
#

%description -n libcdio_paranoia1
This library encapsulates CD-ROM reading and control. Applications
wanting to be oblivious to the OS and device-dependent properties of a
CD-ROM can use this library.

%endif

%package -n libcdio++0
Summary:        CD-ROM Access Library
Group:          Productivity/Multimedia/Other
# bug437293
%ifarch ppc64
Obsoletes:      libcdio-64bit
%endif
#

%description -n libcdio++0
This library encapsulates CD-ROM reading and control. Applications
wanting to be oblivious to the OS and device-dependent properties of a
CD-ROM can use this library.



Authors:
--------
    Herbert Valerio Riedel <hvr@gnu.org>
    Rocky Bernstein <rocky@panix.com>

%package -n libiso9660-8
Summary:        CD-ROM Access Library
Group:          Productivity/Multimedia/Other
# bug437293
%ifarch ppc64
Obsoletes:      libcdio-64bit
%endif
#

%description -n libiso9660-8
This library encapsulates CD-ROM reading and control. Applications
wanting to be oblivious to the OS and device-dependent properties of a
CD-ROM can use this library.


%package -n libudf0
Summary:        CD-ROM Access Library
Group:          Productivity/Multimedia/Other
# bug437293
%ifarch ppc64
Obsoletes:      libcdio-64bit
%endif
#

%description -n libudf0
This library encapsulates CD-ROM reading and control. Applications
wanting to be oblivious to the OS and device-dependent properties of a
CD-ROM can use this library.

%package devel
Summary:        CD-ROM access library
Group:          Development/Languages/C and C++
Requires:       glibc-devel
Requires:       libcdio%{cdio_soname} = %{version}
Requires:       libcdio++0 = %{version}
Requires:       libiso9660-8 = %{version}
Requires:       libudf0 = %{version}
%if %{build_paranoia} == 1
Requires:       libcdio_cdda1 = %{version}
Requires:       libcdio_paranoia1 = %{version}
%endif
# bug437293
%ifarch ppc64
Obsoletes:      libcdio-devel-64bit
%endif
#

%description devel
This library encapsulates CD-ROM reading and control. Applications
wanting to be oblivious to the OS and device-dependent properties of a
CD-ROM can use this library.

%prep
%setup -q
%define buildir ${PWD}

%build
%configure \
	--disable-rpath \
	--enable-static=n \
	--enable-shared=yes \
	--with-pic \
	--enable-rock \
	--without-cd-drive \
	--without-cd-info \
	--without-cdda-player \
	--without-cd-read \
	--without-iso-info \
	--without-iso-read
 VERBOSE=1 make -e %{?jobs:-j%jobs}
#-lcdioutils

%install
%makeinstall
%if 1 == 0
mv $RPM_BUILD_ROOT%{_mandir}/jp $RPM_BUILD_ROOT%{_mandir}/ja
%endif
#empty depdendency libs
rm -rf %{buildroot}%{_bindir} %{buildroot}%{_mandir}
rm -f %{buildroot}%{_libdir}/*.la

%post -n libcdio%{cdio_soname} -p /sbin/ldconfig

%post -n libcdio++0 -p /sbin/ldconfig

%post -n libiso9660-8 -p /sbin/ldconfig

%post -n libudf0 -p /sbin/ldconfig

%postun -n libcdio%{cdio_soname} -p /sbin/ldconfig

%postun -n libcdio++0 -p /sbin/ldconfig

%postun -n libiso9660-8 -p /sbin/ldconfig

%postun -n libudf0 -p /sbin/ldconfig

%post devel
%install_info --info-dir=%{_infodir} %{_infodir}/%{name}.info.gz

%postun devel
%install_info_delete --info-dir=%{_infodir} %{_infodir}/%{name}.info.gz

%files -n libcdio%{cdio_soname}
%defattr (-, root, root)
%{_libdir}/libcdio.so.*

%files -n libcdio++0
%defattr (-, root, root)
%{_libdir}/libcdio++.so.*
%{_libdir}/libiso9660++.so.*

%files -n libiso9660-8
%defattr (-, root, root)
%{_libdir}/libiso9660.so.*

%files -n libudf0
%defattr (-, root, root)
%{_libdir}/libudf.so.*

%files devel
%defattr (-, root, root)
%doc %{_infodir}/*.info*
%{_includedir}/cdio
%{_includedir}/cdio++
%{_libdir}/libcdio*.so
%{_libdir}/libiso9660*.so
%{_libdir}/libudf*.so
%{_libdir}/pkgconfig/*.pc

%if %{build_paranoia} == 1

%post -n libcdio_cdda1 -p /sbin/ldconfig

%post -n libcdio_paranoia1 -p /sbin/ldconfig

%postun -n libcdio_cdda1 -p /sbin/ldconfig

%postun -n libcdio_paranoia1 -p /sbin/ldconfig

%files -n libcdio_cdda1
%defattr (-, root, root)
%{_libdir}/libcdio_cdda.so.*

%files -n libcdio_paranoia1
%defattr (-, root, root)
%{_libdir}/libcdio_paranoia.so.*
%endif

%changelog
openSUSE Build Service is sponsored by