File python-zope.testrunner.spec of Package python-zope.testrunner

#
# spec file for package python-zope.testrunner
#
# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           python-zope.testrunner
Version:        4.4.1
Release:        0
Summary:        Zope testrunner script
License:        ZPL-2.1
Group:          Development/Languages/Python
Url:            http://pypi.python.org/pypi/zope.testrunner
Source:         https://pypi.python.org/packages/source/z/zope.testrunner/zope.testrunner-%{version}.zip
BuildRequires:  fdupes
BuildRequires:  python-devel
BuildRequires:  python-setuptools
BuildRequires:  unzip
# Test requirements:
#BuildRequires:  python-python-subunit
#BuildRequires:  python-six
#BuildRequires:  python-testtools
#BuildRequires:  python-unittest2
#BuildRequires:  python-zope.interface
#BuildRequires:  python-zope.testing
Requires(post): update-alternatives
Requires(postun): update-alternatives
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
%if 0%{?suse_version} && 0%{?suse_version} <= 1110
%{!?python_sitelib: %global python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%else
BuildArch:      noarch
%endif

%description
This package provides a flexible test runner with layer support.

%prep
%setup -q -n zope.testrunner-%{version}
sed -i "s/zope-testrunner =/zope-testrunner-%{py_ver} =/" setup.py

%build
python setup.py build

%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}
ln -s  %{_bindir}/zope-testrunner-%{py_ver} %{buildroot}%{_bindir}/zope-testrunner
# Remove duplicate files
%fdupes -s %{buildroot}%{python_sitelib}

#NOTE(saschpe): Check failing tests
#%check
#python setup.py test

%pre
# Since /usr/bin/pybabel became ghosted to be used with update-alternatives, we have to get rid
# of the old binary resulting from the non-update-alternativies-ified package:
[[ ! -L %{_bindir}/zope-testrunner ]] && rm -f %{_bindir}/zope-testrunner
exit 0

%post
update-alternatives --install %{_bindir}/zope-testrunner zope-testrunner %{_bindir}/zope-testrunner-%{py_ver} 20

%preun
if [ $1 -eq 0 ] ; then
    update-alternatives --remove zope-testrunner %{_bindir}/zope-testrunner-%{py_ver}
fi

%files
%defattr(-,root,root,-)
%doc LICENSE.rst README.rst
%ghost %{_bindir}/zope-testrunner
%{_bindir}/zope-testrunner-%{py_ver}
%{python_sitelib}/*

%changelog
openSUSE Build Service is sponsored by