File php5-pear-Horde_Cache.spec of Package php5-pear-Horde_Cache
#
# spec file for package php5-pear-Horde_Cache
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
# Copyright (c) 2011 Ralf Lang.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Summary: Horde Caching API
License: LGPL-2.1
Group: Development/Libraries/PHP
Name: php5-pear-Horde_Cache
%define pear_name Horde_Cache
%define pear_sname horde_cache
Version: 2.0.1
Release: 0
Source0: http://pear.horde.org/get/Horde_Cache-%{version}.tgz
Source1: COPYING
BuildRoot: %{_tmppath}/%{name}-%{version}-build
Url: http://pear.horde.org/package/Horde_Cache
Requires: php >= 5.3.3
BuildRequires: php >= 5.3.3
BuildRequires: php-pear >= 1.7.0
Requires: php5-pear-Horde_Db >= 2.0.0
Requires: php5-pear-Horde_Log >= 2.0.0
Suggests: php5-pear-Horde_Memcache >= 2.0.0
Requires: php-pear >= 1.7.0
Requires: php5-pear-Horde_Exception >= 2.0.0
Requires: php5-pear-Horde_Util >= 2.0.0
BuildRequires: php5-pear-channel-horde
Requires: php5-pear-channel-horde
BuildArch: noarch
%if 0%{?sles_version} == 11
BuildRequires: php53-devel
%else
BuildRequires: php-macros
%endif
# Fix for renaming (package convention)
Provides: pear-%{pear_sname} = %{version}
Provides: php-pear-%{pear_sname} = %{version}
Provides: php5-pear-%{pear_sname} = %{version}
Obsoletes: pear-%{pear_sname} < %{version}
Obsoletes: php-pear-%{pear_sname} < %{version}
Obsoletes: php5-pear-%{pear_sname} < %{version}
%description
This package provides a simple, functional caching API, with the option to
store the cached data on the filesystem, in one of the PHP opcode cache
systems (APC, eAcclerator, XCache, or Zend Performance Suite's content
cache), memcached, or an SQL table.
%prep
%setup -c
%build
%install
%{__mv} package*.xml %{pear_name}-%{version}
cd %{pear_name}-%{version}
PHP_PEAR_PHP_BIN="$(which php) -d memory_limit=50m"
%{__mkdir_p} %{buildroot}%{php_peardir}/.channels/
%{__cp} %{php_peardir}/.channels/pear.horde.org.reg %{buildroot}%{php_peardir}/.channels/
%{__pear} -v \
-d doc_dir=/doc \
-d bin_dir=%{_bindir} \
-d data_dir=%{php_peardir}/data \
-d test_dir=%{php_peardir}/tests \
install --offline --nodeps -R "%{buildroot}" package.xml
%{__install} -D -m 0644 package.xml %{buildroot}%{php_pearxmldir}/%{pear_name}.xml
%{__install} -D -m 0644 %{SOURCE1} %{buildroot}%{_docdir}/%{name}/COPYING
%{__rm} -rf %{buildroot}/{doc,tmp}
%{__rm} -rf %{buildroot}%{php_peardir}/.{filemap,lock,registry,channels,depdb,depdblock}
cd ..
%php_pear_gen_filelist
%clean
rm -rf %{buildroot}
%post
if [ "$1" = "1" ]; then
%{__pear} install --nodeps --soft --force --register-only %{php_pearxmldir}/%{pear_name}.xml
fi
if [ "$1" = "2" ]; then
%{__pear} upgrade --offline --register-only %{php_pearxmldir}/%{pear_name}.xml
fi
%postun
if [ "$1" = "0" ]; then
%{__pear} uninstall --nodeps --ignore-errors --register-only pear.horde.org/%{pear_name}
fi
%files -f %{name}.files
%defattr(-,root,root)
%{_docdir}/%{name}
%changelog