File libuv.spec of Package libuv

#
# spec file for package libuv
#
# Copyright (c) 2015 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%define somajor 1
Name:           libuv
Version:        1.4.0
Release:        0
Summary:        Cross-platform asychronous I/O
License:        MIT
Group:          Development/Libraries/C and C++
Url:            https://github.com/libuv/libuv
Source0:        https://github.com/libuv/libuv/archive/v%{version}.tar.gz
BuildRequires:  autoconf
BuildRequires:  automake
BuildRequires:  libtool
BuildRequires:  pkg-config
BuildRoot:      %{_tmppath}/%{name}-%{version}-build

%description
libuv is a multi-platform support library with a focus on asynchronous I/O. It
was primarily developed for use by Node.js, but it's also used by Mozilla's
Rust language, Luvit, Julia, pyuv, and others.

%package     -n libuv%{somajor}
Summary:        Cross-platform asychronous I/O
Group:          System/Libraries

%description -n libuv%{somajor}
libuv is a multi-platform support library with a focus on asynchronous I/O. It
was primarily developed for use by Node.js, but it's also used by Mozilla's
Rust language, Luvit, Julia, pyuv, and others.

%package        devel
Summary:        Development libraries for libuv
Group:          Development/Libraries/C and C++
BuildRequires:  glibc-devel
Requires:       libuv%{somajor} = %{version}

%description    devel
Development files for libuv

libuv is a multi-platform support library with a focus on asynchronous I/O. It
was primarily developed for use by Node.js, but it's also used by Mozilla's
Rust language, Luvit, Julia, pyuv, and others.

%prep
%setup -q
sh autogen.sh

%build
%configure --disable-static
make %{?_smp_mflags}

%install
%make_install
find %{buildroot} -type f -name "*.la" -delete -print

%check
# Tests sadly fail
#make %{?_smp_mflags} check

%post -n libuv%{somajor} -p /sbin/ldconfig

%postun -n libuv%{somajor} -p /sbin/ldconfig

%files -n libuv%{somajor}
%defattr(-,root,root)
%{_libdir}/libuv.so.%{somajor}*

%files devel
%defattr(-,root,root)
%doc AUTHORS CONTRIBUTING.md ChangeLog LICENSE README.md
%{_libdir}/libuv.so
%{_includedir}/uv*
%{_libdir}/pkgconfig/libuv.pc

%changelog
openSUSE Build Service is sponsored by