File kdevelop4.spec of Package kdevelop4.5253

#
# spec file for package kdevelop4
#
# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           kdevelop4
Version:        4.7.3
Release:        0
Summary:        Integrated Development Environment for the X Window System, Qt, KDE, and GNOME
License:        GPL-3.0+
Group:          Development/Tools/IDE
Url:            http://www.kdevelop.org
Source0:        http://download.kde.org/stable/kdevelop/%{version}/src/kdevelop-%{version}.tar.bz2
Source1:        missing-translations.tar.xz
BuildRequires:  fdupes
# SLE12 doesn't have kdebase4-workspace[-devel]
%if 0%{?suse_version} != 1315 || 0%{?is_opensuse}
BuildRequires:  kdebase4-workspace-devel
%else
BuildRequires:  libkde4-devel
%endif
BuildRequires:  libkdevplatform-devel >= 1.7.3
BuildRequires:  libqjson-devel
# Catch 13.2, but not Leap nor SLE12
%if 0%{?suse_version} <= 1320 && ! 0%{?is_opensuse} && 0%{?suse_version} != 1315
BuildRequires:  okteta-devel
%endif
BuildRequires:  valgrind-devel
BuildRequires:  xz
Requires:       %{name}-lang = %{version}
Requires:       kdevelop4-cpp-parser
Requires:       libktexteditor
# The kdevelop c++ parser is better for the moment
Recommends:     kdevelop4-plugin-cppsupport
Recommends:     cmake
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
Requires(post):     shared-mime-info
Requires(postun):   shared-mime-info
%kde4_runtime_requires

%description
An integrated development environment (IDE) that allows you to write
programs for the X Window System, the Qt library, or KDE. It includes a
documentation browser, a source code editor with syntax highlighting, a
GUI for the compiler, and much more.

%package devel
Summary:        Integrated Development Environment: Build Environment
License:        GPL-2.0+
Group:          Development/Tools/IDE
Requires:       kdevelop4 = %{version}

%description devel
An integrated development environment (IDE) that allows you to write
programs for the X Window System, the Qt library, or KDE. It includes a
documentation browser, a source code editor with syntax highlighting, a
GUI for the compiler, and much more.

%package doc
Summary:        KDE Integrated Development Environment: Documentation
License:        GPL-2.0+
Group:          Development/Tools/IDE
Requires:       kdevelop4 = %{version}

%description doc
An integrated development environment (IDE) that allows you to write
programs for the X Window System, the Qt library, or KDE. It includes a
documentation browser, a source code editor with syntax highlighting, a
GUI for the compiler, and much more.

%package -n kdevelop4-plugin-cppsupport
Summary:        C++ Language support plugin
License:        GPL-2.0+
Group:          Development/Tools/IDE
Requires:       kdevelop4 = %{version}
Provides:       kdevelop4-cpp-parser
Conflicts:      otherproviders(kdevelop4-cpp-parser)

%description -n kdevelop4-plugin-cppsupport
This package provides the C++ support for KDevelop.
There is also an experimental version available using clang.
If you would like to try that out install kdevelop4-plugin-clang instead

%lang_package
%prep
%setup -q -n kdevelop-%{version}
%if 0%{?suse_version} <= 1320 && !0%{?is_opensuse}
# fix build with older cmake versions (i.e. on 13.2 and below) by
# readding "cmake_policy(SET CMP0002 OLD)" to po/CMakeLists.txt
# (was in there before but has been removed in 4.7.3)
sed -i -e "1s/^/cmake_policy(SET CMP0002 OLD)\n/" po/CMakeLists.txt
%endif

# some translation files are missing in 4.7.3
tar xJf %{S:1}

%build
  %cmake_kde4 -d build
  %make_jobs

%install
  %kde4_makeinstall -C build
  %kde_post_install

  %fdupes -s %{buildroot}

  %find_lang kdevcmake %{name}.lang
  %find_lang kdevcmakebuilder %{name}.lang
  %find_lang kdevcpp %{name}.lang
  %find_lang kdevcustombuildsystem %{name}.lang
  %find_lang kdevcustommake %{name}.lang
  %find_lang kdevelop %{name}.lang
  %find_lang kdevexecuteplasmoid %{name}.lang
  %find_lang kdevformatters %{name}.lang
  %find_lang kdevgdb %{name}.lang
  %find_lang kdevghprovider %{name}.lang
  %find_lang kdevkdeprovider %{name}.lang
  %find_lang kdevmakebuilder %{name}.lang
  %find_lang kdevmanpage %{name}.lang
  %find_lang kdevninja %{name}.lang
  %find_lang kdevokteta %{name}.lang
  %find_lang kdevqthelp %{name}.lang
  %find_lang plasma_applet_kdevelopsessions %{name}.lang
  %find_lang plasma_runner_kdevelopsessions %{name}.lang

%post
/sbin/ldconfig
%mime_database_post

%postun
/sbin/ldconfig
%mime_database_postun

%files lang -f %{name}.lang
%defattr(-,root,root)
%exclude %{_kde4_htmldir}/en/kdevelop/

%files devel
%defattr(-,root,root)
%{_kde4_appsdir}/cmake/modules/FindKDevelop.cmake
%{_kde4_includedir}/kdevelop/

%files doc
%defattr(-,root,root,-)
%doc %lang(en) %{_kde4_htmldir}/en/kdevelop/

%files -n kdevelop4-plugin-cppsupport
%defattr(-,root,root)
%{_kde4_servicesdir}/kdevcppsupport.desktop
%{_kde4_modulesdir}/kdevcpplanguagesupport.so
%{_kde4_libdir}/libkdev4cppduchain.so
%{_kde4_libdir}/libkdev4cppparser.so
%{_kde4_libdir}/libkdev4cpprpp.so
%{_kde4_appsdir}/kdevcppsupport/

%files
%defattr(-,root,root)
%doc AUTHORS COPYING COPYING.LIB
%dir %{_kde4_appsdir}/plasma
%dir %{_kde4_appsdir}/plasma/plasmoids

%{_kde4_applicationsdir}/kdevelop.desktop
%{_kde4_applicationsdir}/kdevelop_ps.desktop

%{_kde4_appsdir}/kdevappwizard/
%{_kde4_appsdir}/kdevcodegen/
%{_kde4_appsdir}/kdevcustommakemanager/
%{_kde4_appsdir}/kdevelop/
%{_kde4_appsdir}/kdevfiletemplates/
%{_kde4_appsdir}/kdevgdb/
%{_kde4_appsdir}/kdevmanpage/
# Catch 13.2, but not Leap nor SLE12
%if 0%{?suse_version} <= 1320 && ! 0%{?is_opensuse} && 0%{?suse_version} != 1315
%{_kde4_appsdir}/kdevokteta/
%endif
%{_kde4_appsdir}/plasma/plasmoids/kdevelopsessions/
%{_kde4_appsdir}/plasma/services/org.kde.plasma.dataengine.kdevelopsessions.operations

%{_kde4_bindir}/kdevelop
%{_kde4_bindir}/kdevelop!

%{_kde4_configdir}/kdeveloprc
%{_kde4_configdir}/kdevelop-qthelp.knsrc

%{_kde4_datadir}/mime/packages/kdevelop.xml

%{_kde4_iconsdir}/*

%{_kde4_libdir}/libkdev4cmakecommon.so
%{_kde4_libdir}/libkdevcompilerprovider.so

%{_kde4_modulesdir}/kcm_kdev*.so
%{_kde4_modulesdir}/kdev*.so
%{_kde4_modulesdir}/krunner_kdevelopsessions.so
%{_kde4_modulesdir}/plasma_engine_kdevelopsessions.so
%{_kde4_servicesdir}/kcm_kdev*
%{_kde4_servicesdir}/kdev*
%{_kde4_servicesdir}/plasma-*-kdev*.desktop

# These files are now provided by kdevelop4-plugin-cppsupport
%exclude %{_kde4_servicesdir}/kdevcppsupport.desktop
%exclude %{_kde4_modulesdir}/kdevcpplanguagesupport.so
%exclude %{_kde4_libdir}/libkdev4cppduchain.so
%exclude %{_kde4_libdir}/libkdev4cppparser.so
%exclude %{_kde4_libdir}/libkdev4cpprpp.so
%exclude %{_kde4_appsdir}/kdevcppsupport/

%changelog
openSUSE Build Service is sponsored by