File python-blosc.spec of Package python-blosc

#
# spec file for package python-blosc
#
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%{?!python_module:%define python_module() python-%{**} python3-%{**}}
Name:           python-blosc
Version:        1.5.1
Release:        0
Summary:        Blosc data compressor for Python
License:        MIT
Group:          Development/Languages/Python
Url:            http://www.blosc.org/
Source:         https://files.pythonhosted.org/packages/source/b/blosc/blosc-%{version}.tar.gz
BuildRequires:  blosc-devel
BuildRequires:  gcc-c++
BuildRequires:  fdupes
BuildRequires:  python-rpm-macros
BuildRequires:  %{python_module devel}
BuildRequires:  %{python_module setuptools}
BuildRequires:  %{python_module numpy-devel}
Requires:       blosc-devel
Requires:       python-numpy
ExclusiveArch:  %ix86 x86_64
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
%python_subpackages

%description
Blosc is a high performance compressor optimized for binary data in
Python.

%prep
%setup -q -n blosc-%{version}

%build
export CFLAGS="%{optflags}"
%python_exec setup.py build_ext --inplace --blosc=%{_prefix}

%install
%python_exec setup.py install -O1 --skip-build --force --root=%{buildroot} --prefix=%{_prefix} --blosc=%{_prefix}
%python_expand %fdupes %{buildroot}%{$python_sitearch}

%files %{python_files}
%defattr(-,root,root,-)
%doc ANNOUNCE.rst README.rst LICENSES/*.txt RELEASE_NOTES.rst
%{python_sitearch}/blosc-%{version}-py*.egg-info
%{python_sitearch}/blosc/

%changelog
openSUSE Build Service is sponsored by