File python-docopt.spec of Package python-docopt

#
# spec file for package python-docopt
#
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%{?!python_module:%define python_module() python-%{**} python3-%{**}}
Name:           python-docopt
Version:        0.6.2
Release:        0
Summary:        Pythonic argument parser, that will make you smile
License:        MIT
Group:          Development/Languages/Python
Url:            http://docopt.org
Source:         https://files.pythonhosted.org/packages/source/d/docopt/docopt-%{version}.tar.gz
BuildRequires:  fdupes
BuildRequires:  python-rpm-macros
BuildRequires:  %{python_module devel}
BuildRequires:  %{python_module setuptools}
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildArch:      noarch
%python_subpackages

%description
docopt creates beautiful command-line interfaces.

Isn't it awesome how optparse and argparse generate help
messages based on your code?!

Hell no!  You know what's awesome?  It's when the option parser is
generated based on the beautiful help message that you write yourself!
This way you don't need to write this stupid repeatable parser-code,
and instead can write only the help message--the way you want it.

docopt helps you create most beautiful command-line interfaces
easily.

%prep
%setup -q -n docopt-%{version}

# Fix wrong-script-interpreter
sed -i "s|#! /usr/bin/env python||" examples/git/git.py

%build
%python_build

%install
%python_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}

%files %{python_files}
%defattr(-,root,root,-)
%doc LICENSE-MIT README.rst
%doc examples/
%{python_sitelib}/*

%changelog
openSUSE Build Service is sponsored by