File gc.spec of Package gc

#
# spec file for package gc
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#



Name:           gc
Version:        7.1.9.6
Release:        1
%define src_ver 7.2alpha6
Group:          Development/Libraries/C and C++
License:        BSD 3-Clause
URL:            http://www.hpl.hp.com/personal/Hans_Boehm/gc/
Summary:        A garbage collector for C and C++
Source:         %{name}-%{src_ver}.tar.bz2
Patch0:         %{name}-build.patch
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildRequires:  gcc-c++ pkg-config

%description
The Boehm-Demers-Weiser conservative garbage collector can be used as a
garbage collecting replacement for C malloc or C++ new. It allows you
to allocate memory basically as you normally would, without explicitly
deallocating memory that is no longer useful. The collector
automatically recycles memory when it determines that it can no longer
be otherwise accessed.

%package -n libgc1
Summary:        A garbage collector for C and C++
Group:          System/Libraries
# bug437293
%ifarch ppc64
Obsoletes:      boehm-gc-64bit
%endif
#

%description -n libgc1
The Boehm-Demers-Weiser conservative garbage collector can be used as a
garbage collecting replacement for C malloc or C++ new. It allows you
to allocate memory basically as you normally would, without explicitly
deallocating memory that is no longer useful. The collector
automatically recycles memory when it determines that it can no longer
be otherwise accessed.

%package devel
Summary:        A garbage collector for C and C++
Group:          Development/Libraries/C and C++
Provides:       gc:/usr/include/gc/gc.h
Requires:       libgc1 = %version, glibc-devel

%description devel
The Boehm-Demers-Weiser conservative garbage collector can be used as a
garbage collecting replacement for C malloc or C++ new. It allows you
to allocate memory basically as you normally would, without explicitly
deallocating memory that is no longer useful. The collector
automatically recycles memory when it determines that it can no longer
be otherwise accessed.

%prep
%setup -q -n %{name}-%{src_ver}
%patch0 -p1

%build
%{suse_update_config -f}
autoreconf -fi
%{__libtoolize} -f
%configure --disable-static --with-pic --enable-cplusplus
make %{?_smp_mflags}

%install
make DESTDIR=$RPM_BUILD_ROOT install
rm -fr $RPM_BUILD_ROOT/usr/share/gc	# docs
%{__rm} -f %{buildroot}%{_libdir}/*.la

%check
make check

%post -n libgc1 -p /sbin/ldconfig

%postun -n libgc1 -p /sbin/ldconfig

%files -n libgc1
%defattr(-, root, root)
%doc README.QUICK doc/README*
%{_libdir}/lib*.so.*

%files devel
%defattr(-, root, root)
%doc doc/[a-z]*
%{_libdir}/lib*.so
%{_libdir}/pkgconfig/*.pc
%{_includedir}/*

%changelog
openSUSE Build Service is sponsored by