File gc.spec of Package gc

#
# spec file for package gc (Version 6.6)
#
# Copyright (c) 2009 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

# norootforbuild


Name:           gc
Version:        6.6
Release:        138
AutoReqProv:    on
# bug437293
%ifarch ppc64
Obsoletes:      boehm-gc-64bit
%endif
#
Group:          Development/Libraries/C and C++
License:        BSD 3-Clause
Url:            http://www.hpl.hp.com/personal/Hans_Boehm/gc/
Summary:        A garbage collector for C and C++
Source:         %{name}%{version}.tar.bz2
#Patch:        %{name}-%{version}-shared.diff
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildRequires:  gcc-c++
Patch:          gcc4.patch
Patch1:         configure.patch
Patch2:         gc.atomic-locks.patch

%description
The Boehm-Demers-Weiser conservative garbage collector can be used as a
garbage collecting replacement for C malloc or C++ new. It allows you
to allocate memory basically as you normally would, without explicitly
deallocating memory that is no longer useful. The collector
automatically recycles memory when it determines that it can no longer
be otherwise accessed.



Authors:
--------
    Hans-J. Boehm
    Alan J. Demers

%package devel
License:        BSD 3-Clause
Summary:        A garbage collector for C and C++
Group:          Development/Libraries/C and C++
Provides:       gc:/usr/include/gc/gc.h
Requires:       gc = %{version} glibc-devel
AutoReqProv:    on

%description devel
The Boehm-Demers-Weiser conservative garbage collector can be used as a
garbage collecting replacement for C malloc or C++ new. It allows you
to allocate memory basically as you normally would, without explicitly
deallocating memory that is no longer useful. The collector
automatically recycles memory when it determines that it can no longer
be otherwise accessed.



Authors:
--------
    Hans-J. Boehm
    Alan J. Demers

%prep
%setup -q -n %name%version
%patch
%patch1
%patch2 -p1

%build
#%{suse_update_config -f}
#autoreconf -fi
#%{__libtoolize} -f
%configure --disable-static --with-pic --enable-cplusplus
%{__make} %{?jobs:-j%jobs}

%install
make DESTDIR=$RPM_BUILD_ROOT install
rm -fr $RPM_BUILD_ROOT/usr/share/gc	# docs
%{__rm} -f %{buildroot}%{_libdir}/*.la

%check
make check

%clean
rm -rf $RPM_BUILD_ROOT

%post -p /sbin/ldconfig

%postun -p /sbin/ldconfig

%files
%defattr(-, root, root)
%doc README.QUICK doc/README*
%{_libdir}/lib*.so.*

%files devel
%defattr(-, root, root)
%doc doc/[a-z]*
%{_libdir}/lib*.so
%{_includedir}/*

%changelog
* Thu Apr 02 2009 crrodriguez@suse.de
- remove static libraries and "la" files
- run make check
* Wed Dec 10 2008 olh@suse.de
- use Obsoletes: -XXbit only for ppc64 to help solver during distupgrade
  (bnc#437293)
* Tue Nov 11 2008 olh@suse.de
- use gcc built-in atomic functions, to fix w3m build
* Thu Oct 30 2008 olh@suse.de
- obsolete old -XXbit packages (bnc#437293)
* Mon Feb 25 2008 crrodriguez@suse.de
- fix library-without-ldconfig-postin errors
* Wed Nov 21 2007 uli@suse.de
- implicit malloc() redirection breaks some apps (bug #335123)
* Sat May 26 2007 ro@suse.de
- split off devel package
* Mon Jan 30 2006 uli@suse.de
- enabled malloc redirection, C++ support
- fixed shared libs
* Wed Jan 25 2006 mls@suse.de
- converted neededforbuild to BuildRequires
* Wed Jan 11 2006 uli@suse.de
- initial package
openSUSE Build Service is sponsored by