File global.spec of Package global

#
# spec file for package global (Version 5.5)
#
# Copyright (c) 2007 SUSE LINUX Products GmbH, Nuernberg, Germany.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

# norootforbuild

Name:           global
BuildRequires:  krb5-devel openssl-devel postgresql-devel
License:        Any permissive
Group:          Development/Tools/Navigators
Autoreqprov:    on
Summary:        Common Source Code Tag System
Version:        5.5
Release:        1
URL:            http://www.gnu.org/software/global/
Source:         %{name}-%{version}.tar.bz2
Patch:          %{name}-%{version}.diff
Patch1:         %{name}-%{version}-gcc.diff
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
PreReq:         %install_info_prereq

%description
GLOBAL is a common source code tag system for C, C++, Yacc, and Java.
You can locate the specified function in source files and move there
easily. It is useful to hack a large project containing many
subdirectories or many main() functions like MH, X, or Linux kernel.



Authors:
--------
    Shigio Yamaguchi <shigio@tamacom.com>

%prep
%setup -q
%patch
%patch1

%build
%{?suse_update_config:%{suse_update_config -f}}
aclocal
automake
autoconf
CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-lssl" ./configure \
                        --prefix=/usr \
			--with-postgres=/usr \
			--mandir=%{_mandir} \
			--infodir=%{_infodir}
make

%install
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT
install -d -m 755 $RPM_BUILD_ROOT/{usr/share/emacs/site-lisp,etc}
mv $RPM_BUILD_ROOT/%{_docdir}/%{name}/gtags.el $RPM_BUILD_ROOT/usr/share/emacs/site-lisp/
mv $RPM_BUILD_ROOT/%{_docdir}/%{name}/gtags.conf $RPM_BUILD_ROOT/etc/

%clean
rm -rf $RPM_BUILD_ROOT

%post
%install_info --info-dir=%{_infodir} %{_infodir}/%{name}.info.gz

%postun
%install_info_delete --info-dir=%{_infodir} %{_infodir}/%{name}.info.gz

%files
%defattr(-,root,root)
%dir /usr/share/emacs
%dir /usr/share/emacs/site-lisp
%config(noreplace) /etc/gtags.conf
/usr/bin/*
%doc %{_docdir}/%{name}
%doc %{_mandir}/man1/*
%doc %{_infodir}/*.info*
/usr/share/emacs/site-lisp/gtags.el
/usr/share/gtags

%changelog
* Mon May 07 2007 - anosek@suse.cz
- updated to version 5.5
  * gtags-parser: Support of 'enum' (java).
  * gtags.el: Changed to work without event-point function.
* Fri Mar 30 2007 - rguenther@suse.de
- add emacs site-lisp directories
* Tue Mar 13 2007 - anosek@suse.cz
- updated to version 5.4.1
  * htags: Added new --item-order option.
  Specify order of items in the top page. The spec is a string
  consists of item signs in order. Each sign means as follows:
  c: caution, s: search form, m: mains, d: definition, f: files.
  The default is 'csmdf'.
  * fixed: htags: didn't extract some '#include' correctly.
* Mon Jan 29 2007 - anosek@suse.cz
- updated to 5.4
  * Further compression of tag file (format version 5).
  Though new global can read older tag file since version-5.0,
  older global cannot read new format.
  * global: Improved performance when the -x option
  is not specified.
  * globash.rc: Added new option -l for tag search command
  (x,r,s,g,P,I,f). This option invokes less(1) directly
  without tag stack.
  * global: Changed not to locate other symbols (-s)
  in GTAGSLIBPATH. This is the original specification of GLOBAL.
  * global: Stop sorting when the -I(--idutils) option specified.
  The output of gid(idutils) is sorted by the suitable way.
  Though the order is slightly differ from global(1), it need
  not be sorted again.
  * global:  Added new option -O(--only-other).
  * htags: Added some new options and new arguments which are
  synonyms of config variable. This decreases dependence
  on configration file
  * gtags.el:
    - Shorten path names in [GTAGS SELECT MODE]:
  If project directory is specified using
  'gtags-visit-rootdir', gtags.el print path using the relative
  path name from the project directory, else print absolute
  path name.
    - Support dynamic completing-read of tag name.
  gtags-make-complete-list is deprecated. You can enjoy
  tag name completetion without invoking this command.
* Fri Sep 08 2006 - anosek@suse.cz
- updated to 5.2
  * htags: Added new options:
    - -h(--func-header) option.
    - -I(--icon) option.
    - -T(table-flist[=fields]) option.
  * htags: Always enable 'Grep pattern' form when the -f(--form)
  option specified. Removed config variable 'enable_grep'
  since it became meaningless. Instead, added a new variable
  'disable_grep'.
  * htags: Removed config variable 'enable_grep' since it is meaningless.
  Instead, added a new variable 'disable_grep'.
  * Changed the priority about the --result option to make the format
  specification easy. The --result option is given to priority more
  than the -t and -x option. (This option appeared in version 5.0.)
  * Added new program 'gtags-cscope'.
  Gtags-cscope is a pseudo cscope which implements the line-oriented
  interface. You can use this command for various clients instead of
  true cscope.
  * Moved to new tag format. (GTAGS, GRTAGS, GSYMS, GPATH)
  Hereafter, older tag format is not supported.
  Compact format was progressively canceled with the adoption of
  the new tag format. The -c(--compact) option of gtags(1)
  was removed.
* Wed Jan 25 2006 - mls@suse.de
- converted neededforbuild to BuildRequires
* Mon Oct 10 2005 - mmarek@suse.cz
- update to 4.8.7
* Mon Aug 01 2005 - anicka@suse.cz
- update to 4.8.6
* Thu Apr 21 2005 - postadal@suse.cz
- fixed for gcc 4.0
* Fri Jan 21 2005 - postadal@suse.cz
- updated to version 4.8.2
* Mon Oct 25 2004 - postadal@suse.cz
- switched heimdal-* to kerberos-devel-packages in #needforbuild
* Thu Aug 12 2004 - postadal@suse.cz
- updated to version 4.7.2
* Fri Feb 13 2004 - postadal@suse.cz
- updated to version 4.7
- added gtags.conf config file
* Sat Jan 10 2004 - adrian@suse.de
- build as user
* Thu Nov 20 2003 - ro@suse.de
- added heimdal-lib to neededforbuild (postgres)
* Mon Jul 28 2003 - postadal@suse.cz
- updated to version 4.6
  * the default value of the config variable 'definition_header' was changed
  to 'no', because the definition header is unsightly according to the place,
  especially in class definition
  * support for PHP language
  * support for SCM_DEFINE macro which is part of guile-snarf
  * added 'right' as a value of config variable 'definition_header'
* Thu Apr 24 2003 - ro@suse.de
- fix install_info --delete call and move from preun to postun
* Thu Feb 13 2003 - mmj@suse.de
- Use %%install_info_macro [#23413]
* Thu Jan 09 2003 - postadal@suse.cz
- updated to version 4.5.1
  * btreeop was replaced with gtags and was removed
  * a lot of new options and bug fixes
* Wed Apr 03 2002 - postadal@suse.cz
- fixed to compile with autoconf-2.53 (fix DJGPP conditional)
- gozilla return to GLOBAL
- fixed security hole in the CGI program generated by htags(1)
- path conversion optimized and bug fixed
* Wed Jan 16 2002 - cihlar@suse.cz
- update to version 4.2:
  * bug fixes
  * nvi-1.81.5 support added
  * DJGPP support added
  * Documentation added
* Thu Nov 29 2001 - cihlar@suse.cz
- update to version 4.2:
  * bug fixes and improvements
  * postgres support added
* Wed Jul 25 2001 - cihlar@suse.cz
- update to version 4.1
* Thu Nov 02 2000 - cihlar@suse.cz
- update to version 4.0.1
- bzipped sources
* Thu Aug 10 2000 - cihlar@suse.cz
- added BuildRoot
- added gtags.el
- fixed bug in htags
* Mon Jun 19 2000 - kasal@suse.cz
- Added Group: tag.
* Thu Feb 03 2000 - kasal@suse.cz
- Oops!  I forgot to include gozilla to the filelist.
* Mon Jan 31 2000 - kasal@suse.cz
- upgraded to version 3.55, fixed
- don't require emacs (fixes Bug #281)
- added gozilla
- /usr/man -> /usr/share/man
* Mon Sep 13 1999 - bs@suse.de
- ran old prepare_spec on spec file to switch to new prepare_spec.
* Mon Nov 16 1998 - ro@suse.de
- use libdb for now (glibc-2.0)
- include sys/types.h in global.c
* Mon Oct 05 1998 - ro@suse.de
- use libdb1 and usr/include/db1 for glibc
* Fri Jul 17 1998 - bs@suse.de
- don't include gctags (is in ge_exec).
* Fri Jun 05 1998 - rj@suse.de
- new package (version 2.24)
openSUSE Build Service is sponsored by