File cim-schema.spec of Package cim-schema

#
# spec file for package cim-schema
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

# norootforbuild

BuildRequires:  unzip

Name:           cim-schema
Url:            http://www.dmtf.org/
Summary:        Common Information Model (CIM) Schema
Version:        2.29.1
Release:        1
Group:          System/Management
License:        Reproducable (c) 1998-2010 DMTF
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
Source0:        http://www.dmtf.org/standards/cim/cim_schema_v2291/cim_schema_%{version}Final-MOFs.zip
Source1:        loadmof.sh
Source2:        rmmof.sh
BuildArch:      noarch

%description
Common Information Model (CIM) is a model for describing overall
management information in a network or enterprise environment. CIM
consists of a specification and a schema. The specification defines the
details for integration with other management models. The schema
provides the actual model descriptions.



Authors:
--------
    DTMF <http://www.dmtf.org/about/contact>

%prep
%setup -c -n %{name}-%{version}

%build

%install
MOFDIR=/usr/share/mof
CIMDIR=$MOFDIR/cimv%{version}
for i in `find . -name "*.mof"`; do
  perl -p -i -e 's/\r//g' $i
done
install -d $RPM_BUILD_ROOT/$CIMDIR
perl -p -i -e 's/\\/\//g' cim*.mof
echo "" >> qualifiers.mof
echo "// Optional Qualifiers: " >> qualifiers.mof
echo "" >> qualifiers.mof
cat qualifiers_optional.mof >> qualifiers.mof
%__rm qualifiers_optional.mof
chmod -R go-wx .
chmod -R a+rX .
%__mv * $RPM_BUILD_ROOT/$CIMDIR/
ln -s cimv%{version} $RPM_BUILD_ROOT/$MOFDIR/cim-current
pushd $RPM_BUILD_ROOT/$CIMDIR/
ln -s cim*.mof CIM_Schema.mof
popd
install -d $RPM_BUILD_ROOT/usr/bin
install -m 755 %{S:1} $RPM_BUILD_ROOT/usr/bin/ 
install -m 755 %{S:2} $RPM_BUILD_ROOT/usr/bin/ 
perl -p -i -e 's~^#pragma include ("qualifiers_optional\.mof")~\/\/#pragma include ("qualifiers_optional\.mof")~g' $RPM_BUILD_ROOT/$MOFDIR/cim-current/CIM_Schema.mof
perl -p -i -e \
	's~^#pragma include \("qualifiers_optional\.mof"\)~\/\/#pragma include ("qualifiers_optional\.mof")~g' \
	$RPM_BUILD_ROOT/$MOFDIR/cim-current/CIM_Schema.mof

%clean
%__rm -rf $RPM_BUILD_ROOT

%files
%defattr(-, root, root)
%dir /usr/share/mof
%dir /usr/share/mof/cimv%{version}
/usr/share/mof/cimv%{version}/*
/usr/share/mof/cim-current
/usr/bin/loadmof.sh
/usr/bin/rmmof.sh

%changelog
openSUSE Build Service is sponsored by