File clementine.spec of Package clementine

#
# spec file for package clementine
#
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           clementine
Version:        1.3.1
Release:        0
Summary:        A cross-platform Music Player derived from Amarok 1.4
License:        GPL-3.0+
Group:          Productivity/Multimedia/Sound/Players
Url:            https://clementine-player.org/
Source:         https://github.com/clementine-player/Clementine/releases/download/%{version}/%{name}-%{version}.tar.xz
# PATCH-FIX-OPENSUSE clementine-fix-sqlite.patch -- Fix startup with default SQLite 3.12+.
Patch0:         clementine-fix-sqlite.patch
# PATCH-FEATURE-UPSTREAM udisks2-support-for-devicemanager.patch
Patch1:         udisks2-support-for-devicemanager.patch
# PATCH-FIX-UPSTREAM clementine-1.3.1-fix-library-clicks.patch -- Fix a misbehaviour while clicking on tree items, from commit b85d09c.
Patch2:         clementine-1.3.1-fix-library-clicks.patch
# Patch fix factory build, add -fPIC to moodbar build
Patch3:         clementine-moodbar-fpic.patch
# PATCH-FIX-UPSTREAM clementine-gcc7fix.patch davejplater@gmail.com -- add <funtional> to includes.
Patch4:         clementine-gcc7fix.patch
%if 0%{?suse_version} > 1325
BuildRequires:  libboost_headers-devel
%else
BuildRequires:  boost-devel
%endif
BuildRequires:  cmake
BuildRequires:  fdupes
# pkgconfig(freeglut) isn't available in openSUSE Leap 42.1 and older.
BuildRequires:  freeglut-devel
BuildRequires:  gcc-c++
BuildRequires:  gettext-tools
BuildRequires:  help2man
BuildRequires:  hicolor-icon-theme
BuildRequires:  liblastfm-devel
BuildRequires:  libqxt-devel
BuildRequires:  update-desktop-files
BuildRequires:  pkgconfig(QJson)
BuildRequires:  pkgconfig(QtCore)
BuildRequires:  pkgconfig(QtGui)
BuildRequires:  pkgconfig(QtSql)
BuildRequires:  pkgconfig(QtWebKit)
BuildRequires:  pkgconfig(cryptopp)
BuildRequires:  pkgconfig(fftw3)
BuildRequires:  pkgconfig(gio-2.0)
BuildRequires:  pkgconfig(glew)
BuildRequires:  pkgconfig(glib-2.0)
BuildRequires:  pkgconfig(gstreamer-1.0)
BuildRequires:  pkgconfig(gstreamer-app-1.0)
BuildRequires:  pkgconfig(gstreamer-audio-1.0)
BuildRequires:  pkgconfig(gstreamer-base-1.0)
BuildRequires:  pkgconfig(gstreamer-tag-1.0)
BuildRequires:  pkgconfig(libcdio)
BuildRequires:  pkgconfig(libchromaprint)
BuildRequires:  pkgconfig(libechonest)
BuildRequires:  pkgconfig(libgpod-1.0)
BuildRequires:  pkgconfig(libmtp)
BuildRequires:  pkgconfig(libnotify)
BuildRequires:  pkgconfig(libprojectM)
BuildRequires:  pkgconfig(libpulse)
BuildRequires:  pkgconfig(libsparsehash)
BuildRequires:  pkgconfig(libxml-2.0)
BuildRequires:  pkgconfig(protobuf)
BuildRequires:  pkgconfig(sqlite3)
BuildRequires:  pkgconfig(taglib) >= 1.8
Requires:       libtag1 >= 1.8
Recommends:     gstreamer-fluendo-mp3
Recommends:     sni-qt
# clementine-kde was last used in openSUSE 12.2.
# plasma_runner was dropped in Clementine 1.1.0.
Provides:       %{name}-kde = %{version}
Obsoletes:      %{name}-kde < %{version}

%description
Clementine is a modern music player and library organiser.

Clementine is a fork of Amarok 1.4, with some features rewritten to
take advantage of Qt4.

Features:
 * Search and play your local music library.
 * Listen to internet radio from Last.FM and SomaFM.
 * Edit tags on MP3 and OGG files, organise your music.
 * Cross-platform - works on GNU/Linux, Windows, and OS X.
 * Native desktop notifications.

%prep
%setup -q
%patch0 -p1
%patch1 -p1
%patch2 -p1
%patch3
%patch4
# NOTE: Build using system versions of libraries.
rm -rvf 3rdparty/taglib
#rm -rvf 3rdparty/libmygpo-qt
#rm -rvf 3rdparty/sha2

%build
%if 1 == 0
%define gcc_version 7
export CC=gcc-7
export CPP=cpp-7
export CXX=g++-7
%endif
export CFLAGS="%{optflags} -fno-strict-aliasing"
export CXXFLAGS="$CFLAGS"
%cmake \
  -DBUILD_WERROR=OFF            \
  -DUSE_SYSTEM_QXT=ON           \
  -DUSE_BUILTIN_TAGLIB=OFF      \
  -DUSE_SYSTEM_PROJECTM=ON      \
  -DBUNDLE_PROJECTM_PRESETS=OFF \
  -DENABLE_MOODBAR=ON           \
  -DENABLE_DBUS=ON
make %{?_smp_mflags}
#-fPIC
%install
%cmake_install

# Generate a man page with help2man.
mkdir -p %{buildroot}%{_mandir}/man1/
pushd %{buildroot}%{_mandir}/man1/
cp -f %{buildroot}%{_bindir}/%{name} ./
help2man --version-string="%{version}" -N -o %{name}.1 ./%{name}
rm -f %{name}
popd

%suse_update_desktop_file clementine Qt AudioVideo Audio Player

%post
%desktop_database_post
%icon_theme_cache_post

%postun
%desktop_database_postun
%icon_theme_cache_postun

%files
%defattr(-,root,root)
%doc Changelog COPYING README.md
%{_bindir}/clementine*
%{_datadir}/applications/clementine.desktop
%{_datadir}/icons/hicolor/*/apps/clementine.*
%dir %{_datadir}/appdata/
%{_datadir}/appdata/clementine.appdata.xml
%{_mandir}/man1/%{name}.1%{?ext_man}
%dir %{_datadir}/kde4/
%dir %{_datadir}/kde4/services/
%{_datadir}/kde4/services/clementine-*.protocol

%changelog
openSUSE Build Service is sponsored by