File maven-ant-plugin.spec of Package maven-ant-plugin
#
# spec file for package maven-ant-plugin
#
# Copyright (c) 2019 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
Name: maven-ant-plugin
Version: 2.4
Release: 0
Summary: Apache Maven Ant Plugin
License: Apache-2.0
Group: Development/Libraries/Java
URL: https://maven.apache.org/plugins/%{name}/
Source0: https://archive.apache.org/dist/maven/plugins/%{name}-%{version}-source-release.zip
BuildRequires: fdupes
BuildRequires: maven-local
BuildRequires: unzip
BuildRequires: mvn(org.apache.ant:ant)
BuildRequires: mvn(org.apache.maven.plugin-tools:maven-plugin-annotations)
BuildRequires: mvn(org.apache.maven.plugins:maven-plugin-plugin)
BuildRequires: mvn(org.apache.maven.plugins:maven-plugins:pom:)
BuildRequires: mvn(org.apache.maven:maven-artifact:2.2.1)
BuildRequires: mvn(org.apache.maven:maven-core)
BuildRequires: mvn(org.apache.maven:maven-model:2.2.1)
BuildRequires: mvn(org.apache.maven:maven-plugin-api)
BuildRequires: mvn(org.apache.maven:maven-project)
BuildRequires: mvn(org.apache.maven:maven-settings:2.2.1)
BuildRequires: mvn(org.codehaus.plexus:plexus-utils)
BuildRequires: mvn(xalan:xalan)
BuildRequires: mvn(xml-apis:xml-apis)
BuildArch: noarch
%description
The Ant Plugin generates build files for Ant 1.6.2 or above from the POM.
%package javadoc
Summary: Javadoc for %{name}
Group: Documentation/HTML
%description javadoc
API documentation for %{name}.
%prep
%setup -q
%build
%{mvn_build} -f \
%if %{?pkg_vcmp:%pkg_vcmp java-devel >= 9}%{!?pkg_vcmp:0}
-- -Dmaven.compiler.release=6
%endif
%install
%mvn_install
%fdupes -s %{buildroot}%{_javadocdir}
%files -f .mfiles
%license LICENSE
%doc NOTICE
%files javadoc -f .mfiles-javadoc
%license LICENSE
%changelog