File tuner.spec of Package tuner
#
# spec file for package tuner
#
# Copyright (c) 2021 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
Name: tuner
Version: 1.5.1
Release: 0
Summary: Minimalist radio station player
License: GPL-3.0-or-later
Group: Productivity/Multimedia/Sound/Players
URL: https://github.com/louis77/tuner
Source: https://github.com/louis77/tuner/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
BuildRequires: fdupes
BuildRequires: hicolor-icon-theme
BuildRequires: meson
BuildRequires: pkgconfig
BuildRequires: update-desktop-files
BuildRequires: vala >= 0.44
BuildRequires: pkgconfig(gee-0.8)
BuildRequires: pkgconfig(geocode-glib-1.0)
BuildRequires: pkgconfig(gio-2.0)
BuildRequires: pkgconfig(glib-2.0)
BuildRequires: pkgconfig(granite)
BuildRequires: pkgconfig(gstreamer-1.0)
BuildRequires: pkgconfig(gstreamer-player-1.0)
BuildRequires: pkgconfig(gtk+-3.0)
BuildRequires: pkgconfig(json-glib-1.0)
BuildRequires: pkgconfig(libgeoclue-2.0)
BuildRequires: pkgconfig(libsoup-2.4)
Recommends: %{name}-lang
Recommends: gstreamer-plugins-base
Recommends: gstreamer-plugins-good
Recommends: gstreamer-plugins-libav
Recommends: gstreamer-plugins-ugly
%description
An Internet Radio Station player for elementary OS.
%lang_package
%prep
%setup -q
%build
%meson
%meson_build
%install
%meson_install
%suse_update_desktop_file -r com.github.louis77.tuner GTK AudioVideo Audio Player
%find_lang com.github.louis77.tuner %{name}.lang
%fdupes %{buildroot}/%{_datadir}
# dirlist HiDPI icons (see: hicolor/index.theme)
touch $PWD/dir.lst
_dirlist=$PWD/dir.lst
pushd %{buildroot}
find ./ | while read _list; do
echo $_list | grep '[0-9]\@[0-9]' || continue
_path=$(echo $_list | sed 's/[^/]//')
if ! ls ${_path%/*}; then
grep -xqs "\%dir\ ${_path%/*}" $_dirlist || echo "%dir ${_path%/*}" >> $_dirlist
fi
done
popd
%files -f dir.lst
%license LICENSE
%doc README.md
%{_bindir}/com.github.louis77.tuner
%{_datadir}/applications/com.github.louis77.tuner.desktop
%{_datadir}/glib-2.0/schemas/com.github.louis77.tuner.gschema.xml
%{_datadir}/icons/hicolor/*/*/com.github.louis77.tuner.??g
%{_datadir}/metainfo/com.github.louis77.tuner.appdata.xml
%files lang -f %{name}.lang
%changelog