File perl-Email-Address.spec of Package perl-Email-Address
#
# spec file for package perl-Email-Address
#
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: perl-Email-Address
Version: 1.909
Release: 0
%define cpan_name Email-Address
Summary: (DEPRECATED) RFC 2822 Address Parsing and Creation
License: Artistic-1.0 OR GPL-1.0-or-later
Group: Development/Libraries/Perl
Url: http://search.cpan.org/dist/Email-Address/
Source0: https://cpan.metacpan.org/authors/id/R/RJ/RJBS/%{cpan_name}-%{version}.tar.gz
Source1: cpanspec.yml
BuildArch: noarch
BuildRoot: %{_tmppath}/%{name}-%{version}-build
BuildRequires: perl
BuildRequires: perl-macros
BuildRequires: perl(Test::More) >= 0.96
%{perl_requires}
%description
*ACHTUNG!* This module has a vulnerability (at
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-7686) which allows
remote attackers to cause denial of service. In other words, sometimes it
takes way too long to process certain kinds of input. Maybe someday this
will be fixed. Until then, use *Email::Address::XS* instead which has
backward compatible API.
This class implements a regex-based RFC 2822 parser that locates email
addresses in strings and returns a list of 'Email::Address' objects found.
Alternatively you may construct objects manually. The goal of this software
is to be correct, and very very fast.
%prep
%setup -q -n %{cpan_name}-%{version}
%build
%{__perl} Makefile.PL INSTALLDIRS=vendor
%{__make} %{?_smp_mflags}
%check
%{__make} test
%install
%perl_make_install
%perl_process_packlist
%perl_gen_filelist
%files -f %{name}.files
%defattr(-,root,root,755)
%doc Changes README
%license LICENSE
%changelog