File python-wsgi_intercept.spec of Package python-wsgi_intercept

#
# spec file for package python-wsgi_intercept
#
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%{?!python_module:%define python_module() python-%{**} python3-%{**}}
Name:           python-wsgi_intercept
Version:        1.5.0
Release:        0
Summary:        Installs a WSGI application in place of a real URI for testing
License:        MIT
Group:          Development/Languages/Python
Url:            https://github.com/cdent/python3-wsgi-intercept
Source:         https://pypi.io/packages/source/w/wsgi_intercept/wsgi_intercept-%{version}.tar.gz
# PATCH-FIX-OPENSUSE speilicke@suse.com -- Patching fails
Patch0:         wsgi_intercept-disable-testbogusdomain.patch
BuildRequires:  %{python_module devel}
BuildRequires:  %{python_module setuptools}
BuildRequires:  python-rpm-macros
# Test requirements:
BuildRequires:  %{python_module httplib2}
BuildRequires:  %{python_module pytest >= 2.4}
BuildRequires:  %{python_module requests >= 2.0.1}
BuildRequires:  %{python_module six}
BuildRequires:  %{python_module urllib3 >= 1.11.0}
Requires:       python-six
Recommends:     python-requests >= 2.0.1
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildArch:      noarch

%python_subpackages

%description
Testing a WSGI application normally involves starting a server at a local host
and port, then pointing your test code to that address. Instead, this library
lets you intercept calls to any specific host/port combination and redirect
them into a `WSGI application`_ importable by your test program.  Thus, you
can avoid spawning multiple processes or threads to test your Web app.

%prep
%setup -q -n wsgi_intercept-%{version}
%if 0%{?suse_version} == 1230
%patch0 -p1
%endif

%build
%python_build

%install
%python_install
rm -rf %{buildroot}%{python_sitelib}/test

%check
# skip tests trying to access google.com
py.test -k "not not_intercepted" build/

%files %{python_files}
%defattr(-,root,root,-)
%{python_sitelib}/wsgi_intercept-%{version}-py%{py_ver}.egg-info
%{python_sitelib}/wsgi_intercept

%changelog
openSUSE Build Service is sponsored by