File python3-pyside.spec of Package python3-pyside

#
# spec file for package python3-pyside
#
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%define _name      pyside
%define libprefix  lib%{_name}
%define pyname     PySide
Name:           python3-%{_name}
Version:        1.2.4
Release:        0
Summary:        PySide - python bindings for Qt
License:        LGPL-2.1+
Group:          Development/Languages/Python
Url:            http://qt-project.org/wiki/PySide
Source0:        https://pypi.python.org/packages/source/P/%{pyname}/%{pyname}-%{version}.tar.gz
Patch0:         pyside-support-python3.5.patch
# We don't need this during build and it conflicts with libqt4-devel:libopenssl_1_0_0-devel
#!BuildIgnore:  openssl
BuildRequires:  cmake
BuildRequires:  fdupes
BuildRequires:  gcc-c++
BuildRequires:  libqt4-devel >= 4.8
BuildRequires:  libshiboken-python3-devel
BuildRequires:  libxslt-devel
BuildRequires:  phonon-devel
BuildRequires:  python3-devel
BuildRequires:  python3-pyside-shiboken
BuildRequires:  python3-setuptools
Requires:       python-pyside-common

%description
The PySide project provides LGPL-licensed Python bindings for the Qt
cross-platform application and UI framework. PySide Qt bindings allow both free
open source and proprietary software development and ultimately aim to support
all of the platforms as Qt itself.

%package -n python-pyside-common
Summary:        PySide - files shared between PySide versions
Group:          Development/Languages/Python

%description -n python-pyside-common
This package contains files needed by PySide for Python 2 and Python 3.

%package devel
Summary:        PySide - python bindings for Qt
Group:          Development/Languages/Python
Requires:       %{name} = %{version}
Requires:       libqt4-devel
Requires:       libshiboken-python3-devel
# cmake can not handle both, python2 and python3 versions at the same time.
Conflicts:      python-pyside-devel

%description devel
The PySide project provides LGPL-licensed Python bindings for the Qt
cross-platform application and UI framework. PySide Qt bindings allow both free
open source and proprietary software development and ultimately aim to support
all of the platforms as Qt itself.

This package contains all the developer tools you need to create your own PyQt
applications.

%prep
%setup -q -n %{pyname}-%{version}
%patch0 -p1

%build
python%{py3_ver} setup.py egg_info
cd sources/%{_name}
%cmake -DCMAKE_BUILD_TYPE=Release \
       -DUSE_PYTHON3=1 \
       -DBUILD_TESTS=FALSE \
       -DQT_PHONON_INCLUDE_DIR=%{_includedir}/phonon
make %{?_smp_mflags}
ctest -R qtcore || true

%install
pushd sources/%{_name}/build
%makeinstall DESTDIR=%{buildroot}
# copy egg_info
cp -R %{_builddir}/%{pyname}-%{version}/%{_name}_package/%{pyname}.egg-info %{buildroot}%{python3_sitearch}/%{pyname}-%{version}-py%{py3_ver}.egg-info
mv %{buildroot}%{_libdir}/pkgconfig/%{_name}.pc %{buildroot}%{_libdir}/pkgconfig/%{_name}-py3.pc
%fdupes %{buildroot}
popd

%post   -p /sbin/ldconfig
%postun -p /sbin/ldconfig

%files
%defattr(-,root,root)
%doc sources/pyside/COPYING
%{_libdir}/%{libprefix}.*.so.*
%{python3_sitearch}/%{pyname}/
%{python3_sitearch}/%{pyname}-%{version}-py%{py3_ver}.egg-info/

%files -n python-pyside-common
%{_datadir}/%{pyname}/

%files devel
%defattr(-,root,root)
%{_includedir}/%{pyname}/
%{_libdir}/%{libprefix}.*.so
%{_libdir}/cmake/*
%{_libdir}/pkgconfig/%{_name}-*.pc

%changelog
openSUSE Build Service is sponsored by