File weston.spec of Package weston

#
# spec file for package weston
#
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           weston
%define lname	libweston0
Version:        3.0.0
Release:        0
Summary:        Wayland Reference Compositor
License:        MIT AND CC-BY-SA-3.0
Group:          System/X11/Servers
Url:            http://wayland.freedesktop.org/

#Git-Clone:	git://anongit.freedesktop.org/wayland/weston
#Git-Web:	http://cgit.freedesktop.org/wayland/weston/
Source:         http://wayland.freedesktop.org/releases/%name-%version.tar.xz
Source2:        http://wayland.freedesktop.org/releases/%name-%version.tar.xz.sig
Source3:        %name.keyring
Patch1:         0001-build-honor-results-obtained-by-pkg-config-libinput.patch
BuildRequires:  autoconf >= 2.64
BuildRequires:  automake >= 1.11
BuildRequires:  libjpeg-devel
BuildRequires:  libtool >= 2.2
BuildRequires:  libxml2-tools
BuildRequires:  pam-devel
BuildRequires:  pkgconfig
BuildRequires:  xkeyboard-config
BuildRequires:  xz
BuildRequires:  pkgconfig(cairo) >= 1.10.0
BuildRequires:  pkgconfig(cairo-egl) >= 1.11.3
BuildRequires:  pkgconfig(cairo-xcb)
BuildRequires:  pkgconfig(colord) >= 0.1.27
BuildRequires:  pkgconfig(dbus-1) >= 1.6
BuildRequires:  pkgconfig(egl)
BuildRequires:  pkgconfig(freerdp2)
BuildRequires:  pkgconfig(gbm)
BuildRequires:  pkgconfig(glesv2)
BuildRequires:  pkgconfig(lcms2)
BuildRequires:  pkgconfig(libdrm) >= 2.4.30
BuildRequires:  pkgconfig(libinput) >= 0.8.0
BuildRequires:  pkgconfig(libsystemd) >= 209
BuildRequires:  pkgconfig(libudev) >= 136
BuildRequires:  pkgconfig(libwebp)
# mtdev isn't really required - the configure check was fixed after the 3.0 release
BuildRequires:  pkgconfig(mtdev) >= 1.1.0
BuildRequires:  pkgconfig(pixman-1) >= 0.25.2
BuildRequires:  pkgconfig(wayland-client) >= 1.12.0
BuildRequires:  pkgconfig(wayland-egl)
BuildRequires:  pkgconfig(wayland-protocols) >= 1.8
BuildRequires:  pkgconfig(wayland-scanner)
BuildRequires:  pkgconfig(wayland-server) >= 1.12.0
BuildRequires:  pkgconfig(xcb)
BuildRequires:  pkgconfig(xcb-composite)
BuildRequires:  pkgconfig(xcb-shm)
BuildRequires:  pkgconfig(xcb-xfixes)
BuildRequires:  pkgconfig(xcb-xkb) >= 1.9
BuildRequires:  pkgconfig(xcursor)
BuildRequires:  pkgconfig(xkbcommon) >= 0.3.0
Requires:       vpx-tools
Requires:       xkeyboard-config

%description
Weston is the reference implementation of a Wayland compositor, and a
useful compositor in its own right. Weston has various backends that
lets it run on Linux kernel modesetting and evdev input as well as
under X11. Weston ships with a few example clients, from simple
clients that demonstrate certain aspects of the protocol to more
complete clients and a simplistic toolkit. There is also a quite
capable terminal emulator (weston-terminal) and an toy/example
desktop shell. Finally, weston also provides integration with the
Xorg server and can pull X clients into the Wayland desktop and act
as a X window manager.

%package -n libweston-3
Summary:        Weston rendering backend collection
Group:          System/Libraries

%description -n libweston-3
This subpackage contains backend renderer plugins, used by
libweston-3-0.

%package -n libweston-3-0
Summary:        The Weston compositor as a shared library
Group:          System/Libraries
Requires:       libweston-3 >= %version

%description -n libweston-3-0
The libweston library is intended for use by other compositor efforts
(projects) that want to more easily utilize Weston's internal
functionalities. Weston's own reference compositor also makes use of
this.

%package -n libweston-desktop-3-0
Summary:        The Weston compositor as a shared library
Group:          System/Libraries

%description -n libweston-desktop-3-0
libweston-desktop provides an additional level of functionality of
relevance to compositors implementing a desktop metaphor style of
graphical interface. This library API is designed around xdg_shell
functionality, providing for handling of popups, window state, and
interfacing with Xwayland.

%package devel
Summary:        Development files for Weston plugins
Group:          Development/Libraries/C and C++

%description devel
Weston is the reference implementation of a Wayland compositor, and a
useful compositor in its own right. Weston has various backends that
lets it run on Linux kernel modesetting and evdev input as well as
under X11.

This package contains all necessary include files and libraries needed
to develop plugins for Weston.

%prep
%setup -q
%patch -P 1 -p1

%build
#if [ ! -e configure ]; then
	autoreconf -fi
#fi
# Ensure people will use pkgconfig to locate headers.
# Implicit enable-libunwind would make the tests run endlessly on i586.
%configure --disable-static --includedir="%_includedir/%name" \
	--disable-setuid-install \
	--disable-libunwind
make %{?_smp_mflags}

%install
%make_install
find "%buildroot" -type f -name "*.la" -delete -print

%check
%if !0%{?qemu_user_space_build}
export XDG_RUNTIME_DIR="$PWD/xdg"
mkdir -pm go-rwx "$XDG_RUNTIME_DIR"
if ! make BACKEND=headless-backend.so check; then
	cat test-suite.log
	# make check can not pass completely without an actual screen.
	#exit 1
fi
%endif

%post   -n libweston-3-0 -p /sbin/ldconfig
%postun -n libweston-3-0 -p /sbin/ldconfig
%post   -n libweston-desktop-3-0 -p /sbin/ldconfig
%postun -n libweston-desktop-3-0 -p /sbin/ldconfig

%files
%defattr(-,root,root)
%doc COPYING README
%_bindir/w*
%_libexecdir/%name-*
%_libdir/%name/
%_datadir/%name/
%_datadir/wayland-sessions/
%_mandir/man?/*.*

%files -n libweston-3-0
%defattr(-,root,root)
%_libdir/libweston-3.so.0*

%files -n libweston-3
%defattr(-,root,root)
%_libdir/libweston-3/

%files -n libweston-desktop-3-0
%defattr(-,root,root)
%_libdir/libweston-desktop-3.so.0*

%files devel
%defattr(-,root,root)
%_includedir/%name/
%_libdir/pkgconfig/*.pc
%_libdir/libweston*.so

%changelog
openSUSE Build Service is sponsored by