File libwebkit.spec of Package libwebkit
#
# spec file for package libwebkit (Version 1.0.1)
#
# Copyright (c) 2008 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: libwebkit
Url: http://webkit.org/
BuildRequires: bison curl-devel flex gperf gtk2-devel libicu-devel libqt4-devel libxslt-devel sqlite-devel
License: LGPL v2.0 only; LGPL v2.0 or later
Group: Development/Libraries/C and C++
Summary: Library for rendering web content, GTK+ Port
BuildRoot: %{_tmppath}/%{name}-%{version}-build
Version: 1.0.1
Release: 4
Source: webkit-%{version}.tar.bz2
Patch0: webkit-cairo-canvas-r34625-for-1.0.1.patch
Patch1: webkit-fix-gcc43.patch
Patch2: libwebkit-no-return-in-nonvoid.patch
Patch3: libwebkit-use-after-free.patch
%define debug_package_requires libwebkit-1_0-1 = %{version}-%{release}
%description
WebKit is a web content engine, derived from KHTML and KJS from KDE,
and used primarily in Apple's Safari browser. It is made to be
embedded in other applications, such as mail readers, or web browsers.
It is able to display content such as HTML, SVG, XML, and others. It
also supports DOM, XMLHttpRequest, XSLT, CSS, Javascript/ECMAscript and
more.
Authors:
--------
The KDE Team <kde@kde.org>
Apple Computer, Inc.
Trolltech ASA
Google Inc.
Nokia Corporation
Staikos Computing Services Inc. <info@staikos.net>
%package -n libwebkit-1_0-1
Group: Development/Libraries/C and C++
License: LGPL v2.0 only; LGPL v2.0 or later
Provides: libWebKitGtk0 = %{version}
Obsoletes: libWebKitGtk0 <= %{version}
#
Summary: Library for rendering web content, GTK+ Port
%description -n libwebkit-1_0-1
WebKit is a web content engine, derived from KHTML and KJS from KDE,
and used primarily in Apple's Safari browser. It is made to be
embedded in other applications, such as mail readers, or web browsers.
It is able to display content such as HTML, SVG, XML, and others. It
also supports DOM, XMLHttpRequest, XSLT, CSS, Javascript/ECMAscript and
more.
Authors:
--------
The KDE Team <kde@kde.org>
Apple Computer, Inc.
Trolltech ASA
Google Inc.
Nokia Corporation
Staikos Computing Services Inc. <info@staikos.net>
%package -n libwebkit-devel
License: LGPL v2.0 only; LGPL v2.0 or later
Group: Development/Libraries/C and C++
Summary: Library for rendering web content, GTK+ Port
Requires: libwebkit-1_0-1 = %{version} gtk2-devel
# Requires: libcurl-devel libicu-devel libjpeg-devel libxml2-devel libxslt-devel sqlite3-devel
Provides: WebKitGtk-devel = %{version}
Obsoletes: WebKitGtk-devel <= %{version}
%description -n libwebkit-devel
WebKit is a web content engine, derived from KHTML and KJS from KDE,
and used primarily in Apple's Safari browser. It is made to be
embedded in other applications, such as mail readers, or web browsers.
It is able to display content such as HTML, SVG, XML, and others. It
also supports DOM, XMLHttpRequest, XSLT, CSS, Javascript/ECMAscript and
more.
Authors:
--------
The KDE Team <kde@kde.org>
Apple Computer, Inc.
Trolltech ASA
Google Inc.
Nokia Corporation
Staikos Computing Services Inc. <info@staikos.net>
%package -n webkit-jsc
License: LGPL v2.0 only; LGPL v2.0 or later
Group: Development/Libraries/C and C++
Summary: Library for rendering web content, GTK+ Port
%description -n webkit-jsc
WebKit is a web content engine, derived from KHTML and KJS from KDE,
and used primarily in Apple's Safari browser. It is made to be
embedded in other applications, such as mail readers, or web browsers.
It is able to display content such as HTML, SVG, XML, and others. It
also supports DOM, XMLHttpRequest, XSLT, CSS, Javascript/ECMAscript and
more.
Authors:
--------
The KDE Team <kde@kde.org>
Apple Computer, Inc.
Trolltech ASA
Google Inc.
Nokia Corporation
Staikos Computing Services Inc. <info@staikos.net>
%prep
%setup -q -n webkit-%{version}
%patch0 -p 1
%patch1
%patch2
%patch3 -p1
%build
%ifarch ppc64
RPM_OPT_FLAGS="$RPM_OPT_FLAGS -mminimal-toc"
%endif
autoreconf --force --install
export CFLAGS=" $RPM_OPT_FLAGS"
%configure --enable-svg-experimental
make %{?jobs:-j %jobs}
%install
%makeinstall
find %{buildroot} -name "*.la" -exec rm {} \;
%post -n libwebkit-1_0-1 -p /sbin/ldconfig
%postun -n libwebkit-1_0-1 -p /sbin/ldconfig
%clean
rm -rf $RPM_BUILD_ROOT
%files -n libwebkit-1_0-1
%defattr(-,root,root)
%{_libdir}/libwebkit-1.0.so.1
%{_libdir}/libwebkit-1.0.so.1.0.0
%files -n libwebkit-devel
%defattr(-,root,root)
%doc JavaScriptCore/COPYING.LIB WebCore/LICENSE-APPLE WebCore/LICENSE-LGPL-2 WebCore/LICENSE-LGPL-2.1
%{_libdir}/libwebkit-1.0.so
%{_libdir}/pkgconfig/webkit-1.0.pc
%{_includedir}/webkit-1.0
%files -n webkit-jsc
%defattr(-,root,root)
%{_bindir}/jsc
%changelog
* Mon Oct 06 2008 cthiel@suse.de
- reviewed
* Wed Oct 01 2008 dominique-openusse@leuenberger.net
- Let's not package up the *.la files. They anyhow have illegal
references to other la files which are no longer packaged
(libwebkit-1.0.la for example contains ref to libsqlite3.la)
* Fri Sep 19 2008 maw@suse.de
- Add libwebkit-use-after-free.patch (bnc#427349, bwo#19618,
and CVE-2008-3632).
* Tue Aug 26 2008 ajorgensen@novell.com
- Fix for -debug* requiring wrong package
* Sat Aug 23 2008 ajorgensen@novell.com
- Patch no-return-in-nonvoid-function error
* Wed Aug 06 2008 ajorgensen@novell.com
- Update to version 1.0.1
- First release tarball
* Sat Jun 14 2008 schwab@suse.de
- Use -mminimal-toc on ppc64.
* Wed Jan 16 2008 stbinner@suse.de
- update to snapshot r29509
* Thu Jan 03 2008 stbinner@suse.de
- rename to comply to shared library packaging policy more exactly
* Wed Dec 19 2007 stbinner@suse.de
- initial package