File alsa-tools.spec of Package alsa-tools

#
# spec file for package alsa-tools (Version 1.0.21)
#
# Copyright (c) 2009 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

# norootforbuild


Name:           alsa-tools
BuildRequires:  alsa-devel fdupes fltk-devel gcc-c++ gtk2-devel update-desktop-files
%define package_version	1.0.21
Url:            http://www.alsa-project.org/
Summary:        Various ALSA Tools
Version:        1.0.21
Release:        1
License:        GPL v2 or later
Group:          Productivity/Multimedia/Sound/Utilities
AutoReqProv:    on
Requires:       alsa-firmware, fxload
Source:         ftp://ftp.alsa-project.org/pub/tools/alsa-tools-%{package_version}.tar.bz2
Source1:        README.SuSE
Source2:        sbipatches.tar.bz2
Source3:        envy24control.desktop
Source4:        rmedigicontrol.desktop
Source7:        rme.png
Source8:        envy24.png
Patch:          alsa-tools-desktop-fix.dif
# Patch1:         alsa-tools-git-fixes.diff
BuildRoot:      %{_tmppath}/%{name}-%{version}-build

%description
Various tools for ALSA including DSP loaders.



Authors:
--------
    Jaroslav Kysela <perex@perex.cz>
    Takashi Iwai <tiwai@suse.de>
    Uros Bizjak <uros@kss-loka.si>

%package gui
Summary:        Various ALSA Tools with GUI
Group:          Productivity/Multimedia/Sound/Utilities
License:        GPL v2 or later

%description gui
Various tools for ALSA with GUI for controlling the configuration and
the mixer of sepcific sound cards.



Authors:
--------
    Jaroslav Kysela <perex@perex.cz>
    Thomas Charbonnel <thomas@undata.org>
    Robert Vetter <postmaster@robertvetter.com>
    Martin Langer <martin-langer@gmx.de>

%package devel
Summary:        Include Files and Libraries mandatory for Development
Group:          Development/Languages/C and C++
License:        GPL v2 or later
Requires:       alsa-tools = %{version}

%description devel
This package contains all necessary include files and libraries needed
to develop applications that require these.



Authors:
--------
    Jaroslav Kysela <perex@perex.cz>
    Takashi Iwai <tiwai@suse.de>
    Uros Bizjak <uros@kss-loka.si>

%prep
%setup -q -a 2 -n %{name}-%{package_version}
cp %{SOURCE1} .
%patch -p1
# %patch1 -p1

%build
for d in envy24control rmedigicontrol echomixer; do
  cp $d/configure.in-gtk2 $d/configure.in
done
ALL_PACKS="envy24control seq/sbiload sscape_ctl hdspconf hdsploader hdspmixer rmedigicontrol echomixer usx2yloader us428control as10k1 ld10k1"
%ifnarch ppc ppc64
ALL_PACKS="$ALL_PACKS sb16_csp"
%endif
for d in $ALL_PACKS; do
  (cd $d
  # aclocal
  # test -f Makefile.am && automake -a --foreign
  # autoconf
  autoreconf -fi
  %configure
  make %{?jobs:-j %jobs}
  )
done
# compile as10k1 examples
make -C as10k1/examples dsp

%install
ALL_PACKS="envy24control seq/sbiload sscape_ctl hdspconf hdsploader hdspmixer rmedigicontrol echomixer usx2yloader us428control as10k1 ld10k1"
%ifnarch ppc ppc64
ALL_PACKS="$ALL_PACKS sb16_csp"
%endif
for d in $ALL_PACKS; do
  (cd $d
  make DESTDIR="$RPM_BUILD_ROOT" install
  )
done
rm -f $RPM_BUILD_ROOT%{_libdir}/liblo10k1.la
# remove obsolete hotplug files
rm -rf $RPM_BUILD_ROOT/etc/hotplug
# install pixmaps
mkdir -p $RPM_BUILD_ROOT%{_datadir}/pixmaps
cp %{SOURCE7} $RPM_BUILD_ROOT%{_datadir}/pixmaps
cp %{SOURCE8} $RPM_BUILD_ROOT%{_datadir}/pixmaps
cp hdspmixer/pixmaps/hdspmixer.png $RPM_BUILD_ROOT%{_datadir}/pixmaps
cp hdspconf/pixmaps/hdspconf.png $RPM_BUILD_ROOT%{_datadir}/pixmaps
# install desktop files
%suse_update_desktop_file -i envy24control AudioVideo Mixer GTK
%suse_update_desktop_file -i rmedigicontrol AudioVideo Mixer GTK
%suse_update_desktop_file hdspconf AudioVideo Utility
%suse_update_desktop_file hdspmixer AudioVideo Mixer
# install documents
mkdir -p $RPM_BUILD_ROOT%{_docdir}/%{name}
for d in $ALL_PACKS; do
  (cd $d
  n=${d##*/}
  mkdir -p $RPM_BUILD_ROOT%{_docdir}/%{name}/$n
  for f in AUTHORS COPYING* ChangeLog NEWS README* TODO; do
    test -s $f || continue
    install -c -m 0644 $f $RPM_BUILD_ROOT%{_docdir}/%{name}/$n
  done
  )
done
# extra doc for ld10k1
mkdir -p $RPM_BUILD_ROOT%{_docdir}/%{name}/ld10k1/doc
cp ld10k1/doc/README $RPM_BUILD_ROOT%{_docdir}/%{name}/ld10k1/doc
cp ld10k1/doc/*.txt $RPM_BUILD_ROOT%{_docdir}/%{name}/ld10k1/doc
cp ld10k1/doc/*_usage $RPM_BUILD_ROOT%{_docdir}/%{name}/ld10k1/doc
# opl3 sounds
mkdir -p $RPM_BUILD_ROOT%{_datadir}/sounds/opl3
install -c -m 0644 *.o3 *.sb $RPM_BUILD_ROOT%{_datadir}/sounds/opl3
(cd as10k1
mkdir -p $RPM_BUILD_ROOT%{_docdir}/%{name}/as10k1/examples
cp examples/*.asm examples/*.emu10k1 $RPM_BUILD_ROOT%{_docdir}/%{name}/as10k1/examples
)
%fdupes -s $RPM_BUILD_ROOT

%post -p /sbin/ldconfig

%postun -p /sbin/ldconfig

%clean
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT

%files
%defattr(-, root, root)
%doc %{_docdir}/%{name}
%{_bindir}/sscape_ctl
%{_bindir}/sbiload
%ifnarch ppc ppc64
%{_bindir}/cspctl
%endif
%{_bindir}/hdsploader
%{_bindir}/usx2yloader
%{_bindir}/us428control
%{_mandir}/man?/*
%{_datadir}/sounds/opl3
%{_bindir}/as10k1
%{_sbindir}/ld10k1
%{_sbindir}/ld10k1d
%{_sbindir}/dl10k1
%{_bindir}/lo10k1
%{_bindir}/init_*
%{_datadir}/ld10k1
%{_libdir}/liblo10k1.so.*

%files gui
%defattr(-, root, root)
%{_bindir}/envy24control
%{_bindir}/rmedigicontrol
%{_bindir}/hdspconf
%{_bindir}/hdspmixer
%{_bindir}/echomixer
%{_datadir}/applications/*.desktop
%{_datadir}/pixmaps/*

%files devel
%defattr(-, root, root)
%{_includedir}/lo10k1
%{_libdir}/liblo10k1.so
%{_datadir}/aclocal/*.m4

%changelog
openSUSE Build Service is sponsored by