File apache2-mod_apparmor.spec of Package apache2-mod_apparmor
#
# spec file for package apache2-mod_apparmor (Version 2.0.2)
#
# Copyright (c) 2008 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
# norootforbuild
Name: apache2-mod_apparmor
%if ! %{?distro:1}0
%if %{?suse_version:1}0
%define distro suse
%endif
%if %{?fedora_version:1}0
%define distro redhat
%endif
%endif
%if ! %{?distro:1}0
%define distro suse
%endif
# this is required to be underscore
%define module_name mod_apparmor
Summary: AppArmor module for apache2
Version: 2.0.2
Release: 168
Group: Productivity/Security
Source0: %{name}-%{version}-860.tar.gz
License: LGPL v2.1 or later
BuildRoot: %{_tmppath}/%{name}-%{version}-build
Url: http://forge.novell.com/modules/xfmod/project/?apparmor
BuildRequires: libapparmor-devel
Obsoletes: mod_change_hat mod-change-hat mod-apparmor apache2-mod-apparmor
Provides: mod_change_hat mod-change-hat mod-apparmor apache2-mod-apparmor
%if %{distro} == "suse"
%define apxs /usr/sbin/apxs2
%define apache_mmn %(MMN=$(%{apxs} -q LIBEXECDIR)_MMN; test -x $MMN && $MMN)
PreReq: apache2-prefork
PreReq: apparmor-parser
BuildRequires: apache2-devel
Requires: apache2 %{apache_mmn}
%else
%if %{distro} == "redhat" || %{distro} == "rhel4"
%define apxs /usr/sbin/apxs
PreReq: httpd
BuildRequires: httpd-devel
%endif
%endif
%define module_path %(%{apxs} -q LIBEXECDIR)
%define apache_sysconfdir %(%{apxs} -q SYSCONFDIR)
%description
apache2-modapparmor adds support to apache2 to provide AppArmor
confinement to individual cgi scripts handled by apache modules like
mod_php and mod_perl.
This package is part of a suite of tools that used to be named
SubDomain.
The documentation is in the apparmor-admin_en package.
Authors:
--------
sbeattie@suse.de
%prep
%setup -q
%build
make APXS=%{apxs}
%install
make install DESTDIR=${RPM_BUILD_ROOT} DISTRO=%{distro} MANDIR=%{_mandir}
%if %{distro} == "suse"
mkdir -p ${RPM_BUILD_ROOT}%{_libdir}/apache2-prefork/
ln -s %{module_path}/%{module_name}.so ${RPM_BUILD_ROOT}%{_libdir}/apache2-prefork/%{module_name}.so
%else
%if %{distro} == "redhat" || %{distro} == "rhel4"
mkdir -p ${RPM_BUILD_ROOT}/%{apache_sysconfdir}.d/
install -m 644 %{module_name}.conf ${RPM_BUILD_ROOT}/%{apache_sysconfdir}.d/
%endif
%endif
%clean
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
%files
%defattr(-,root,root)
%{module_path}
%if %{distro} == "suse"
%{_libdir}/apache2-prefork/%{module_name}.so
%else
%if %{distro} == "redhat" || %{distro} == "rhel4"
%{apache_sysconfdir}.d/%{module_name}.conf
%endif
%endif
%doc COPYING.LGPL
%{_mandir}/man*/*
%doc *.[0-9].html
%doc common/apparmor.css
%post
%if %{distro} == "suse"
/usr/sbin/a2enmod apparmor
%endif
%preun
%if %{distro} == "suse"
if [ $1 = 0 ] ; then
/usr/sbin/a2dismod apparmor
fi
%endif
%if %{distro} == "suse"
%triggerpostun -- mod_change_hat mod-change-hat
/usr/sbin/a2enmod apparmor || true
%endif
%changelog
* Tue Nov 11 2008 ro@suse.de
- make sure the triggerscript always exits with a true value
* Mon Jul 30 2007 sbeattie@suse.de
- Convert builddep on libapparmor to libapparmor-devel
* Fri Apr 13 2007 sbeattie@suse.de
- Update to AppArmor 2.0.2 (minor changes only)
- Add mod_apparmor(8) to package
* Wed Sep 06 2006 poeml@suse.de
- rename to apache2-mod_apparmor
- use a2enmod instead of frob_sysconfig
- remove SuSEconfig calls
* Fri May 26 2006 schwab@suse.de
- Don't strip binaries.
* Sat Apr 01 2006 srarnold@suse.de
- Relicense to LGPL (#157579)
* Mon Feb 06 2006 sbeattie@suse.de
- Renamed apache config options:
ImmhatName -> AAHatName
ImmDefaultHatName -> AADefaultHatName
* Mon Jan 30 2006 poeml@suse.de
- removed libapr-util1-devel from BuildRequires (apache2-devel does
require it)
* Sun Jan 29 2006 sbeattie@suse.de
- Fix linking against libapparmor.so (renamed from libimmunix.so)
- No more neededforbuild in STABLE
* Wed Jan 25 2006 mls@suse.de
- converted neededforbuild to BuildRequires
* Sat Jan 14 2006 sbeattie@suse.de
- Add dependency on contents of /usr/lib/apache2_MMN
* Fri Jan 06 2006 sbeattie@suse.de
- Fixup SUSE autobuild require on apache-devel-packages
- Add svn revision number to the source tarball
* Sun Dec 18 2005 sbeattie@suse.de
- Include symlink in %%{_libdir}/apache2-prefork/
* Fri Dec 09 2005 sbeattie@suse.de
- Rename to apache2-mod-apparmor for consistency with SUSE packages
- Rename module to mod_apparmor.so
* Thu Dec 08 2005 sbeattie@suse.de
- rename package to mod-apparmor
- relicense to GPL for open source release
- reset version to 2.0-1