File bakefile.spec of Package bakefile
#
# spec file for package bakefile (Version 0.2.6)
#
# Copyright (c) 2009 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
# norootforbuild
# nodebuginfo
Name: bakefile
BuildRequires: python python-devel
License: X11/MIT
Group: Development/Libraries/C and C++
Summary: Tool required to build WebKit
Version: 0.2.6
Release: 1
Source0: %{name}-%{version}.tar.bz2
BuildRoot: %{_tmppath}/%{name}-%{version}-build
Url: http://www.bakefile.org
Requires: python
%description
Tool required to build WebKit
Authors:
--------
Vaclav Slavik <vslavik@fastmail.fm>
Wodzimierz Skiba <abx@abx.art.pl>
%prep
%setup -q
%build
# autoreconf -f -i
%configure
make %{?jobs:-j%jobs}
%install
%makeinstall
%clean
rm -rf "$RPM_BUILD_ROOT"
%files
%defattr(-,root,root)
%{_bindir}/bakefil*
%{_datadir}/bakefile*
%{_libdir}/bakefile*
%{_datadir}/aclocal/bakefile-lang.m4
%{_datadir}/aclocal/bakefile.m4
%{_datadir}/aclocal/bakefile-dllar.m4
%{_datadir}/man/man1/bakefil*
%changelog
* Tue Apr 07 2009 vuntz@novell.com
- Update to version 0.2.6:
+ autoconf: fixed dependencies support for traditional Unix
compilers
+ autoconf: correct shared library extension under HP-UX ia64
+ autoconf: added support for new (10 and 11) Intel C/C++
compiler versions
+ watcom: fixes for OpenWatcom 1.8
+ fixed assert failure with wxWidgets' presets
+ msvs*prj: pass preprocessor flags to IDL compiler
+ msvs*prj: define WIN32 preprocessor symbol
+ fixed 100%% CPU usage in bakefile_gen
+ added <debug-info-edit-and-continue> tag to support Visual
Studio debugger's Edit and Continue feature
+ msvs*prj: allow overriding names of .vcproj files using
MSVS_PROJECT_FILE variable
- Use makeinstall.
* Sat Dec 20 2008 mboman@suse.de
- Update to version 0.2.5:
+ msvs200xprj: if "-o foo.vcproj" is specified on the command line, only
generate foo.vcproj and not foo.sln
+ autoconf: fixes for non-default BUILDDIR
+ msvs2005prj: fixed _WIN32_WCE define for PocketPC 2003 platform
+ put user- or configure-provided LDFLAGS and LIBS to the end of linker
+ command line to avoid conflicts of local libraries with system-wide
+ xcode2: fixed <ldflags> to not delete previously specified flags
+ xcode2: fixed <cxxflags> and <cppflags> for C++ files
+ xcode2: fixed <library> handling
+ added <depends-on-file> to all formats, with warnings if it's not
+ implemented
+ mingw, gnu: avoid "No rule to make target ..." errors in generated
makefiles when dependency header is removed
+ msvs2003prj, msvs2005prj: don't use /RTC1 flag in release builds with
debug information enabled
+ msvs2003prj, msvs2005prj: enable functions inlining iff optimization is
enabled instead of doing it unconditionally
+ xcode2: added support for <headers>
+ msvs2003prj, msvs2005prj: improvements to make generated projects more
similar to natively created projects
+ fixes for running on Solaris
+ xcode2: fixed naming of <dll> targets
+ check for incorrect used of conditional <set>
+ added support for multiple source files with the same name
+ msvs2003prj, msvs2005prj: fixed to generate correct precompiled headers
setting for auto vs. manual PCH creation
+ fixed incorrect dependencies of the "install" target
+ added support for Visual Studio 2008
+ bakefile_gen --clean removes directories created by Bakefile
+ fixed <subproject>'s <target> tag to work with all formats
* Wed Aug 06 2008 mauro@suse.de
- Updated to version 0.2.3
- removed support for C++ Builder X, it no longer exists and the format
wasn't used by anyone in practice
- significantly improved Xcode format (Kevin Ollivier)
- fixed running bakefile_gen if the name of temporary directory contains
spaces
- msvc6prj: use /pdb linker option to make the projects work when imported
in MSVC7.1 (Scott Bailey, patch #1732354)
- msvs2005prj: added support for Pocket PC platform
- added support for MSVS2003 project files (based on patch by
Aleksander Jaromin)
- Bakefile now generates files with output format's platform's default
line endings; added --eol option to override this (based on patch by
Francesco Montorsi)
- added envvar() convenience function for referencing environment variables
- added --wrap-output command line option for tweaking line-wrapping
behavior (based on patch by Francesco Montorsi)
- bakefile_gen uses all available CPUs by default now; use explicit -j1
flag to get the old behavior
- autoconf: fixed shared libraries sonames on NetBSD and OpenBSD
- added limited support for conditional variables dependent on other
conditional variables based by Francesco Montorsi (previously, only
dependency on options was possible)
- added "debug" level to the <echo> command
- deprecated <echo level="warning"> in favor of new <warning> command
- added XML Schema for FORMATS.bkmanifest and Bakefiles.bkgen files
- autoconf: check if install -d works (patch by Warren Young)
- dmars: always use -HP99 switch; made the value configurable (#160)
- autoconf: fixed warning about datarootdir variable with autoconf-2.61+
- fixed <lib-path> to generated correct output when passed empty string
as argument (#170; based on patch by Scott Bailey)
- msvs2005prj: fixed handling of include and library paths with spaces
- msvc6prj: fixed to not use minimal rebuild with optimization (#42)
- autoconf: call AC_BAKEFILE_PROG_CC/CXX from AC_BAKEFILE (#64)
- autoconf: added pkgconfig module (Francesco Montorsi, #105)
- added preliminary support for generating multiple variants
of makefiles in the same format (#156)
- msvs2005prj: fixed to correctly exclude conditional targets from
configurations they aren't built in (#181, John Ralls)
- msvs2005prj: fixed runtime library selection
- SRCDIR variable now uses Unix and not native paths like other variables
- fixes to win32 install target support (Francesco Montorsi)
- mingw: ensure win32 shell is used even if sh.exe is on PATH
* Sun Aug 26 2007 gecko@suse.de
- New version of bakefile