File libdb-4_5.spec of Package libdb_java-4_5

#
# spec file for package libdb-4_5 (Version 4.5.20)
#
# Copyright (c) 2009 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

# norootforbuild


Name:           libdb-4_5
%define         generic_name db
%define         docdir %{_defaultdocdir}/%{name}
%define         source_dir %{_datadir}/%{name}-source
Version:        4.5.20
Release:        97
%define         major 4
%define         minor 5
Summary:        Berkeley DB Database Library Version 4.5
Source:         db-%{version}.tar.bz2
Url:            http://www.sleepycat.com
Patch0:         patch.%{version}.1
Patch1:         patch.%{version}.2
Patch2:         db-%{version}.dif
License:        BSD 3-clause (or similar)
Group:          System/Libraries
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
Prefix:         %{_prefix}
# bug437293
%ifarch ppc64
Obsoletes:      db-64bit
%endif
#
Provides:       db = %{version}

%description
The Berkeley DB Database is a programmatic toolkit that provides
database support for applications.

This package contains the necessary runtime libraries.



%package -n db-utils-doc
License:        BSD 3-clause (or similar)
Summary:        Documentation for the Command Line tools for Managing Berkeley DB Databases
Group:          Productivity/Databases/Tools
Prefix:         %{_prefix}
Requires:       db = %{version}

%description -n db-utils-doc
The Berkeley DB Database is a programmatic toolkit that provides
database support for applications.

This package contains the documentation for the command line tools for
managing Berkeley DB databases.



%package -n db-utils
License:        BSD 3-clause (or similar)
Summary:        Command Line tools for Managing Berkeley DB Databases
Group:          Productivity/Databases/Tools
Prefix:         %{_prefix}
Requires:       db = %{version}

%description -n db-utils
The Berkeley DB Database is a programmatic toolkit that provides
database support for applications.

This package contains the command line tools for managing Berkeley DB
databases.



%package -n     db-doc
License:        BSD 3-clause (or similar)
Summary:        Documentation for Berkeley DB
Group:          Development/Libraries/C and C++
Prefix:         %{_prefix}

%description -n db-doc
The Berkeley DB Database is a programmatic toolkit that provides
database support for applications.

This package contains the documentation.



%package        devel
License:        BSD 3-clause (or similar)
Summary:        Development Files and Libraries for the old Berkeley DB library Version 4.5
Group:          Development/Libraries/C and C++
Prefix:         %{_prefix}
Requires:       db = %{version} glibc-devel
Provides:       db-devel = %{version}

%description    devel
The Berkeley DB Database is a programmatic toolkit that provides
database support for applications.

This package contains the header files and libraries.



%prep 
%setup -q -n %{generic_name}-%{version}
%patch0
%patch1
%patch2
cd ..
tar -jcf %{generic_name}-%{version}.tar.bz2 %{generic_name}-%{version}

%build
cd dist
./s_config
CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
CC=gcc
export CFLAGS CXXFLAGS CC
#
# Build now the NPTL version
#
mkdir ../build_nptl
cd ../build_nptl
../dist/configure --prefix=%{_prefix} \
        --libdir=%{_libdir} --enable-compat185 --disable-dump185 \
        --enable-shared --enable-static --enable-rpc --disable-cxx \
	--with-mutex="POSIX/pthreads/library" \
        %{_target_cpu}-suse-linux
# Make sure O_DIRECT is really disabled (build host could have old kernel)
perl -pi -e 's/#define HAVE_O_DIRECT 1/#undef HAVE_O_DIRECT/' db_config.h
# Remove libtool predep_objects and postdep_objects wonkiness
perl -pi -e 's/^predep_objects=".*$/predep_objects=""/' libtool
perl -pi -e 's/^postdep_objects=".*$/postdep_objects=""/' libtool
perl -pi -e 's/-shared -nostdlib/-shared/' libtool
make LIBSO_LIBS='$(LIBS)' LIBXSO_LIBS='$(LIBS)'" -L%{_libdir} -lstdc++"

%install
mkdir -p ${RPM_BUILD_ROOT}%{_includedir}/db4
#mkdir -p ${RPM_BUILD_ROOT}% {source_dir}/
#
#cp % {_builddir}/% {generic_name}-% {version}.tar.bz2 ${RPM_BUILD_ROOT}% {source_dir}/
#mkdir -p $RPM_BUILD_ROOT/% {_defaultdocdir}/% {name}-source
#cat >>$RPM_BUILD_ROOT/% {_defaultdocdir}/% {name}-source/README<<EOF
#The patches in this directory were applied to the sources.
#The sources were installed to:
#% {source_dir}/% {generic_name}-% {version}.tar.bz2
#EOF
CONFIG_ARGS=$(find . -name "config.log" -exec grep "\$ \.\./dist\/configure" {} \; | sed 's/.*configure\( --.*\)/\1/g')
if [ -z "$CONFIG_ARGS" ]
then
  echo "could not find configure arguments ... exiting"
  exit 42
fi
#echo $CONFIG_ARGS >> $RPM_BUILD_ROOT/% {_defaultdocdir}/% {name}-source/configure_args.txt
#cp % {_sourcedir}/*patch* $RPM_BUILD_ROOT/% {_defaultdocdir}/% {name}-source || true
#cp % {_sourcedir}/*.dif*  $RPM_BUILD_ROOT/% {_defaultdocdir}/% {name}-source || true
#
mkdir -p ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}
cd build_nptl
make prefix=${RPM_BUILD_ROOT}%{_prefix} libdir=${RPM_BUILD_ROOT}%{_libdir} strip=true install
cd ..
# make ldd happy:
chmod 755 $RPM_BUILD_ROOT%{_libdir}/libdb*.so
# Fix header file installation
mv ${RPM_BUILD_ROOT}%{_includedir}/*.h ${RPM_BUILD_ROOT}%{_includedir}/db4
echo "#include <db4/db.h>" > ${RPM_BUILD_ROOT}%{_includedir}/db.h
echo "#include <db4/db_185.h>" > ${RPM_BUILD_ROOT}%{_includedir}/db_185.h
rm -f ${RPM_BUILD_ROOT}%{_includedir}/db4/db_cxx.h
# remove dangling tags symlink from examples.
rm -f examples_cxx/tags
rm -f examples_c/tags
# Move documentation to the right directory
mkdir -p $RPM_BUILD_ROOT%{docdir}
mv $RPM_BUILD_ROOT%{_prefix}/docs/* $RPM_BUILD_ROOT/%{docdir}
cp -a examples_cxx examples_c $RPM_BUILD_ROOT/%{docdir}
cp -a LICENSE README $RPM_BUILD_ROOT/%{docdir}
#
# Remove api documentation for Java and TCL
rm -rf $RPM_BUILD_ROOT/%{docdir}/java
rm -rf $RPM_BUILD_ROOT/%{docdir}/api_java
rm -rf $RPM_BUILD_ROOT/%{docdir}/api_tcl
mv $RPM_BUILD_ROOT/%{docdir}/collections/tutorial $RPM_BUILD_ROOT/%{docdir}/
# Remove crappy *.la files
rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
rm -rf $RPM_BUILD_ROOT%{_libdir}/tls/*.la

%post -p /sbin/ldconfig

%postun -p /sbin/ldconfig

%clean
rm -rf ${RPM_BUILD_ROOT}

%files 
%defattr(-,root,root)
%{_libdir}/libdb-%{major}.%{minor}.so

%files -n db-doc
%defattr(-,root,root)
%dir %{docdir}
%doc %{docdir}/LICENSE
%doc %{docdir}/README
%doc %{docdir}/index.html
%doc %{docdir}/license
%doc %{docdir}/images
%doc %{docdir}/api_c
%doc %{docdir}/api_cxx
%doc %{docdir}/gsg*
%doc %{docdir}/ref
%doc %{docdir}/examples_c
%doc %{docdir}/examples_cxx
%doc %{docdir}/tutorial

%files -n db-utils-doc
%defattr(-,root,root)
%doc %{docdir}/utility

%files -n db-utils
%defattr(-,root,root)
%{_bindir}/berkeley_db_svc
%{_bindir}/db_archive
%{_bindir}/db_checkpoint
%{_bindir}/db_deadlock
%{_bindir}/db_dump
%{_bindir}/db_load
%{_bindir}/db_printlog
%{_bindir}/db_recover
%{_bindir}/db_stat
%{_bindir}/db_upgrade
%{_bindir}/db_verify
%{_bindir}/db_hotbackup

%files devel
%defattr(-,root,root)
%dir %{_includedir}/db4
%{_includedir}/db.h
%{_includedir}/db_185.h
%{_includedir}/db4/db.h
%{_includedir}/db4/db_185.h
%{_libdir}/libdb.so
%{_libdir}/libdb.a
%{_libdir}/libdb-%{major}.%{minor}.a
%{_libdir}/libdb-%{major}.so
#% files source
#% defattr(-,root,root)
#% {_defaultdocdir}/% {name}-source
#% {source_dir}
#

%changelog
openSUSE Build Service is sponsored by