File perl-Test-Exception.spec of Package perl-Test-Exception

#
# spec file for package perl-Test-Exception (Version 0.27 )
#
# Copyright (c) 2009 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

# norootforbuild


Name:           perl-Test-Exception
%define cpan_name %( echo %{name} | %{__sed} -e 's,perl-,,' )
Summary:        Test::Exception - Test exception based code
Version:        0.27 
Release:        42
License:        Artistic License ..
Group:          Development/Libraries/Perl
Url:            http://search.cpan.org/dist/Test-Exception
Source:         Test-Exception-%{version}.tar.bz2
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildRequires:  perl
BuildRequires:  perl-macros
BuildRequires:  perl(Test::Pod) >= 1.00
BuildRequires:  perl(Test::Simple) >= 0.7
# only perl >= 5.10.0 will fullfill deps
#%if %{perl_subversion} > 8
##echo "breq Test::Builder >=0.7"
#BuildRequires:  perl(Test::Builder) >= 0.7
#BuildRequires:  perl(Test::Builder::Tester) >= 1.07
#%else
BuildRequires:  perl(Test::Builder)
BuildRequires:  perl(Test::Builder::Tester)
#%endif
BuildRequires:  perl(Test::More) >= 0.7
BuildRequires:  perl(Test::Harness) >= 2.03
BuildRequires:  perl(Sub::Uplevel) >= 0.18
#
Requires:       perl = %{perl_version}
Requires:       perl(Sub::Uplevel) >= 0.18
Requires:       perl(Test::More) >= 0.7
# only perl >= 5.10.0 will fullfill deps
#%if %{perl_subversion} > 8
##echo "req Test::Builder >=0.7"
#Requires:  perl(Test::Builder) >= 0.7
#%else
#echo "req Test::Builder"
Requires:       perl(Test::Builder)
#%endif

%description
This module provides a few convenience methods for testing exception
based code. It is built with Test::Builder and plays happily with
Test::More and friends.

  Authors:	Adrian Howard <adrianh@quietstars.com>
%prep
%setup -q -n %{cpan_name}-%{version}
echo "perlVersion: "%{perl_version}

%build
perl Makefile.PL OPTIMIZE="$RPM_OPT_FLAGS -Wall"
%{__make}

%check
%{__make} test

%install
%perl_make_install
%perl_process_packlist
%perl_gen_filelist

%clean
%{__rm} -rf $RPM_BUILD_ROOT

%files -f %{name}.files
# normally you only need to check for doc files
%defattr(0644,root,root,0755)
%doc Changes README

%changelog
openSUSE Build Service is sponsored by