File quilt.spec of Package quilt
#
# spec file for package quilt (Version 0.48)
#
# Copyright (c) 2009 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
# norootforbuild
Name: quilt
BuildRequires: diffstat ed procmail
Summary: A Tool for Working with Many Patches
License: GPL v2 or later
Group: Productivity/Text/Utilities
Version: 0.48
Release: 3
Requires: coreutils diffutils patch gzip bzip2 perl mktemp diffstat
%if %{suse_version} > 910
Recommends: procmail
%endif
AutoReqProv: off
Source: %{name}-%{version}.tar.bz2
Source1: suse-start-quilt-mode.el
Patch1: expand.diff
Patch2: docdir.diff
Patch3: patch-wrapper-rpm.diff
Patch4: fix-test-create-delete.diff
Patch5: hide-git-desc-error.diff
Patch6: mail-dont-use-equal-tilde.diff
Patch7: revert-should-not-hard-link.diff
Patch8: fix-fr-import-message.diff
Url: http://savannah.nongnu.org/projects/quilt
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%description
Quilt allows you to easily manage large numbers of patches by keeping
track of the changes each patch makes. Patches can be applied,
un-applied, refreshed, and more.
Quilt originally was based on Andrew Morton's patch scripts found at
http://www.zip.com.au/~akpm/linux/patches/.
Authors:
--------
Andreas Gruenbacher <agruen@suse.de>
%prep
%setup -q
%patch -p1 -P 1 -P 2 -P 3 -P 4 -P 5 -P 6 -P 7 -P 8
%build
autoconf
# --with-rpmbuild=/usr/lib/rpm/rpmb:
#
# SUSE Autobuild uses a version of /usr/bin/rpmbuild that sources
# /etc/profile to reset the PATH. We must not do that: the
# inspect script needs to pass an additional path component to
# rpmbuild for the tar and patch wrappers.
CFLAGS="$RPM_OPT_FLAGS" \
./configure --prefix=/usr \
--mandir=%{_mandir} \
--with-sendmail=/usr/sbin/sendmail \
--with-diffstat=/usr/bin/diffstat \
--with-patch-wrapper \
--with-patch=/usr/bin/patch \
--with-rpmbuild=/usr/lib/rpm/rpmb
make BUILD_ROOT=$RPM_BUILD_ROOT RELEASE=%release
%check
make check
%install
# /usr/share/quilt/compat/mta will be a stale symlink: we don't want to add
# sendmail to neededforbuild just because of this.
export NO_BRP_STALE_LINK_ERROR=yes
make install BUILD_ROOT=$RPM_BUILD_ROOT
mv $RPM_BUILD_ROOT/etc/bash_completion.d/quilt{,.sh}
#make rpmlint happy
chmod 755 $RPM_BUILD_ROOT/%{_datadir}/quilt/scripts/patchfns
# We only needed the /usr/bin/patch compatibility symlink for the
# test suite.
[ $RPM_BUILD_ROOT/usr/share/quilt/compat/patch -ef /usr/bin/patch ] \
&& rm -f $RPM_BUILD_ROOT/usr/share/quilt/compat/patch
[ $RPM_BUILD_ROOT/usr/share/quilt/compat/awk -ef /usr/bin/awk ] \
&& rm -f $RPM_BUILD_ROOT/usr/share/quilt/compat/awk
%{find_lang} %{name}
# Make "vi" an alias for the edit command
ln -s edit $RPM_BUILD_ROOT/usr/share/quilt/vi
# Autoload quilt-mode in the SuSE emacs package
install -m 644 %_sourcedir/suse-start-quilt-mode.el \
$RPM_BUILD_ROOT/usr/share/emacs/site-lisp/
%clean
rm -rf $RPM_BUILD_ROOT
%files -f %{name}.lang
%defattr(-, root, root)
/usr/bin/guards
/usr/bin/quilt
/usr/share/quilt/
/usr/share/emacs/
/usr/lib/quilt/
%config /etc/quilt.quiltrc
%config /etc/bash_completion.d/quilt.sh
%doc %{_mandir}/man1/guards.1.gz
%doc %{_mandir}/man1/quilt.1.gz
%doc doc/README
%doc doc/README.MAIL
%doc doc/quilt.pdf
%changelog