File JTOpen.spec of Package JTOpen

#
# spec file for package JTOpen (Version 6.3)
#
# Copyright (c) 2008 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

# norootforbuild


Name:           JTOpen
BuildRequires:  unzip
%define cvs_version 6_3
License:        IBM Public License
Group:          Development/Libraries/Java
Url:            http://oss.software.ibm.com/developerworks/opensource/jt400/index.html
Requires:       jre1.1.x
AutoReqProv:    on
Summary:        The Open Source Version of the IBM Toolbox for Java
Version:        6.3
Release:        1
Source0:        jtopen_%{cvs_version}.zip
Source1:        jtopen_%{cvs_version}_source.zip
Source2:        README.SuSE
Source3:        jtopen_%{cvs_version}_javadoc.zip
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildArch:      noarch

%description
The IBM Toolbox for Java is a library of Java classes supporting the
client/server and Internet programming models to an iSeries or AS/400
server. The classes can be used by Java applets, servlets, and
applications to easily access iSeries and AS/400 data and resources.

The toolbox does not require additional client support beyond what is
provided by the Java Virtual Machine and TCP/IP.



%package doc
License:        IBM Public License
Summary:        Additional Package Documentation
Group:          Development/Libraries/Java

%description doc
JTOpen is an Open Source version of the IBM Toolbox for Java.

The IBM Toolbox for Java is a library of Java classes supporting
client/server and internet programming models for an iSeries or AS/400
server. The classes can be used by Java applets, servlets, and
applications to easily access iSeries and AS/400 data and resources.

The Toolbox does not require additional client support over and above
what is provided by the Java Virtual Machine and TCP/IP.



%prep
%setup -q -c
#
install -m 644 %{S:1} %{S:2} .
# unpack javadoc
install -m 755 -d ./javadoc
unzip -qq %{S:3} -d ./javadoc 

%build

%install
install -d -m 755 $RPM_BUILD_ROOT%{_datadir}/%{name}/
install -d -m 755 $RPM_BUILD_ROOT%{_docdir}/%{name}/
cp -r lib $RPM_BUILD_ROOT%{_datadir}/%{name}/
cp  *.zip $RPM_BUILD_ROOT%{_datadir}/%{name}/
cp -r javadoc *.html README.SuSE $RPM_BUILD_ROOT%{_docdir}/%{name}/

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-,root,root)
%dir %{_docdir}/%{name}
%{_docdir}/%{name}/*.html
%{_docdir}/%{name}/README.SuSE
%{_datadir}/%{name}/

%files doc
%defattr(-,root,root)
%{_docdir}/%{name}/javadoc

%changelog
* Thu Sep 11 2008 mvyskocil@suse.cz
- Update to new upstream version 6.3
  * Command call: Changed scope of getThreadSafetyProperty() from private to package.
  * Command call: Refined tracking of missing V5R4 PTF for QCDRCMDI (SI29629).
  * Connection pool: Fix bug to reuse connections which have a maxLifetime of 0.
  * Connection: Added AS400 properties: mustAddLanguageLibrary, mustUseSuppliedProfile.
  * Connection: Added AS400 properties: mustUseSockets, mustUseNetSockets, threadUsed.
  * Connection: Ensure that the socket never gets left open.
  * Connection: Fix code so that applets do not get AccessControlException.
  * Connection: Only try to load PASE library when on V6R1 or higher.
  * Connection: Fix for JTOpen bug 2039039: Set another timeout when opening a socket connection.
  * Data area: Honor setting of threadSafe property.
  * Data conversion: Modification to handling of Date convert(*CURRENT) to adjust to local time.
  * Data conversion: Added method AS400DataType.getJavaType().
  * Data conversion: Regenerated conversion tables for CCSIDs 835 and 4931.
  * JDBC: Add support for getSQLXML on Blob columns, for consistency with native JDBC driver.
  * JDBC: Allow userid/password in URL to override blanks in parameters.
  * JDBC: Fix ResultSet navigation for various relative scrolling.
  * JDBC: Fix cast exception for DBClob when written as a locator.
  * JDBC: Fix double JDBC driver registration with DriverManager.registerDriver().
  * JDBC: Fix generated keys truncation.
  * JDBC: Fix lob locator update and retrieval from AS400JDBCResultSet.
  * JDBC: Fix logic so that ResultSet.relative(1) is same as ResultSet.next().
  * JDBC: Fix long schema bug in library list.
  * JDBC: Fix stream helper method.
  * JDBC: Fix server trace bug.
  * JDBC: Fix typo in byteLength variable.
  * JDBC: Get database metadata from SYSIBM stored procedures if "metadata source" property is set to 1.
  * JDBC: Ignore Warnings to allow users to specify list of SQL states to cause JDBC to ignore and not issue warnings.
  * JDBC: Misc XML fixes to not rely on external parsers.
  * JDBC: More resultset cursor navigation fixes for various abnormal scrolling.
  * JDBC: Prohibit accidental JDBC Connection with userid or password of "".
  * JDBC: Use connection property "translate hex" value in the algorithm to generate extended dynamic sql package name.
  * Messages: Added new MessageFile.getMessage() method, with additional CCSID parameters.
  * NetServer: Deprecated class; use ISeriesNetServer instead.
  * Object description: Fixed StringIndexOutOfBoundsException.
  * Object description: New method ObjectDescription.getObjectLockList().
  * PTF: Added constants to represent new V6R1 status values.
  * Print: Added method Printer.setAttributes(), to match functionality of RPrinter.
  * RLA: Changes to verifyS38MSGRM() to better handle ClassCastException.
  * System pool: Added 2 constructors, and isValidNameForSharedPool().
  * System pool: Eliminated logic errors.  Strip trailing blanks from returned String-valued attributes.
  * System value: Enhanced javadoc and code comments.
  * Trace: Add more tracing for invalid passwords.
  * Trace: Added tracing of connection ID.
  * Trace: Skip stack trace for "Class com.ibm.as400.access.Properties not found".
  * Trace: If incorrect reply datastream header: Trace bytes, and disregard stream.
  * Trace: Streamlined trace messages for 'GSSToken not available' and non-fatal ClassNotFoundException.
  * User: Add getObjectsOwned() method.
* Thu Mar 29 2007 dbornkessel@suse.de
- added unzip to build requires
* Mon Sep 25 2006 dbornkessel@suse.de
- no icecream
- update to v.5.2
* Tue Mar 14 2006 olh@suse.de
- updated to version 5.0 [#149530 - LTC21539]
* Wed Jan 25 2006 mls@suse.de
- converted neededforbuild to BuildRequires
* Thu Jan 12 2006 skh@suse.de
- updated to version 4.9 [fate #140782]
* Tue May 04 2004 pmladek@suse.cz
- updated to version 4.3.1 [#39648]
* Mon Apr 19 2004 pmladek@suse.cz
- updated to version 4.3 [#39093]:
  * does not contain elderly documentation, the current one is available
  online from the home page
  * the doc subpackage still contains the actual javadoc
- updated README.SuSE accordingly
- removed obsolete BuildRoot cleaning from the install phase
* Tue Mar 02 2004 pmladek@suse.cz
- updated to version 4.2
- fixed installation, moved from /usr/lib to /usr/share
* Thu Feb 05 2004 hmacht@suse.de
- added entry # norootforbuild in specfile
* Mon Aug 25 2003 pmladek@suse.cz
- updated to the version 4.1
* Fri Jun 20 2003 ro@suse.de
- added directory to filelist
* Tue Aug 06 2002 pmladek@suse.cz
- updated to version 3.1
- included sources
- fixed README.SuSE
- fixed permissions of directories
* Thu Oct 11 2001 pmladek@suse.cz
- package created, version 2.04
openSUSE Build Service is sponsored by