File gnokii.spec of Package gnokii

#
# spec file for package gnokii (Version 0.6.24)
#
# Copyright (c) 2008 SUSE LINUX Products GmbH, Nuernberg, Germany.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

# norootforbuild


Name:           gnokii
BuildRequires:  bluez-libs gtk2-devel libical-devel libusb-devel perl-XML-Parser
BuildRequires:  coreutils mysql-devel pcsc-lite-devel postgresql-devel update-desktop-files
Version:        0.6.24
Release:        1
PreReq:         permissions
Requires:       bluez-libs
Group:          Hardware/Mobile
License:        GPL v2 or later
Url:            http://www.gnokii.org/
Summary:        Nokia Connectivity Program
Source:         %{name}-%{version}.tar.bz2
Source1:        xgnokii.desktop
Source2:        gnokii.xpm
Source3:        README.SUSE
BuildRoot:      %{_tmppath}/%{name}-%{version}-build

%description
gnokii is a package of programs for communicating with a Nokia cellular
phone in Linux. Read the READMEs in /usr/share/doc/packages/gnokii to
find out which models are supported.



Authors:
--------
    Hugh Blemings <hugh@linuxcare.com>
    Pavel Janik ml. <Pavel.Janik@linux.cz>
    Jan Derfinak <ja@mail.upjs.sk>

%package -n xgnokii
Group:          Hardware/Mobile
Summary:        Nokia Connectivity Program
Provides:       gnokii:/usr/share/xgnokii
Requires:       gnokii gtk2

%description -n xgnokii
xgnokii is an X Window System front-end for gnokii. gnokii has to be
installed as well.



Authors:
--------
    Hugh Blemings <hugh@linuxcare.com>
    Pavel Janik ml. <Pavel.Janik@linux.cz>
    Jan Derfinak <ja@mail.upjs.sk>

%package smsd
Group:          Hardware/Mobile
Summary:        Nokia Connectivity Program
Provides:       gnokii:/usr/share/smsd
Requires:       gnokii

%description smsd
gnokii is a package of programs for communicating with a Nokia cellular
phone in Linux. Please read the READMEs in
/usr/share/doc/packages/gnokii to find out which models are supported.



Authors:
--------
    Hugh Blemings <hugh@linuxcare.com>
    Pavel Janik ml. <Pavel.Janik@linux.cz>
    Jan Derfinak <ja@mail.upjs.sk>

%package devel
Group:          Hardware/Mobile
Summary:        Nokia Connectivity Program
Requires:       %{name} = %{version}
Requires:       %{name}-smsd = %{version}
Requires:       libical-devel xorg-x11-devel libusb-devel glib2-devel libopenssl-devel

%description devel
gnokii is a package of programs for communicating with a Nokia cellular
phone in Linux. Please read the READMEs in
/usr/share/doc/packages/gnokii to find out which models are supported.



Authors:
--------
    Hugh Blemings <hugh@linuxcare.com>
    Pavel Janik ml. <Pavel.Janik@linux.cz>
    Jan Derfinak <ja@mail.upjs.sk>

%prep
%setup -q

%build
export CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC -Wall -Wno-unused -fstack-protector -fno-strict-aliasing"
%configure \
    --enable-nls \
    --enable-security \
    --disable-static \
    --with-x
make %{?jobs:-j%jobs}
make -C smsd %{?jobs:-j%jobs}

%install
cp %{S:3} .
make DESTDIR=$RPM_BUILD_ROOT install
make DESTDIR=$RPM_BUILD_ROOT -C smsd install
rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
rm -f $RPM_BUILD_ROOT%{_libdir}/smsd/*.la
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}
sed "s:/usr/local/sbin:%{_sbindir}:g" Docs/sample/gnokiirc > $RPM_BUILD_ROOT%{_sysconfdir}/gnokiirc
chmod +x $RPM_BUILD_ROOT%{_bindir}/sendsms
%find_lang %{name}
install -D -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/pixmaps/gnokii.xpm
%suse_update_desktop_file -i xgnokii Utility TelephonyTools Calendar ContactManagement Office GTK
# prepare documentation
find Docs -name 'Makefile.*' -exec rm -f {} \;
rm -rf Docs/man $RPM_BUILD_ROOT%{_datadir}/doc/%{name}
chmod -x Docs/gnokii.nol
mv Docs/sample Docs/examples

%post
/sbin/ldconfig
%{run_permissions}
%verifyscript
%verify_permissions -e %{_sbindir}/mgnokiidev

%postun
/sbin/ldconfig

%clean
rm -rf $RPM_BUILD_ROOT

%files -f %{name}.lang
%defattr(-,root,root)
%config(noreplace) %{_sysconfdir}/gnokiirc
%doc COPYING COPYRIGHT ChangeLog MAINTAINERS TODO Docs/*
%doc %{_mandir}/man1/gnokii*
%doc %{_mandir}/man8/gnokiid*
%doc %{_mandir}/man8/mgnokiidev*
%{_bindir}/gnokii
%{_bindir}/gnokiid
%{_libdir}/*.so.*
%verify(not mode) %attr(0755, root, uucp) %{_sbindir}/mgnokiidev

%files -n xgnokii
%defattr(-,root,root)
%doc %{_mandir}/man1/xgnokii*
%{_bindir}/xgnokii
%{_datadir}/xgnokii
%{_datadir}/applications/*
%{_datadir}/pixmaps/*

%files smsd
%defattr(-,root,root)
%doc %{_mandir}/man1/sendsms*
%doc %{_mandir}/man8/smsd*
%{_bindir}/sendsms
%{_bindir}/smsd
%dir %{_libdir}/smsd
%{_libdir}/smsd/libsmsd_file.so

%files devel
%defattr(-,root,root)
%{_libdir}/*.so
%{_libdir}/smsd/libsmsd_mysql.so
%{_libdir}/smsd/libsmsd_pq.so
%{_libdir}/pkgconfig/*
%{_includedir}/gnokii.h
%{_includedir}/gnokii

%changelog
* Tue Mar 25 2008 prusnak@suse.cz
- updated to 0.6.24
  * libgnokii changes
  o prepare new API for config handling; it will allow third
  party applications to use own configuration
  o add id for Nokia 5300 to misc.c only; use model=series40 in
  gnokiirc for this and similar phones
  o create a new function moving code from atgen.c to split raw
  fields of a PDU coded SMS and copy them to gn_sms_raw struct
  for later decoding
  o change gn_memory_type2str() to be the inverse of
  gn_str2memory_type(), ie converting a numeric gn_memory_type
  like GN_MT_ME into a short string like "ME"; converting into
  a more user friendly string like "Internal memory" is now
  done by gn_memory_type_print()
  * at driver updates
  o in ReplyGetSMS() use the new function to split raw fields of
  a PDU coded SMS (code refactoring, no functional changes)
  o do not segfault when AT+COPS? returns only the first value
  as in +COPS: 0
  o AT protocol supports only one SMS Center, so pretend that its
  location is number 1 and return GN_ERR_INVALIDLOCATION
  when requested SMSC location is not 1
  o use gn_str2memory_type() and the new gn_memory_type2str() to
  convert memory arguments
  o implement the functions to support --showsmsfolderstatus for
  up to 4 folders
  o fix setting the current memory on Sony Ericsson phones
  o force the encoding to be GSM when we're expecting an "ASCII"
  answer, fixes a lot of functionality on Sony Ericsson, Samsung
  and Sagem phones.
  o in GN_OP_SaveSMS set data->raw_sms->number with location
  number where message was stored, as expected by gnokii
       --savesms
  o in Sony Ericsson driver atsoer.c fix off by one command
  string length in se_at_memory_type_set()
  o parse date and time if sent by phone when reading phonebook
  entries (eg DC, MC, RC memories)
  * pcsc driver updates
  o implement --getsms from SM memory; this can read deleted SMS
  o implement the functions to support --showsmsfolderstatus
  * documentation updates
  o add to gnokii man page the missing options of --sendsms
  command (--8bit, --concat, --animation and --wappush) and
  document all its other long options
  o try to make an impression that all the phones are supported
  * gnokii updates
  o make --getsmsc understand the "end" keyword
  o the -f and -F options of --getsms now output short memory
  names for X-GSM-Memory
  o use the new gn_memory_type2str() to show memory name instead
  of numeric ID in --showsmsfolderstatus output
  * nk6100 driver
  o use "SIM card" instead of "SMS Inbox" as SM folder name for
       --showsmsfolderstatus
* Tue Feb 19 2008 prusnak@suse.cz
- updated to 0.6.23
  * documentation updates
  o add further details for logo commands to gnokii man page
  and fix --getwapsetting/--writewapsetting
  o update xgnokii/ChangeLog
  * build system updates
  o don't include packaging directory in the release tarballs
  o don't allow to build without debug
  o switch build system to automake
  o allow silent (make -s) build
  o add missing includes on glibc 2.7
  o get rid of XGNOKIIDIR
  o add --disable-smsd option to disable smsd compilation and
  installation
  * libgnokii updates
  o update gsm network list
  o use defines instead of hardcoding values
  o correct FBUS sequence number initialization
  o make the function gn_get_connectiontype() visible even when
  compiling with -fvisibility=hidden
  o remove deprecated gn_cfg_read() function
  o initialize active call table with Idle state for checking
  active calls
  * xgnokii updates
  o avoid to use hardcodes
  o avoid segfault on calendar fetching
  o display a dialog to inform the user that some functions in
  the Calendar window are not yet implemented ("Save to phone",
  "Send via SMS", "Import from file", "Export to file"); also
  make menu items for "Add reminder", "Add call", "Add
  meeting", "Add birthday", "Delete note" work
  * pcsc driver updates
  o provide more information to the --identify command
  o implement --getnetworkinfo
  * gnokii updates
  o trailing \n with --sendsms was not calculated into sms length
  but it was added into sms text; as the result if \n was 161st
  char in the sms and it was the last one we were telling user
  that just one sms will be sent and we sent two
  * nk6510 driver updates
  o print out rf level information in debug mode even it gnokii
  structures are not initialized
  o add call notification handler
  o attempt to "fix" problem with getting folder list on some
  Series40 phones
* Wed Nov 28 2007 prusnak@suse.cz
- updated to 0.6.22
  * build system updates
  o make install and install-devel work correctly
  o xgnokii.pc should be installed with install-devel
  o add MS Visual C++ 2008 project files
  * at driver updates
  o make CNMI mode argument configurable in at_driver_instance
  o don't fallback to default memory type if desired one is not
  available
  o new specific driver for Motorola
  * xgnokii updates
  o change the way phonebooks entries are deleted
  o make sure it didn't copy subentries from previously read
  phonebook entry
  o fix moving phonebook entries from SIM to phone and vice versa
  o when a phonebook entry is successfully saved or deleted do
  not process it again
  o do not let the user write phonebook names longer than the
  space allocated by libgnokii
  * link layer updates
  o reset link layer status when resending message
  o extend buffer for the reply as a workaround for libusb
  problem
  o improve DKU-5 initialization again
  * libgnokii updates
  o export delivery report status as enum, not only text
  o use businessCategory for caller group number when exporting
  and importing phonebook entries in LDIF format (instead of
  businessGroup and callerGroup)
  o add function to return connection name
  o make gn_gsm_initialise() print the "phone instance config" in
  a format that can be copied into gnokiirc
  * nk6510 driver updates
  o don't free driver instance too early
* Mon Nov 12 2007 prusnak@suse.cz
- updated to 0.6.21
  * xgnokii updates
  o update xgnokii desktop file
  o reading contacts from phone would miss the last entries if
  phonebook contained holes (see gnokii fix for --getphonebook
  below)
  o importing contacts from file now replaces entries with the
  same location number leaving the others untouched (in prior
  versions the others were deleted)
  o replace sprintfs() with snprintfs()
  * link layer updates
  o improve DKU-5 initialization stage
  o be careful with return value from read()
  * at driver updates
  o return an error from at_memory_type_set() when a phonebook
  memory type supported by libgnokii isn't supported by the
  phone's AT+CPBS= command
  o avoid memory corruption due to too small buffer with getsms
  and delete sms after incoming sms notification
  * build system updates
  o change location of gnapplet.sis
  o configure.in and makefiles simplification
  o install gnokii.pc with install-devel and not install target
  * libgnokii updates
  o new error code GN_ERR_ASYNC
  o add support for async way of send_sms()
  o add ids for Nokia 6030
  o add ids for Nokia 3110 classic
  o replace sprintfs() and strcpys() with snprintfs
  o return an error when trying to read from file more phonebook
  subentries than the space allocated
  * gnapplet driver updates
  o add support for setactiveprofile
  * gnokii updates
  o fix --getphonebook not reading the last entries in two cases
  when some entries before those meant to be read were empty
  and make it fail on more errors (empty or invalid locations
  are still handled like in previous versions)
  o replace sprintfs() and strcpys() with snprintfs()
  * translation updates
  o new Portugal translation
  * device layer updates
  o make BlueZ connection non blocking on read()
- removed obsolete patch:
  * sms-out-of-sync.patch (included in update)
* Thu Nov 08 2007 prusnak@suse.cz
- fixed crashes when sending text message [#336961]
  (sms-out-of-sync.patch)
* Wed Oct 31 2007 prusnak@suse.cz
- added pcsc-lite-devel to BuildRequires
- don't package .la files
- cleaned spec file
* Tue Oct 30 2007 prusnak@suse.cz
- updated to 0.6.20
  * libgnokii updates
  o add support for Nokia 6070 and 2630
  o add a driver for PC/SC SIM card readers using libpcsclite;
  see Docs/README-PCSC for details
  o add two new phonebook memory types: SD for "Service Dialing
  Numbers" and BD for "Barred Dialing Numbers"
  o improve error messages while parsing config file
  o enhance error handling for parsing config
  o remove gn_file_text_save() from API
  o remove getline() replacement from compat.c
  o add gn_sms2mbox() function that converts SMS to mbox
  compliant format
  o add sanity checking for fwrite()/write() calls
  o make incoming buffer size for atbus link driver dynamically
  allocatable (was fixed size)
  o prevent strip_slashes() from stripping non-slashes
  * build system updates
  o add FAQ, KNOWN_BUGS and README-DKU2 to the list of files
  installed with "make install-docs" and remove
  gnokii-hackers-howto, gettext-howto and packaging-howto from
  that list
  o simplify Makefiles, remove obsolete targets
  o don't fail on parallel builds
  o fix compilation warnings
  o use standard paths for docdir and localedir
  * gnokii updates
  o add error handling for security commands
  o getprofile requires ringtone_list being allocated (Pawel Kot)
  o replace gn_file_text_save() with local writefile()
  o add getline() replacement to gnokii-utils.c
  o gnokii --getsms new --append-file/-a switch to append SMS
  to an existing file
  o gnokii --getsms -f/-F/-a use now mbox compliant format for
  stored sms, all sms read are stored in the same file
  o write more messages to stderr; the rule is that diagnostics
  indicating success or failure go to stderr, while information
  read from the phone goes to stdout
  o add sanity checking for fwrite()/write() calls
  * at driver updates
  o fix buffer size calculating in AT_WritePhonebook
  o fix SMS-SUBMIT parsing
  o calculate phonebook size for SonyEricsson: they don't answer
  with memory stats to AT+CPBS, calculate it by reading and
  counting entries (which is fast)
  o fix SetDateTime for Sony Ericsson, which requires timezone
  to be added
  * documentation updates
  o update Docs/protocol/nk6110.txt with another error code for
  "Get code status err"
  * nk6100 driver updates
  o add error code GN_ERR_SIMPROBLEM for --changesecuritycode
  * xgnokii updates
  o when exporting the phonebook to a file in raw format handle
  backslashes as escapes like in gnokii --getphonebook
  * link layer updates
  o make DKU-5 connection initialisation working again
  * translation updates
  o updated Italian translation and fixed Content-Type to match
  actual encoding of text which was UTF-8
* Tue Oct 09 2007 prusnak@suse.cz
- updated to 0.6.19
  * libgnokii updates
  o match declaration with definition
  o fix base64 encoding
  o read reference id from send sms reply and from delivery
  report
  o in gn_phonebook2ldif() output homePostalAddress when it isn't
  in a subentry
  o fix some typos
  o minor code cleanup in unixserial.c
  o some phones allow SMS location 0
  * build system updates
  o define u_int8_t where not present
  o include sys/time.h from gnokii.h
  o don't allow empty '-L' argument with Xlibs
  * gnokii updates
  o fix getallfiles
  o return non-zero error code when writephonebook fails
  o initialize networkinfo structure for --getnetworkinfo
  * xgnokii changes
  o try to avoid xgnokii freeze on exit for blacklisted phones;
  this is not a fix, just nasty workaround
  * nk6510 driver updates
  o fix segfault for sendsms
  * nk6100 driver updates
  o do not segfault when using --getsmsreader
  * atgen driver updates
  o Sony Ericsson phones can't do CREG=2 (only CREG=1), so just
  skip that and only do COPS in getnetworkinfo
* Thu Jul 26 2007 prusnak@suse.cz
- updated to 0.6.18
  * at driver updates
  o mark SMS messages as read/unread/sent/unsent where possible
  o fix battery level reading
  o add support for call notifications
  o add support for getActiveCalls
  o fix sms outbox reading
  o don't segfault if data->battery_unit is not allocated
  o add support for SMS notifications
  o fix in unsolicited messages handling
  o make SMS notifications more portable and move specific Nokia
  stuff to atnok.c
  * libgnokii updates
  o add void *callback_data argument to callbacks
  o use GN_CALL_MAX_PARALLEL instead of hardcode
  o add more sanity checks for sms reading
  o extend cell broadcast callback with gn_statemachine argument
  o fix splitting long messages
  o add support for occurrences field in calendar
  o add function for checking available connection types
  o fix memory leak in gn_sms_send() when sms_prepare() fails
  (found by valgrind) and pass on more return values from
  encode/decode functions
  o fix error message for "debug" option in gnokiirc: supported
  values have always been "off" and "on"
  * nk6510 driver updates
  o add support for incoming sms callbacks
  o add support for occurrences field in calendar
  o account for phonebook blocks not sent due to limited packet space
  o set of address blocks counts as one data block
  o treat Postal entries as addresses
  o when processing incoming phone book messages, skip unrelated
  errors
  o avoid duplicate phonebook subentries
  o speed up reading calendar entries
  * nokia_dku2 module updates
  o add N70 id and new endpoint addresses
  * nk6100 driver updates
  o add GN_OP_GetSMSFolders and GN_OP_GetSMSFolderStatus to
  support gnokii --showsmsfolderstatus
  * gnokii updates
  o update callback functions to match current libgnokii
  o add support for occurrences field in calendar
  * smsd updates
  o add support for multipart SMS for MySQL backend
* Fri Jun 22 2007 prusnak@suse.cz
- updated to 0.6.17 (see ChangeLog for all changes)
  * gnokii updates
  o do not open the log file when communication with phone is not
  needed; this fixes a memory leak found with valgrind
  o fix valgrind error "Conditional jump or move depends on
  uninitialised value(s)" in --getwapsetting
  o fix valgrind error "Conditional jump or move depends on
  uninitialised value(s)" in --getprofile
  o fix --divert options parsing
  o return an error if unexpected optional arguments are given to
  some commands and do stricter error checking
  o make --getphonebook output a telephone number in --ldif
  format even when there are no subentries
  o let foogle() access global data and state
  o fix command arguments handling for getting, setting and
  playing ringtones
  * libgnokii updates
  o fix memory leaks when config file has been open and memory
  allocated but [global] section or section given with --phone
  are not found (another valgrind finding)
  o in serial_close() fix valgrind warning "invalid file
  descriptor -1 in syscall close()" when serial_open() failed
  (eg. wrong permissions on /dev/ttyS0)
  o introduce use_locking field to config structure and fill it
  from the config file
  o make strings in cfgreader better translatable
  o use default values when incorrect option is given in the
  config file (where safe and possible)
  o for connection type dku2libusb treat port as the number of
  DKU2 USB endpoint; this is useful when you have more than
  one DKU2 phone connected to the computer; numbering goes
  from 1 upwards
  o in gn_file_phonebook_raw_parse() parse all the fields even if
  an empty name is given
* Wed May 16 2007 olh@suse.de
- Buildrequires libusb -> libusb-devel
  Remove unneded Requires libusb
* Wed May 09 2007 prusnak@suse.cz
- updated to 0.6.15 (see ChangeLog for all changes)
  * libgnokii changes
  o handle new type of phonebook number for ldif and vcard output
  o be more compliant with VCARD 3.0
  o add Nokia 6136 support
  o fix overflow when printing SMS date
  o add new phonebook entry types
  o for concatenated messages send the smallest part at the end
  o for concatenated unicode messages try not to split character
  across multiple parts
  o add support for Nokia 6233
  o fix segfault on contacts handling in AT driver for long names
  o improve INT_MAX detection
  o make gn_ical2calnote() and gn_ical2todo() print the parsed
  notes only when debug = on
  o don't invoke additional fcntls when with_async is set to 0,
  which is always
  o add extented phonebook support into public API
  o add file types into public API
  o add support for extented phonebook (not quite works yet)
  * gnokii updates
  o search for default config files if an empty filename is given
  to --config
  o fix --setdatetime segfault
  o fix --deletephonebook incorrect argument number counting
  o print phonebook entry number in case when there's no
  subentry
  o fix logo options segfaults
  o exit gnokii after --viewlogo or --listnetworks
  o compare network name with translated "unknown" string in logo
  operations too
  o make --getspeeddial and --setspeeddial print to stdout on
  success, not stderr
  o fix --getringtone parsing options
  o fix --sendsms usage string: -r is the short form of --report
  o use readtext() in savesms() too
- dropped obsolete patches:
  * cvs.patch (included in update)
  * fbusinit.patch (included in update)
  * maxlen.patch (included in update)
* Fri Feb 23 2007 prusnak@suse.cz
- backported code from CVS fixing buffer overflows (cvs.patch) [#237107]
- fixed 'array subscript out of range' (maxlen.patch)
* Wed Jan 24 2007 prusnak@suse.cz
- cleaned spec file and thus fixed build errors
* Wed Jan 03 2007 prusnak@suse.cz
- fixed uninitialised variable (fbusinit.patch) [#231178]
* Tue Dec 05 2006 prusnak@suse.cz
- moved xgnokii manpage from /usr/X11R6/man to %%{_mandir} [#225092]
* Mon Nov 13 2006 ro@suse.de
- really remove resmgr support
* Mon Nov 13 2006 mjancar@suse.cz
- disable resmgr patch (#218662)
* Mon Aug 28 2006 dgollub@suse.de
- update to 0.6.14
  * gnokii updates
  o added --config and --phone options
  o gnokii functions got splitted in several files
  o ...
  * libgnokii updates
  o added gn_wap_push functions
  o fixed encoding issue on 64bit systems
  o Nokia 6280 and 3220 support added
  o handle new types of telephone numbers
  o added functions to load config from alternate file
  o fixed serveral bugs
  o ...
  * utils updates
  o added 'waitcall' program which can be used in a script
  to get phone number of incoming call.
  o ...
  * nk6510 driver updates
  * nk6100 driver updates
  * documentation updates
  * translation updates
- removed wchar patch for 64bit systems
* Thu Aug 17 2006 ro@suse.de
- workaround missing makefile deps for parallel make
- call gettextize for mkinstalldirs problem
* Mon Jul 10 2006 dgollub@suse.de
- fixed encoding problem for 64bit systems (wrong wchar_t casting)
* Mon Jun 19 2006 dgollub@suse.de
- update to 0.6.13
  * libgnokii updates
  o added library layer
  o added GNOKII_API and GNOKII_DEPRECTAED
  o added support for caller groups
  o added encoding setup function for libgnokii
  o ...
  * nk6510 updates
  o added support for writing extended calendar information
  o Nokia 6680 support added
  o Nokia Series 40 support added
  * device layer updates
  o new libusb driver for dku2 cable (connection = dku2libusb)
  * gnokii, xgnokii, libgnokii bugfixes
- modified resmgr patch (added --enable-resmgr option)
- moved smsd manpages from -devel to -smsd package
- removed smsd libtool files
- moved pkgconfig and .la files to -devel package
- updated descriptions of -devel and -smsd package
- updated authors list
* Mon Jun 12 2006 poeml@suse.de
- update to 0.6.12
  * nk6510 driver updates
  o Nokia 6015i support added
  o Nokia 6101 support added
  o Nokia 6680 support added
  o Nokia 6235 over IrDA support
  * documentation updates
  o non Nokia phones are supported by AT driver -- express it
  more verbosively
  * atgen driver updates
  o identify should work on phones not supporting "AT+CGxx"
  commands
  * xgnokii, libgnokii, gnokiid bugfixes
- compile with libical instead of its own deprecated ical
  implementation
- compile with -fno-strict-aliasing
* Wed Jan 25 2006 mls@suse.de
- converted neededforbuild to BuildRequires
* Thu Jan 12 2006 mjancar@suse.cz
- update to 0.6.10
- compile with -fstack-protector
* Sat Sep 03 2005 matz@suse.de
- Put -lresmgr in the right place, so that libgnokii.so is linked
  against it. [fixes kdepim3 build]
* Tue Aug 30 2005 mjancar@suse.cz
- add resmgr support (#62927)
- branch devel subpackage
* Wed Aug 10 2005 sbrabec@suse.cz
- Do not require -devel packages.
* Mon Aug 01 2005 mjancar@suse.cz
- update to 0.6.8
* Tue Apr 26 2005 meissner@suse.de
- fixed 1 byte buffer overflow in sms number handling.
* Thu Apr 14 2005 mjancar@suse.cz
- fix for gcc 4.0
* Fri Feb 25 2005 mjancar@suse.cz
- update to 0.6.4
* Wed Dec 15 2004 hvogel@suse.de
- fix desktop file
* Tue Jul 13 2004 adrian@suse.de
- drop ical support again.
  libical gets dropped and the functionality is present in kmobile
* Mon Jul 05 2004 adrian@suse.de
- update to version 0.6.3
- enable bluetooth support
- enable ical support
- enable security support
* Thu Apr 08 2004 mjancar@suse.cz
- fix permissions verifying (#38641)
* Fri Feb 27 2004 mjancar@suse.cz
- update to 0.6.0
* Tue Feb 17 2004 adrian@suse.de
- fix Categories
* Thu Oct 30 2003 mjancar@suse.cz
- fix permissions
- no root for build
* Thu Oct 16 2003 mjancar@suse.cz
- fix segfault on exit (#32233)
* Fri Oct 10 2003 mjancar@suse.cz
- update to 0.5.5
* Fri Aug 15 2003 adrian@suse.de
- install icon and desktop file
* Fri Jun 20 2003 mjancar@suse.cz
- fix locales instalation
- use %%{run_ldconfig}
* Tue Jun 17 2003 mjancar@suse.cz
- update to 0.5.2
- kill obsolete patches
* Wed May 28 2003 ro@suse.de
- added smssend and ppm2nokia to filelists
* Mon Feb 17 2003 vbobek@suse.cz
- updated to version 0.5.0pre6
  * source cleanup
  * API improved
  * new features
  * more mobiles working with the driver
  * doc updated
  * bug fixes
  * added subpackage smsd
- added patch for compiling with -fPIC
* Tue Jul 30 2002 uli@suse.de
- build with -fPIC (fixes x86-64)
* Tue Jul 23 2002 stark@suse.de
- update to 0.4.2
- fixed type in Makefile
* Mon Jul 15 2002 stark@suse.de
- update to 0.4.1
- use %%{_libdir} for shared lib
* Fri Jul 12 2002 stark@suse.de
- update to 0.4.0
* Thu Jul 11 2002 meissner@suse.de
- auto* rerun.
* Mon Apr 29 2002 stark@suse.de
- update to 0.3.5
  * This version corrects the datacall problem introduced in 0.3.4.
  This version is only released because there is no stable
  version from the next gnokii series (0.4).
* Tue Mar 19 2002 stark@suse.de
- security update to 0.3.4 (#14960)
- removed suid-bit from mgnokiidev (-> permissions.easy)
* Mon Oct 01 2001 stark@suse.de
- use BuildRoot
- update to 0.3.3
- gnokii group is no longer needed -> uucp
- splitted package into gnokii and xgnokii
* Mon Sep 24 2001 stark@suse.de
- cleanup spec-file a bit
* Sun Sep 23 2001 stark@suse.de
- removed init-script (gnokiid has to be started for every
  connection)
- removed rc.config variables
* Sun Sep 23 2001 stark@suse.de
- moved rc-link to /etc/init.d
* Thu Jan 25 2001 tw@suse.de
- added an init-script to start gnokiid
- install the configuration file.
openSUSE Build Service is sponsored by