File libburnia.spec of Package libburnia

#
# spec file for package libburnia
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%define libburn_ver    0.9.0.pl00
%define libisoburn_ver 0.6.4.pl00
%define libisofs_ver   0.6.40

Name:           libburnia
Version:        %{libburn_ver}
Release:        3
License:        GPLv2+
Summary:        A project for reading, mastering and writing optical discs
Url:            http://libburnia-project.org/
Group:          Productivity/Multimedia/CD/Record
Source:         libburn-%{libburn_ver}.tar.bz2
Source1:        libisoburn-%{libisoburn_ver}.tar.bz2
Source2:        libisofs-%{libisofs_ver}.tar.bz2
BuildRequires:  libacl-devel
BuildRequires:  pkg-config
BuildRequires:  zlib-devel
BuildRoot:      %{_tmppath}/%{name}-%{version}-build

%description
Libburnia is a project for reading, mastering and writing optical discs.
Currently it is comprised of libraries named libisofs, libburn,
libisoburn, a cdrecord emulator named cdrskin, and xorriso, a tool for
creating and manipulating ISO 9660 filesystem images.

%package -n libburnia-tools
License:        GPLv2+
Summary:        Tools for Creating and Manipulating ISO 9660 Images and Writing Optical Media
Group:          Productivity/Multimedia/CD/Record
Requires(post): info
Requires(preun):info

%description -n libburnia-tools
Commandline tools provided by the libburnia project including cdrskin, a
cdrecord emulator, and xorriso, a tool for creating and manipulating ISO 9660
filesystem images.

%package -n libburnia-devel
License:        GPLv2+
Summary:        Development Files for libisofs, libburn, and libisoburn
Group:          Development/Libraries/C and C++
Requires:       libburn4 = %{libburn_ver}
Requires:       libisoburn1 = %{libisoburn_ver}
Requires:       libisofs6 = %{libisofs_ver}
Provides:       libburn-devel = %{libburn_ver}
Provides:       libisoburn-devel = %{libisoburn_ver}
Provides:       libisofs-devel = %{libisofs_ver}

%description -n libburnia-devel
Development files for developing application using libisofs, libburn,
and libisoburn.

%package -n libburn4
Version:        %{libburn_ver}
Release:        3
License:        GPLv2+
Summary:        Library for Writing Preformatted Data onto Optical Media
Group:          System/Libraries

%description -n libburn4
Libburn is a library for writing preformatted data onto optical media such as
CD, DVD, BD (Blu-Ray) and also offers a facility for reading data blocks from
its drives without using the normal block device I/O.

%package -n libisoburn1
Version:        %{libisoburn_ver}
Release:        4
License:        GPLv2+
Summary:        Frontend for libburn and libisofs
Group:          System/Libraries

%description -n libisoburn1
Libisoburn is a frontend for libraries libburn and libisofs which enables
creation and expansion of ISO-9660 filesystems on all CD/DVD/BD media supported
by libburn. This includes media like DVD+RW, which do not support multi-session
management on media level and even plain disk files or block devices.  Since it
specializes on data files in ISO-9660 filesystem images it is not suitable for
audio (CD-DA) or any other CD layout which does not entirely consist of
ISO-9660 sessions.

%package -n libisofs6
Version:        %{libisofs_ver}
Release:        3
License:        GPLv2+
Summary:        Library for Creating ISO-9660 Filesystems
Group:          System/Libraries

%description -n libisofs6
Libisofs is a library for creating ISO-9660 filesystems with extensions like
RockRidge or Joliet. It is also a full featured ISO-9660 editor, allowing you
to modify an ISO image or multisession disc, including file addition/removal,
change of file names and attributes, etc.

ISO-9660 images can be made bootable from CD, DVD, or BD via an El Torito boot
record and appropriate boot image files from boot managers like GRUB, ISOLINUX,
or system specific boot loaders. It is also possible to install a Master Boot
Record for hard-disk-like media, e.g. USB memory sticks.

Libisofs supports the extension AAIP which allows to store ACLs and xattr in
ISO-9660 filesystems and zisofs compression which is transparently uncompressed
by some Linux kernels. It is possible to have data file content compressed to
gzip format or to have it filtered by an external process.

%prep
%setup -q -a 0 -a 1 -a 2 -c -T

%build
TEMP_ROOT=`mktemp -d`
export C_INCLUDE_PATH="$TEMP_ROOT%{_includedir}"
export LIBRARY_PATH="$TEMP_ROOT%{_libdir}"
export PKG_CONFIG_PATH="$TEMP_ROOT%{_libdir}/pkgconfig"

cd libburn-%(echo %{libburn_ver} | sed 's/\(.*\)\.pl[0-9]\+/\1/')
%configure --disable-static
make %{?_smp_mflags}
make DESTDIR=$TEMP_ROOT install
rm -f $TEMP_ROOT%{_libdir}/*.la

cd ../libisofs-%{libisofs_ver}
%configure --disable-static
make %{?_smp_mflags}
make DESTDIR=$TEMP_ROOT install
rm -f $TEMP_ROOT%{_libdir}/*.la

cd ../libisoburn-%(echo %{libisoburn_ver} | sed 's/\(.*\)\.pl[0-9]\+/\1/')
%configure --disable-static
make %{?_smp_mflags}
make DESTDIR=$TEMP_ROOT install
rm -f $TEMP_ROOT%{_libdir}/*.la

%install
cd libburn-%(echo %{libburn_ver} | sed 's/\(.*\)\.pl[0-9]\+/\1/')
%make_install
cd ../libisofs-%{libisofs_ver}
%make_install
cd ../libisoburn-%(echo %{libisoburn_ver} | sed 's/\(.*\)\.pl[0-9]\+/\1/')
%make_install
rm -f %{buildroot}%{_libdir}/*.la

%clean
rm -rf %{buildroot}

%post -n libburn4 -p /sbin/ldconfig

%postun -n libburn4 -p /sbin/ldconfig

%post -n libisoburn1 -p /sbin/ldconfig

%postun -n libisoburn1 -p /sbin/ldconfig

%post -n libisofs6 -p /sbin/ldconfig

%postun -n libisofs6 -p /sbin/ldconfig

%post -n libburnia-tools
%install_info --info-dir=%{_infodir} %{_infodir}/%{name}.info*

%preun -n libburnia-tools
%install_info_delete --info-dir=%{_infodir} %{_infodir}/%{name}.info*

%files -n libburnia-tools
%defattr(-,root,root)
%{_bindir}/cdrskin
%{_bindir}/osirrox
%{_bindir}/xorrecord
%{_bindir}/xorriso
%{_bindir}/xorrisofs
%{_infodir}/xorriso.info*
%{_mandir}/man1/cdrskin.1*
%{_mandir}/man1/xorriso.1*

%files -n libburnia-devel
%defattr(-,root,root)
%{_includedir}/libburn
%{_includedir}/libisoburn
%{_includedir}/libisofs
%{_libdir}/pkgconfig/libburn-1.pc
%{_libdir}/pkgconfig/libisoburn-1.pc
%{_libdir}/pkgconfig/libisofs-1.pc
%{_libdir}/*.so

%files -n libburn4
%defattr(-,root,root)
%doc libburn-%(echo %{libburn_ver} | sed 's/\(.*\)\.pl[0-9]\+/\1/')/{AUTHORS,CONTRIBUTORS,COPYING,COPYRIGHT,README}
%{_libdir}/libburn.so.*

%files -n libisoburn1
%defattr(-,root,root)
%doc libisoburn-%(echo %{libisoburn_ver} | sed 's/\(.*\)\.pl[0-9]\+/\1/')/{AUTHORS,COPYING,COPYRIGHT,README,TODO}
%{_libdir}/libisoburn.so.*

%files -n libisofs6
%defattr(-,root,root)
%doc libisofs-%{libisofs_ver}/{AUTHORS,COPYING,COPYRIGHT,NEWS,README,TODO}
%{_libdir}/libisofs.so.*

%changelog
openSUSE Build Service is sponsored by