File mutt.spec of Package mutt.import4421

#
# spec file for package mutt
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

# norootforbuild


Name:           mutt
#!BuildIgnore: sendmail
BuildRequires:  cyrus-sasl-devel cyrus-sasl-gssapi docbook-xsl-stylesheets docbook_4 gdbm-devel glibc-i18ndata ispell krb5-devel libcom_err libgcrypt libgpg-error-devel libidn-devel libxml2 libxslt lynx ncurses-devel openssl-devel postfix sgml-skel update-desktop-files xli
#if
%if 0%{?suse_version} > 1130
BuildRequires:  libassuan-devel libgpgme-devel
%else
BuildRequires:  gpgme-devel
%endif
License:        GPLv2+
Group:          Productivity/Networking/Email/Clients
Url:            http://www.mutt.org
Provides:       muttssl
Obsoletes:      muttssl
Recommends:     smtp_daemon
%if 0%{?suse_version} > 1130
Requires(post):   shared-mime-info
Requires(postun): shared-mime-info
%endif
# NOTE: We don't want this dependency and desktop-data-SuSE is in all
# desktop selections.
#Requires:    desktop-data-SuSE
AutoReqProv:    on
Version:        1.5.21
Release:        14.<RELEASE15>
Summary:        Mail Program
# ftp://ftp.mutt.org/mutt/devel/
Source0:        %name-%version.tar.bz2
Source1:        Signature_conversion
Source2:        README.alternates
Source3:        mutt.png
Source4:        mutt.desktop
Source5:        skel.muttrc
Source6:        krb5-config
Source7:        mutt-1.5.21.de.po
Patch:          %name-%version.dif
# http://www.spinnaker.de/mutt/compressed/
Patch1:         patch-%version.rr.compressed.1.bz2
Patch2:         %name-1.5.9i-pgpewrap.diff
Patch3:         %name-1.5.20-sendgroupreplyto.diff
Patch4:         %name-1.5.15-wrapcolumn.diff
Patch5:         patch-1.5.5.1.nt.xtitles.3.ab.1
# http://lunar-linux.org/index.php?page=mutt-sidebar
Patch6:         patch-1.5.21.sidebar-aa6aa.txt.bz2
Patch7:         mutt-1.5.21.sidebar-fix.dif
Patch8:         mutt-1.5.21-opennfs.dif
Patch9:         mutt-1.5.20-gpgme_set_locale.patch
Patch10:        bug-676388-largefile.patch
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
%global         _sysconfdir %{_sysconfdir}

%description
A very powerful mail user agent. It supports (among other nice things)
highlighting, threading, and PGP. It takes some time to get used to,
however.

%prep
%setup -q -n mutt-%version
%patch
%patch1 -p1
%patch2 -p0
%patch3 -p1
%patch4 -p0
%patch5 -p1 
%patch6 -p1
%patch7 -p0
%patch8 -p0 
%patch9 -p1
%patch10 -p1

cp doc/Muttrc Muttrc.SuSE
cp %{S:2} .

%build
autoreconf -fi
CC=gcc
CFLAGS="-Wall $RPM_OPT_FLAGS -I. -D_GNU_SOURCE -fno-strict-aliasing"
CFLAGS="$CFLAGS -fstack-protector"
#CFLAGS="$CFLAGS -DSUSE_IMAP_FORCE_SSL"
KRB5CFGPATH=%{S:6}
export CC CFLAGS KRB5CFGPATH
chmod 755 $KRB5CFGPATH
./configure $RPM_ARCH-suse-linux \
	--prefix=%{_prefix} \
	--datadir=%{_datadir} \
	--sysconfdir=%{_sysconfdir} \
	--mandir=%_mandir \
	--with-docdir=%_defaultdocdir/%name \
	--enable-imap \
	--enable-pop \
	--enable-pgp \
	--enable-gpgme \
	--enable-nfs-fix \
	--enable-mailtool \
	--enable-compressed \
	--disable-external-dotlock \
	--with-ssl=%{_prefix} \
	--with-sasl=%{_prefix} \
	--with-gss=%{_prefix} \
	--with-regex \
	--enable-smtp \
	--enable-hcache \
	--with-idn
make -C doc clean
make -C po update-po
cp %{S:7} po/de.po
make
make -C doc

%install
make install DESTDIR=$RPM_BUILD_ROOT
mv Muttrc.SuSE $RPM_BUILD_ROOT%{_sysconfdir}/Muttrc
install -m 755 %{S:1} $RPM_BUILD_ROOT%{_bindir}
gzip -9 doc/manu*.txt
rm -f contrib/Makefile*
# datadir not automatically created:
mkdir -p $RPM_BUILD_ROOT%{_datadir}/mutt
# mbox/mmdf manual page conflicts with the one from tin, so rename it
mv $RPM_BUILD_ROOT%_mandir/man5/mbox.5 \
   $RPM_BUILD_ROOT%_mandir/man5/mbox_mutt.5
mv $RPM_BUILD_ROOT%_mandir/man5/mmdf.5 \
   $RPM_BUILD_ROOT%_mandir/man5/mmdf_mutt.5
   %find_lang %name
# We get mime.types from aaa_base
rm -f $RPM_BUILD_ROOT%{_sysconfdir}/mime.types
# Mutt BTS is gone
rm -f $RPM_BUILD_ROOT/%_mandir/man1/{flea*,muttbug*}
rm -f $RPM_BUILD_ROOT%{_bindir}/{flea,muttbug}
rm -f $RPM_BUILD_ROOT%{_sysconfdir}/Muttrc.dist
rm -f $RPM_BUILD_ROOT%{_sysconfdir}/mime.types.dist
mkdir -p $RPM_BUILD_ROOT%{_datadir}/pixmaps
install -m 644 %{SOURCE3} $RPM_BUILD_ROOT%{_datadir}/pixmaps/
mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
install -m 644 %{SOURCE4} $RPM_BUILD_ROOT%{_datadir}/applications/
install -D -m 644 %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/skel/.muttrc
%suse_update_desktop_file mutt

%if 0%{?suse_version} > 1130

%post
%mime_database_post

%postun
%mime_database_postun
%endif

%clean
rm -rf $RPM_BUILD_ROOT

%files -f %name.lang
%defattr(-,root,root)
%doc doc/manual*.html doc/manual.txt.gz COPYRIGHT INSTALL README* NEWS TODO
%doc doc/PGP-Notes.txt doc/applying-patches.txt doc/devel-notes.txt
%doc contrib/
%config(noreplace) %{_sysconfdir}/skel/.muttrc
%{_bindir}/mutt
%{_bindir}/pgpewrap
%{_bindir}/pgpring
%{_bindir}/smime_keys
%{_bindir}/Signature_conversion
%{_datadir}/applications/*.desktop
%{_datadir}/pixmaps/mutt.png
%_mandir/man1/mutt.1.gz
%_mandir/man1/smime_keys.1.gz
%_mandir/man5/mmdf_mutt.5.gz
%_mandir/man5/muttrc.5.gz
%_mandir/man5/mbox_mutt.5.gz
%{_datadir}/mutt
%config(noreplace) %{_sysconfdir}/Muttrc

%changelog
openSUSE Build Service is sponsored by