File pango.spec of Package pango

#
# spec file for package pango
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


# When updating the binary version, do not forget to also update baselibs.conf
%define pango_binary_version 1.6.0

Name:           pango
License:        LGPLv2.1+
Group:          System/Libraries
Version:        1.28.3
Release:        3.<RELEASE2>
# NOTE: on upgrade to a new upstream version, change the Obsoletes from <= to < (here and in baselibs.conf)
Summary:        Library for Layout and Rendering of Text
Source:         ftp://ftp.gnome.org/pub/GNOME/sources/pango/1.18/%{name}-%{version}.tar.bz2
Source1:        README.SuSE
Source2:        macros.pango
Source99:       baselibs.conf
# PATCH-FIX-UPSTREAM pango64.patch bgo129534 -- needed for biarch. Unfortunately, this is not good enough for usptream.
Patch0:         pango64.patch
# PATCH-FIX-UPSTREAM pango-CVE-2011-0020.patch bnc#666101 CVE-2011-0020 vuntz@opensuse.org -- heap corruption in font parsing with FreeType2 backend
Patch1:         pango-CVE-2011-0020.patch
# PATCH-FIX-UPSTREAM pango-CVE-2011-0064.patch bnc#672502 CVE-2011-0064. vuntz@opensuse.org -- handle realloc failure in the buffer
Patch2:         pango-CVE-2011-0064.patch
BuildRequires:  gcc-c++
BuildRequires:  gtk-doc
BuildRequires:  pkg-config
BuildRequires:  pkgconfig(cairo)
BuildRequires:  pkgconfig(fontconfig)
BuildRequires:  pkgconfig(freetype2)
BuildRequires:  pkgconfig(gobject-2.0)
BuildRequires:  pkgconfig(gobject-introspection-1.0)
BuildRequires:  pkgconfig(libthai)
BuildRequires:  pkgconfig(xft)
BuildRequires:  pkgconfig(xrender)
BuildRoot:      %{_tmppath}/%{name}-%{version}-build

%description
Pango is a library for layout and rendering of text, with an emphasis
on internationalization. It can be used anywhere that text layout
is needed.

Pango forms the core of text and font handling for GTK+.

%package -n libpango-1_0-0
License:        LGPLv2.1+
Summary:        Library for Layout and Rendering of Text
Group:          System/Libraries
Requires(post): %{name}-tools
Provides:       %{name} = %{version}
# Note: we keep <= (and a rpmlint warning...) until we get a version higher than 1.28.3 (when this provides/obsoletes was introduced)
Obsoletes:      %{name} <= %{version}
# bug437293
%ifarch ppc64
Obsoletes:      pango-64bit
%endif
#

%description -n libpango-1_0-0
Pango is a library for layout and rendering of text, with an emphasis
on internationalization. It can be used anywhere that text layout
is needed.

Pango forms the core of text and font handling for GTK+.

%package tools
License:        LGPLv2.1+
Summary:        Library for Layout and Rendering of Text -- Tools
Group:          System/Libraries

%description tools
Pango is a library for layout and rendering of text, with an emphasis
on internationalization. It can be used anywhere that text layout
is needed.

Pango forms the core of text and font handling for GTK+.

%package module-thai-lang
License:        LGPLv2.1+
Summary:        Library for Layout and Rendering of Text -- Module for the Thai Language
Group:          System/Libraries
Requires(post): %{name}-tools
Requires(postun): %{name}-tools
Provides:       locale(pango:th_TH)

%description module-thai-lang
Pango is a library for layout and rendering of text, with an emphasis
on internationalization. It can be used anywhere that text layout
is needed.

Pango forms the core of text and font handling for GTK+.

%package devel
License:        LGPLv2.1+
Requires:       libpango-1_0-0 = %{version}
Summary:        Library for Layout and Rendering of Text -- Development Files
Group:          Development/Libraries/GNOME
# bug437293
%ifarch ppc64
Obsoletes:      pango-devel-64bit
%endif
Obsoletes:      pango-doc <= %{version}
Provides:       pango-doc = %{version}

%description devel
Pango is a library for layout and rendering of text, with an emphasis
on internationalization. It can be used anywhere that text layout
is needed.

Pango forms the core of text and font handling for GTK+.

This package contains all necessary include files and libraries needed
to develop applications that require these.

%prep
%setup -q
%if "%_lib" == "lib64"
cp -a %{S:1} .
%patch0 -p0
%endif
%patch1 -p1
%patch2 -p1

%build
%configure --disable-static --with-pic
make %{?jobs:-j%jobs}

%install
%makeinstall
find %{buildroot}%{_libdir} -name '*.la' -type f -delete -print
touch %{buildroot}%{_sysconfdir}/pango/pango.modules
%if "%_lib" == "lib64"
mv %{buildroot}%{_bindir}/pango-querymodules %{buildroot}%{_bindir}/pango-querymodules-64
mv %{buildroot}%{_sysconfdir}/pango/pango.modules %{buildroot}%{_sysconfdir}/pango/pango64.modules
%endif
# Install rpm macros
mkdir -p %{buildroot}%{_sysconfdir}/rpm
cp %{S:2} %{buildroot}%{_sysconfdir}/rpm

%clean
rm -rf %{buildroot}

###########################################################################
# Note: when updating scriptlets, don't forget to also update baselibs.conf
###########################################################################

# Convenient %define for the scriplets
%if "%_lib" == "lib64"
%define _pango_querymodules %{_bindir}/pango-querymodules-64
%define _pango_querymodules_update_cache %{_pango_querymodules} > %{_sysconfdir}/pango/pango64.modules
%else
%define _pango_querymodules %{_bindir}/pango-querymodules
%define _pango_querymodules_update_cache %{_pango_querymodules} > %{_sysconfdir}/pango/pango.modules
%endif

%post -n libpango-1_0-0
/sbin/ldconfig
%if 0
# In case libpango-1_0-0 gets installed before pango-tools, we don't want to
# fail. So we make the call to pango-querymodules dependent on the existence of
# the binary. This is why we also have a %post for pango-tools.
%endif
if test -f %{_pango_querymodules}; then
  %{_pango_querymodules_update_cache}
fi

%if 0
# No need to call pango-querymodules in postun:
# - if it's an upgrade, it will have been called in post
# - if it's an uninstall, we don't care about this anymore
%endif

%postun -n libpango-1_0-0 -p /sbin/ldconfig

%post module-thai-lang
%{_pango_querymodules_update_cache}

%postun module-thai-lang
%{_pango_querymodules_update_cache}

%post tools
%if 0
# If we install pango-tools for the first time, then we should run it in case
# libpango-1_0-0 was installed first (ie, if
# %{_libdir}/pango/%{pango_binary_version} already exists) which means
# pango-querymodules couldn't run there.
%endif
if [ $1 == 1 ]; then
  test -d %{_libdir}/pango/%{pango_binary_version}
  if test $? -eq 0; then
    %{_pango_querymodules_update_cache}
  fi
fi

%files -n libpango-1_0-0
%defattr(-,root,root)
%if "%_lib" == "lib64"
%doc README AUTHORS COPYING ChangeLog README.SuSE
%else
%doc README AUTHORS COPYING ChangeLog
%endif
%dir %{_libdir}/pango
%dir %{_libdir}/pango/%{pango_binary_version}
%dir %{_libdir}/pango/%{pango_binary_version}/modules
%{_libdir}/pango/%{pango_binary_version}/modules/pango-arabic-fc.so
%{_libdir}/pango/%{pango_binary_version}/modules/pango-arabic-lang.so
%{_libdir}/pango/%{pango_binary_version}/modules/pango-basic-fc.so
%{_libdir}/pango/%{pango_binary_version}/modules/pango-basic-x.so
%{_libdir}/pango/%{pango_binary_version}/modules/pango-hangul-fc.so
%{_libdir}/pango/%{pango_binary_version}/modules/pango-hebrew-fc.so
%{_libdir}/pango/%{pango_binary_version}/modules/pango-indic-fc.so
%{_libdir}/pango/%{pango_binary_version}/modules/pango-indic-lang.so
%{_libdir}/pango/%{pango_binary_version}/modules/pango-khmer-fc.so
%{_libdir}/pango/%{pango_binary_version}/modules/pango-syriac-fc.so
%{_libdir}/pango/%{pango_binary_version}/modules/pango-thai-fc.so
%{_libdir}/pango/%{pango_binary_version}/modules/pango-tibetan-fc.so
%{_libdir}/lib*.so.*
%{_libdir}/girepository-1.0/Pango-1.0.typelib
%{_libdir}/girepository-1.0/PangoCairo-1.0.typelib
%{_libdir}/girepository-1.0/PangoFT2-1.0.typelib
%{_libdir}/girepository-1.0/PangoXft-1.0.typelib
%dir %{_sysconfdir}/pango
%{_sysconfdir}/pango/pangox.aliases
%if "%_lib" == "lib64"
%ghost %{_sysconfdir}/pango/pango64.modules
%else
%ghost %{_sysconfdir}/pango/pango.modules
%endif

%files tools
%defattr(-, root, root)
%{_bindir}/pango-querymodules*
%{_bindir}/pango-view
%doc %{_mandir}/man1/pango-querymodules.1*
%doc %{_mandir}/man1/pango-view.1*

# We have this module in a subpackage because it requires additional libraries.

%files module-thai-lang
%defattr(-, root, root)
%{_libdir}/pango/%{pango_binary_version}/modules/pango-thai-lang.so

%files devel
%defattr(-, root, root)
%{_libdir}/lib*.so
%{_libdir}/pkgconfig/*.pc
%{_includedir}/pango-1.0/
%{_datadir}/gir-1.0/*.gir
%doc %{_datadir}/gtk-doc/html/pango/
%{_sysconfdir}/rpm/macros.pango

%changelog
openSUSE Build Service is sponsored by