File python-boto.spec of Package python-boto

#
# spec file for package python-boto (Version 2.0)
#
# Copyright (c) 2010 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%define modname boto

Name:           python-%{modname}
Version:        2.0
Release:        1
%define extraver b3
License:        MIT
Summary:        Python interface to Amazon Web Services
Url:            http://code.google.com/p/boto/
Group:          Development/Libraries/Python
Source:         %{modname}-%{version}%{extraver}.tar.bz2
BuildRequires:  python-setuptools
BuildRequires:  pyxml
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
%{py_requires}
%if %{?suse_version: %{suse_version} > 1110} %{!?suse_version:1}
BuildArch:      noarch
%endif

%description
An integrated interface to current and future infrastructural services offered by Amazon Web Services. Currently, this includes:

    * Simple Storage Service (S3)
    * Simple Queue Service (SQS)
    * Elastic Compute Cloud (EC2)
    * Mechanical Turk
    * SimpleDB
    * CloudFront

Author:
--------
        Mitch Garnaat <mitch@garnaat.com>

%prep
%setup -q -n %{modname}-%{version}%{extraver}

%build
export CFLAGS="%{optflags}"
%{__python} setup.py build

%install
%{__python} setup.py install --prefix=%{_prefix} --root=%{buildroot} --record-rpm=INSTALLED_FILES

%clean
%{__rm} -rf %{buildroot}

%files -f INSTALLED_FILES
%defattr(-,root,root)
%doc README

%changelog
openSUSE Build Service is sponsored by