File webyast-licenses-ui.spec of Package webyast-licenses-ui

#
# spec file for package webyast-licenses-ui
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#



Name:           webyast-licenses-ui
Recommends:     WebYaST(org.opensuse.yast.modules.eulas)
Provides:       yast2-webclient-eulas = %{version}
Obsoletes:      yast2-webclient-eulas < %{version}
PreReq:         yast2-webclient >= 0.0.2
License:        GPLv2
Group:          Productivity/Networking/Web/Utilities
Url:            http://en.opensuse.org/Portal:WebYaST
AutoReqProv:    on
Version:        0.2.2
Release:        1
Summary:        WebYaST - license management UI
Source:         www.tar.bz2
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildArch:      noarch
BuildRequires:  rubygem-mocha rubygem-test-unit rubygem-webyast-rake-tasks webyast-base-ui-testsuite
BuildRequires:  ruby
BuildRequires:  yast2-webclient

#
%define plugin_name eulas
%define plugin_dir %{webyast_ui_dir}/vendor/plugins/%{plugin_name}
#

%package testsuite
License:        GPLv2
Group:          Productivity/Networking/Web/Utilities
Requires:       %{name} = %{version}
Requires:       webyast-base-ui-testsuite rubygem-mocha rubygem-test-unit
Summary:        Testsuite for webyast-licenses-ui package

%description
WebYaST - Plugin providing UI for license management.

Authors:
--------
    Martin Kudlvasr <mkudlvasr@suse.cz>
    Josef Reidinger <jreidinger@suse.cz>

%description testsuite
This package contains complete testsuite for webyast-licenses-ui package.
It is only needed for verifying the functionality of the module
and it is not needed at runtime.

%prep
%setup -q -n www

%build
export RAILS_PARENT=%{webyast_ui_dir}
env LANG=en rake makemo

%check
%webyast_ui_check

%install

#
# Install all web and frontend parts.
#
mkdir -p $RPM_BUILD_ROOT/%{plugin_dir}
cp -a * $RPM_BUILD_ROOT/%{plugin_dir}
rm -f $RPM_BUILD_ROOT/%{plugin_dir}/COPYING

# remove .po files (no longer needed)
rm -rf $RPM_BUILD_ROOT/%{plugin_dir}/po
# search locale files
%find_lang webyast-licenses-ui

%clean
rm -rf $RPM_BUILD_ROOT

%files -f webyast-licenses-ui.lang
%defattr(-,root,root)
%dir %{webyast_ui_dir}
%dir %{webyast_ui_dir}/vendor
%dir %{webyast_ui_dir}/vendor/plugins
%dir %{plugin_dir}
%dir %{plugin_dir}/locale
%dir %{plugin_dir}/config
%dir %{plugin_dir}/doc
%{plugin_dir}/README
%{plugin_dir}/Rakefile
%{plugin_dir}/init.rb
%{plugin_dir}/install.rb
%{plugin_dir}/uninstall.rb
%{plugin_dir}/app
%{plugin_dir}/lib
%{plugin_dir}/config/rails_parent.rb
%{plugin_dir}/doc/README_FOR_APP
%doc COPYING

%files testsuite
%defattr(-,root,root)
%{plugin_dir}/test

%changelog
openSUSE Build Service is sponsored by