File yast2-installation.spec of Package yast2-installation

#
# spec file for package yast2-installation
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

# norootforbuild


Name:           yast2-installation
Version:        2.20.5
Release:        1.<RELEASE2>

BuildRoot:      %{_tmppath}/%{name}-%{version}-build
Source0:        yast2-installation-2.20.5.tar.bz2

Prefix:         /usr

Group:          System/YaST
License:        GPLv2+
BuildRequires:  docbook-xsl-stylesheets doxygen libxslt perl-XML-Writer sgml-skel update-desktop-files yast2-core-devel yast2-devtools yast2-testsuite

# FileSystems::possible_root_fs
BuildRequires:  yast2-storage >= 2.19.12

# xmllint
BuildRequires:  libxml2

# to convert control.rnc o control.rng
BuildRequires:  trang

# PackageCallbacks::RegisterEmptyProgressCallbacks()
BuildRequires:  yast2 >= 2.16.52

# Pkg::SourceProvideDigestedFile() 
BuildRequires:  yast2-pkg-bindings >= 2.17.25

# Unified progress bar (done by visnov) 
BuildRequires:  yast2-packager >= 2.17.9

# AutoinstConfig::getProposalList
Requires:       autoyast2-installation >= 2.17.1

# ProductControl::DisabledACItems, ::DisabledSubProposals
Requires:       yast2 >= 2.18.23

# Language::GetLanguageItems and other API
# Language::Set (handles downloading the translation extensions)
Requires:       yast2-country-data >= 2.16.11

# Pkg::SourceProvideDigestedFile() 
Conflicts:      yast2-pkg-bindings < 2.17.25

# Mouse-related scripts moved to yast2-mouse
Conflicts:      yast2-mouse < 2.18.0

# New API for ProductLicense
Requires:       yast2-packager >= 2.19.2

# FileSystems::possible_root_fs
Requires:       yast2-storage >= 2.19.12

# use in startup scripts
Requires:       initviocons

# Only in inst-sys
# Requires:	yast2-network
# Requires:	yast2-add-on
# Requires:	yast2-update

# Pkg::SourceProvideSignedFile Pkg::SourceProvideDigestedFile
# pkg-bindings are not directly required
Conflicts:      yast2-pkg-bindings < 2.17.25

# InstError
Conflicts:      yast2 < 2.18.6

# Added new function WFM::ClientExists
Conflicts:      yast2-core < 2.17.10

# ButtonBox widget
Conflicts:      yast2-ycp-ui-bindings < 2.17.3

# tar-gzip some system files and untar-ungzip them after the installation (FATE #300421, #120103)
Requires:       tar gzip
Requires:       coreutils

# for the first/second stage of installation
# currently not used
# bugzilla #208307
#Requires:	/usr/bin/jpegtopnm
#Requires:	/usr/bin/pnmtopng

# BNC 446533, /sbin/lspci called but not installed
Requires:       pciutils

Recommends:     yast2-registration
Recommends:     yast2-online-update
Recommends:     yast2-users
Recommends:     yast2-firewall
Recommends:     release-notes
Recommends:     curl
Recommends:     yast2-update
Recommends:     yast2-add-on

PreReq:         %fillup_prereq

BuildArch:      noarch

Summary:        YaST2 - Installation Parts

%package devel-doc
License:        GPLv2+
Group:          Documentation/HTML
Requires:       yast2-installation >= 2.15.34

PreReq:         %fillup_prereq

Summary:        YaST2 - Installation Parts

%description
System installation code as present on installation media.

%description devel-doc
System installation code as present on installation media.

%prep
%setup -n yast2-installation-2.20.5

%build
%{prefix}/bin/y2tool y2autoconf
%{prefix}/bin/y2tool y2automake
autoreconf --force --install

export CFLAGS="$RPM_OPT_FLAGS -DNDEBUG"
export CXXFLAGS="$RPM_OPT_FLAGS -DNDEBUG"

%{?suse_update_config:%{suse_update_config -f}}
./configure --libdir=%{_libdir} --prefix=%{prefix} --mandir=%{_mandir}
# V=1: verbose build in case we used AM_SILENT_RULES(yes)
# so that RPM_OPT_FLAGS check works
make %{?jobs:-j%jobs} V=1

%install
make install DESTDIR="$RPM_BUILD_ROOT"
[ -e "%{prefix}/share/YaST2/data/devtools/NO_MAKE_CHECK" ] || Y2DIR="$RPM_BUILD_ROOT/usr/share/YaST2" make check DESTDIR="$RPM_BUILD_ROOT"
for f in `find $RPM_BUILD_ROOT/%{prefix}/share/applications/YaST2/ -name "*.desktop"` ; do
    d=${f##*/}
    %suse_update_desktop_file -d ycc_${d%.desktop} ${d%.desktop}
done

for f in `find %{buildroot}%{_datadir}/autoinstall/modules -name "*.desktop"`; do
    %suse_update_desktop_file $f
done 

%clean
rm -rf "$RPM_BUILD_ROOT"

%post
%{fillup_only -ns security checksig}

%files
%defattr(-,root,root)
%dir /usr/share/YaST2/control
/usr/share/YaST2/control/*.xml
# Fixme: move to another package (to make build of other packages faster)
/usr/share/YaST2/control/*.rng
/usr/share/YaST2/control/*.rnc

/usr/share/YaST2/clients/*.ycp
/usr/share/YaST2/modules/*.ycp
/usr/share/YaST2/modules/*.ybc
%{prefix}/share/applications/YaST2/*.desktop
/usr/share/autoinstall/modules/*.desktop
/usr/share/YaST2/schema/autoyast/rnc/deploy_image.rnc
%dir /usr/share/autoinstall
%dir /usr/share/autoinstall/modules
%dir /usr/share/YaST2/include/installation
/usr/share/YaST2/include/installation/*

# agents
/usr/share/YaST2/scrconf/etc_passwd.scr
/usr/share/YaST2/scrconf/cfg_boot.scr
/usr/share/YaST2/scrconf/cfg_windowmanager.scr
/usr/share/YaST2/scrconf/cfg_fam.scr
/usr/share/YaST2/scrconf/etc_install_inf.scr
/usr/share/YaST2/scrconf/etc_install_inf_alias.scr
/usr/share/YaST2/scrconf/etc_install_inf_options.scr
/usr/share/YaST2/scrconf/proc_modules.scr
/usr/share/YaST2/scrconf/run_df.scr
# fillup
/var/adm/fillup-templates/sysconfig.security-checksig

# programs and scripts
%{prefix}/lib/YaST2/startup

# icewm
/etc/icewm

%dir %{prefix}/share/doc/packages/yast2-installation
%{prefix}/share/doc/packages/yast2-installation/COPYING
%readme %{prefix}/share/doc/packages/yast2-installation/README

%files devel-doc
%defattr(-,root,root)
%doc %{prefix}/share/doc/packages/yast2-installation
%exclude %{prefix}/share/doc/packages/yast2-installation/COPYING
%exclude %{prefix}/share/doc/packages/yast2-installation/README

%changelog
openSUSE Build Service is sponsored by