File yast2-ruby-bindings.spec of Package yast2-ruby-bindings

#
# spec file for package yast2-ruby-bindings (Version 0.3.5)
#
# Copyright (c) 2009 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

# norootforbuild


Name:           yast2-ruby-bindings
Version:        0.3.5
Release:        1
License:        GPL
Group:          System/YaST
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
Source0:        yast2-ruby-bindings-%{version}.tar.bz2
Prefix:         /usr
BuildRequires:  cmake gcc-c++ libxcrypt-devel swig yast2-core-devel
BuildRequires:  yast2-devtools >= 2.16.3
# libzypp-devel is missing .la requires
BuildRequires:  ruby-devel
Requires:       yast2-core >= 2.16.37
BuildRequires:  yast2-core-devel >= 2.16.37
Requires:       yast2-ycp-ui-bindings       >= 2.16.37
BuildRequires:  yast2-ycp-ui-bindings-devel >= 2.16.37
Requires:       ruby
Summary:        Ruby bindings for the YaST platform

%description
The bindings allow YaST modules to be written using the Ruby language
and also Ruby scripts can use YaST agents, APIs and modules.

%prep
%setup -n yast2-ruby-bindings-%{version}

%build
mkdir build
cd build
cmake -DCMAKE_INSTALL_PREFIX=%{prefix} \
      -DLIB=%{_lib} \
      -DCMAKE_C_FLAGS="%{optflags}" \
      -DCMAKE_CXX_FLAGS="%{optflags}" \
      -DCMAKE_BUILD_TYPE=Release \
      -DCMAKE_SKIP_RPATH=1 \
      ..
make %{?jobs:-j %jobs}

%install
cd build
make install DESTDIR=$RPM_BUILD_ROOT
cd ..

%clean
rm -rf "$RPM_BUILD_ROOT"

%files
%defattr (-, root, root)
%{_libdir}/YaST2/plugin/libpy2lang_ruby.so
%{_libdir}/ruby/vendor_ruby/%{rb_ver}/ycp.rb
%{_libdir}/ruby/vendor_ruby/%{rb_ver}/%{rb_arch}/ycpx.so
%changelog
openSUSE Build Service is sponsored by