File librest.spec of Package librest

#
# spec file for package librest
#
# Copyright (c) 2010 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#



Name:           librest
%define _name   rest
%define soname  0
%define abi     0.7
Version:        0.7.10
Release:        1
License:        LGPLv2.1
Summary:        Library to access RESTful web services
Url:            http://git.gnome.org/browse/librest/
Group:          Development/Libraries/GNOME
Source0:        http://download.gnome.org/sources/rest/0.7/%{_name}-%{version}.tar.bz2
BuildRequires:  pkgconfig(glib-2.0)
BuildRequires:  pkgconfig(gobject-introspection-1.0)
BuildRequires:  pkgconfig(libsoup-2.4)
BuildRequires:  pkgconfig(libsoup-gnome-2.4)
BuildRequires:  pkgconfig(libxml-2.0)
BuildRoot:      %{_tmppath}/%{name}-%{version}-build

%description
This library was designed to make it easier to access web services that
claim to be "RESTful". A reasonable description is that a RESTful
service should have urls that represent remote objects, which methods
can then be called on.

It is comprised of two parts:

    * the first aims to make it easier to make requests by providing a
      wrapper around libsoup.
    * the second aids with XML parsing by wrapping libxml2.

%package -n librest%{soname}
License:        LGPLv2.1
Summary:        Library to access RESTful web services
Group:          Development/Libraries/GNOME

%description -n librest%{soname}
This library was designed to make it easier to access web services that
claim to be "RESTful". A reasonable description is that a RESTful
service should have urls that represent remote objects, which methods
can then be called on.

It is comprised of two parts:

    * the first aims to make it easier to make requests by providing a
      wrapper around libsoup.
    * the second aids with XML parsing by wrapping libxml2.

%package devel
License:        LGPLv2.1
Summary:        Library to access RESTful web services - Development Files
Group:          Development/Libraries/GNOME
Requires:       librest%{soname} = %{version}

%description devel
This library was designed to make it easier to access web services that
claim to be "RESTful". A reasonable description is that a RESTful
service should have urls that represent remote objects, which methods
can then be called on.

It is comprised of two parts:

    * the first aims to make it easier to make requests by providing a
      wrapper around libsoup.
    * the second aids with XML parsing by wrapping libxml2.

%prep
%setup -q -n %{_name}-%{version}

%build
%configure --disable-static
%__make %{?jobs:-j%jobs} V=1

%install
%makeinstall
find %{buildroot} -type f -name "*.la" -delete -print

%clean
%{__rm} -rf %{buildroot}

%post -n librest%{soname} -p /sbin/ldconfig

%postun -n librest%{soname} -p /sbin/ldconfig

%files -n librest%{soname}
%defattr(-, root, root)
%doc AUTHORS COPYING README
%{_libdir}/librest-%{abi}.so.%{soname}
%{_libdir}/librest-%{abi}.so.%{soname}.*
%{_libdir}/librest-extras-%{abi}.so.%{soname}
%{_libdir}/librest-extras-%{abi}.so.%{soname}.*
%{_libdir}/girepository-1.0/Rest-%{abi}.typelib
%{_libdir}/girepository-1.0/RestExtras-%{abi}.typelib

%files devel
%defattr(-, root, root)
%{_libdir}/librest-%{abi}.so
%{_libdir}/librest-extras-%{abi}.so
%{_libdir}/pkgconfig/rest-%{abi}.pc
%{_libdir}/pkgconfig/rest-extras-%{abi}.pc
%{_datadir}/gir-1.0/*.gir
%{_includedir}/rest-%{abi}/
%doc %{_datadir}/gtk-doc/html/rest-%{abi}/

%changelog
openSUSE Build Service is sponsored by