File libtorrent-rasterbar.spec of Package libtorrent-rasterbar

#
# spec file for package libtorrent-rasterbar
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%define _soname 6
# for setting those bcond_with* configs see
# http://lizards.opensuse.org/2008/09/12/conditional-features-aka-use-flags/
# optionally build with examples
%bcond_with examples

Name:           libtorrent-rasterbar
Version:        0.15.9
Release:        0
Summary:        Libtorrent is a C++ implementation of the BitTorrent protocol
License:        BSD-3-Clause
Group:          Development/Libraries/C and C++
Url:            http://www.rasterbar.com/products/libtorrent/
Source:         http://libtorrent.googlecode.com/files/%{name}-%{version}.tar.gz
Patch0:         libtorrent-rasterbar-0.15.9-missing-return.patch
BuildRequires:  boost-devel >= 1.36
BuildRequires:  gcc-c++
BuildRequires:  libGeoIP-devel
BuildRequires:  pkg-config
BuildRequires:  pkgconfig(openssl)
BuildRequires:  pkgconfig(python)
BuildRequires:  pkgconfig(zlib)
BuildRoot:      %{_tmppath}/%{name}-%{version}-build

%description
libtorrent is a C++ library that aims to be a good alternative to all the other bittorrent implementations around. It is a library and not a full featured client, although it comes with a working example client.

The main goals of libtorrent are:
* to be cpu efficient
* to be memory efficient
* to be very easy to use

This package holds the sample client and example files for libtorrent-rasterbar.

%package -n %{name}%{_soname}
Summary:        Libtorrent is a C++ implementation of the BitTorrent protocol
Group:          System/Libraries

%description -n %{name}%{_soname}
libtorrent is a C++ library that aims to be a good alternative to all the other bittorrent implementations around. It is a library and not a full featured client, although it comes with a working example client.

The main goals of libtorrent are:
* to be cpu efficient
* to be memory efficient
* to be very easy to use

%package -n python-%{name}
Summary:        Python Bindings for libtorrent-rasterbar
Group:          Development/Libraries/Python
Requires:       python >= %{py_ver}

%description -n python-libtorrent-rasterbar
Python Bindings for package libtorrent-rasterbar.

%if %{with examples}

%package -n %{name}-tools
Summary:        Example tools from libtorrent-rasterbar
Group:          Development/Libraries/C and C++

%description -n %{name}-tools
Example tools from the libtorrent-rasterbar package.
%endif

%package devel
Summary:        Libtorrent is a C++ implementation of the BitTorrent protocol
Group:          Development/Libraries/C and C++
Requires:       %{name}%{_soname} = %{version}
Requires:       boost-devel >= 1.36
Requires:       gcc-c++
Requires:       libGeoIP-devel
Requires:       pkgconfig(openssl)
Requires:       pkgconfig(zlib)

%description devel
libtorrent is a C++ library that aims to be a good alternative to all the other bittorrent implementations around. It is a library and not a full featured client, although it comes with a working example client.

The main goals of libtorrent are:
* to be cpu efficient
* to be memory efficient
* to be very easy to use

This package holds the development files for libtorrent-rasterbar.

%package doc
Summary:        Documentation for libtorrent-rasterbar
Group:          Documentation/HTML

%description doc
Documentation for package libtorrent-rasterbar.

%prep
%setup -q
%patch0 -p1

%build
export CFLAGS="%{optflags} -g -fno-strict-aliasing"
export CXXFLAGS="%{optflags} -g -fno-strict-aliasing"
export LDFLAGS="%{optflags} -lrt"

%configure \
        --disable-static \
        --disable-silent-rules \
        --with-libgeoip \
        --with-boost-libdir=%{_libdir} \
        --enable-tests \
%if %{with examples}
        --enable-examples \
%endif
        --enable-python-binding

make %{?_smp_mflags}

%install
%make_install
rm -v %{buildroot}%{_libdir}/*.la
# move doc to separate package
mkdir -p %{buildroot}%{_defaultdocdir}/%{name}
install -m 644 docs/* %{buildroot}%{_defaultdocdir}/%{name}/

%post  -n %{name}%{_soname} -p /sbin/ldconfig

%postun -n %{name}%{_soname} -p /sbin/ldconfig

%if %{with examples}

%files -n %{name}-tools
%defattr(-,root,root)
%{_bindir}/client_test
%{_bindir}/dump_torrent
%{_bindir}/enum_if
%{_bindir}/make_torrent
%{_bindir}/simple_client
%endif

%files -n %{name}%{_soname}
%defattr(-,root,root)
%doc AUTHORS COPYING ChangeLog NEWS README
%{_libdir}/%{name}.so.%{_soname}
%{_libdir}/%{name}.so.%{_soname}.0.0

%files -n python-%{name}
%defattr(-,root,root)
%py_sitedir/libtorrent.so
%py_sitedir/python_libtorrent-%{version}-py%{py_ver}.egg-info

%files devel
%defattr(-,root,root)
%{_includedir}/libtorrent/
%{_libdir}/%{name}.so
%{_libdir}/pkgconfig/%{name}.pc

%files doc
%defattr(-,root,root)
%doc %{_defaultdocdir}/%{name}/

%changelog
openSUSE Build Service is sponsored by