File popt.spec of Package popt

#
# spec file for package popt (Version 1.13)
#
# Copyright (c) 2009 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#



Name:           popt
Version:        1.13
Release:        2
#!BuildIgnore:  rpmlint-Factory
License:        MIT
Summary:        A C library for parsing command line parameters
Group:          System Environment/Libraries
Url:            http://www.rpm5.org/
Source:         popt-%{version}.tar.gz
Patch:          popt-1.13-popt_fprintf.diff
BuildRoot:      %{_tmppath}/%{name}-%{version}-build

%description
Popt is a C library for parsing command line parameters.  Popt was
heavily influenced by the getopt() and getopt_long() functions. It
improves on them by allowing more powerful argument expansion. Popt can
parse arbitrary argv[] style arrays and automatically set variables
based on command line arguments.  Popt allows command line arguments to
be aliased via configuration files and includes utility functions for
parsing arbitrary strings into argv[] arrays using shell-like rules.

%package -n libpopt0
License:        MIT
Summary:        A C library for parsing command line parameters
Group:          System Environment/Libraries
Provides:       popt = %{version}-%{release}
Obsoletes:      popt < %{version}

%description -n libpopt0
Popt is a C library for parsing command line parameters.  Popt was
heavily influenced by the getopt() and getopt_long() functions. It
improves on them by allowing more powerful argument expansion. Popt can
parse arbitrary argv[] style arrays and automatically set variables
based on command line arguments.  Popt allows command line arguments to
be aliased via configuration files and includes utility functions for
parsing arbitrary strings into argv[] arrays using shell-like rules.

%package devel
License:        MIT
Summary:        Development files for the popt library
Group:          Development/Libraries
Requires:       libpopt0 = %{version}

%description devel
The popt-devel package includes header files and libraries necessary
for developing programs which use the popt C library. It contains the
API documentation of the popt library, too.

%prep
%setup -q
%patch -p1

%build
%configure --libdir=/%{_lib}
make

%install
make DESTDIR=$RPM_BUILD_ROOT install
rm -f $RPM_BUILD_ROOT/%_lib/libpopt.a
rm -f $RPM_BUILD_ROOT/%_lib/libpopt.la

%clean
rm -rf $RPM_BUILD_ROOT

%post -n libpopt0 -p /sbin/ldconfig

%postun -n libpopt0 -p /sbin/ldconfig

%files -n libpopt0
%defattr(-,root,root)
%doc CHANGES COPYING
/%{_lib}/libpopt.so.*
/usr/share/locale/*/LC_MESSAGES/popt.mo

%files devel
%defattr(-,root,root)
%doc README
/%{_lib}/libpopt.so
%{_includedir}/popt.h
%{_mandir}/man3/popt.3*

%changelog
openSUSE Build Service is sponsored by