File protobuf-c.spec of Package protobuf-c

#
# spec file for package protobuf-c
#
# Copyright (c) 2011 Pascal Bleser
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#



Name:           protobuf-c
Version:        0.15
Release:        0
%define soname 0
Summary:        C bindings for Google's Protocol Buffers
Source:         http://protobuf-c.googlecode.com/files/protobuf-c-%{version}.tar.gz
Source99:       protobuf-c-rpmlintrc
Url:            http://code.google.com/p/protobuf-c/
Group:          Development/Tools/Other
License:        ASL 2.0 
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildRequires:  autoconf
BuildRequires:  automake
BuildRequires:  gcc
BuildRequires:  glibc-devel
BuildRequires:  libtool
BuildRequires:  make
BuildRequires:  pkgconfig
BuildRequires:  protobuf-devel
Requires:       libprotobuf-c-devel = %{version}

%description
This package provides a code generator and runtime libraries to use Protocol
Buffers from pure C (not C++).

It uses a modified version of protoc called protoc-c.

%package -n libprotobuf-c%{soname}
Summary:        C bindings for Google's Protocol Buffers
Group:          System/Libraries

%description -n libprotobuf-c%{soname}
This package provides a code generator and runtime libraries to use Protocol
Buffers from pure C (not C++).

%package -n libprotobuf-c-devel
Summary:        C bindings for Google's Protocol Buffers
Group:          Development/Libraries/C and C++
Requires:       libprotobuf-c%{soname} = %{version}

%description -n libprotobuf-c-devel
This package provides a code generator and runtime libraries to use Protocol
Buffers from pure C (not C++).

%prep
%setup -q

%build
%if 0
mkdir build
pushd build
export CFLAGS="%{optflags}"
cmake \
    -DCMAKE_VERBOSE_MAKEFILE=TRUE \
    -DCMAKE_INSTALL_PREFIX:PATH="%{_prefix}" \
    -DCMAKE_SKIP_RPATH=TRUE \
    -DCMAKE_BUILD_WITH_INSTALL_RPATH=FALSE \
    -DCMAKE_STRIP="/usr/bin/touch" \
    ..
%__make %{?_smp_flags}
popd #build
%else
%configure
%__make %{?_smp_flags}
%endif

%install
%if 0
pushd build
%makeinstall
popd #build
%else
%makeinstall
%endif

%__rm "%{buildroot}%{_libdir}"/*.a
%__rm "%{buildroot}%{_libdir}"/*.la

%post   -n libprotobuf-c%{soname} -p /sbin/ldconfig

%postun -n libprotobuf-c%{soname} -p /sbin/ldconfig

%clean
%{?buildroot:%__rm -rf "%{buildroot}"}

%files
%defattr(-,root,root)
%doc ChangeLog TODO
%{_bindir}/protoc-c

%files -n libprotobuf-c%{soname}
%defattr(-,root,root)
%{_libdir}/libprotobuf-c.so.%{soname}
%{_libdir}/libprotobuf-c.so.%{soname}.*

%files -n libprotobuf-c-devel
%defattr(-,root,root)
%dir %{_includedir}/google
%{_includedir}/google/protobuf-c
%{_libdir}/libprotobuf-c.so
%{_libdir}/pkgconfig/libprotobuf-c.pc

%changelog
openSUSE Build Service is sponsored by