File pommed.spec of Package pommed

#
# spec file for package pommed (Version 1.14)
#
# Copyright (c) 2008 SUSE LINUX Products GmbH, Nuernberg, Germany.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

# norootforbuild

Name:           pommed
Summary:        Apple laptops hotkeys event handler
License:        GPL v2 only
Group:          Hardware/Mobile
Version:        1.14
Release:        1
Url:            http://technologeek.org/projects/pommed/
BuildRequires:  alsa-devel audiofile-devel gtk2-devel libglade2-devel pciutils-devel update-desktop-files
BuildRequires:  dbus-1-devel libconfuse-devel libsmbios-devel libsmbios-libs
BuildRequires:  xorg-x11-libX11-devel xorg-x11-libXext-devel xorg-x11-libXpm-devel xorg-x11-util-devel
BuildRequires:  xorg-x11
%if 0%{?suse_version} > 1020
BuildRequires:  fdupes
%endif
PreReq:         %insserv_prereq %fillup_prereq 
Requires:       eject xorg-x11
Source0:        %name-%version.tar.bz2
Source1:        pommed.init
Source2:        gpomme.desktop
Source3:        gpommerc
Source4:        pommed-README.SuSE
Source5:        pommed-rpmlintrc
Patch:          pommed-1.10-build.patch
Patch2:         pommed-1.14-dbus.patch
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
%define         kdedir /opt/kde3

%description
pommed handles the hotkeys found on the Apple MacBook Pro, MacBook and
PowerBook laptops and adjusts the LCD backlight, sound volume, keyboard
backlight or ejects the CD-ROM drive accordingly.

pommed also monitors the ambient light sensors to automatically light
up the keyboard backlight on the MacBook Pro and PowerBook.

Optional support for the Apple Remote control is available.



Authors:
--------
    Julien BLACHE <jb@jblache.org>

%package -n gpomme
Summary:        Graphical client for pommed
Group:          Hardware/Mobile
Requires:       pommed
Requires:       dbus-1

%description -n gpomme
pommed handles the hotkeys found on the Apple MacBook Pro, MacBook and
PowerBook laptops and adjusts the LCD backlight, sound volume, keyboard
backlight or ejects the CD-ROM drive accordingly.

gpomme is a graphical client for pommed. It listens for signals sent by
pommed on DBus and displays the action taken by pommed along with the
current state associated to this action.



Authors:
--------
    Julien BLACHE <jb@jblache.org>

%package -n wmpomme
Summary:        WindowMaker dockapp client for pommed
Group:          Hardware/Mobile
Requires:       pommed
Requires:       dbus-1

%description -n wmpomme
pommed handles the hotkeys found on the Apple MacBook Pro, MacBook and
PowerBook laptops and adjusts the LCD backlight, sound volume, keyboard
backlight or ejects the CD-ROM drive accordingly.

wmpomme is a dockapp client for pommed. It displays the current level
of each item controlled by pommed.



Authors:
--------
    Julien BLACHE <jb@jblache.org>

%prep
%setup
%patch
%patch2 -p1

%build
## FIXME: make CFLAGS="$RPM_OPT_FLAGS" %{?jobs:-j%jobs}
make %{?jobs:-j%jobs}

%install
mkdir -p %buildroot/%_bindir %buildroot/%_sbindir %buildroot/%_sysconfdir/{init.d,dbus-1/system.d} 
mkdir -p %buildroot/%_datadir/{applications,icons,pixmaps,gpomme,locale} 
mkdir -p %buildroot/%_mandir/man1 %buildroot/%{kdedir}/share/{autostart,config}
install -m 755 pommed/pommed          %buildroot/%_sbindir
install -m644 %{SOURCE4} README.SuSE
%ifarch ppc ppc64
install -m 644 pommed.conf.pmac       %buildroot/%_sysconfdir/pommed.conf
%else
install -m 644 pommed.conf.mactel     %buildroot/%_sysconfdir/pommed.conf
%endif
install -m 644 dbus-policy.conf       %buildroot/%_sysconfdir/dbus-1/system.d/pommed.conf
install -m 755 %{S:1}                 %buildroot/%_sysconfdir/init.d/pommed
ln -sf %_sysconfdir/init.d/pommed %buildroot/%_sbindir/rcpommed
install -m 644 pommed.1               %buildroot/%_mandir/man1
# gpomme
install -m 755 gpomme/gpomme          %buildroot/%_bindir
install -m 644 gpomme/gpomme.1        %buildroot/%_mandir/man1
install -m 644 gpomme/*.desktop       %buildroot/%_datadir/applications
install -m 644 icons/gpomme*          %buildroot/%_datadir/icons
install -m 644 icons/gpomme_32x32.xpm %buildroot/%_datadir/pixmaps/gpomme.xpm
install -m 644 gpomme/gpomme.glade    %buildroot/%_datadir/gpomme
cp -a gpomme/themes                   %buildroot/%_datadir/gpomme
rm -rfv %buildroot/%_datadir/gpomme/themes/src
for mo in gpomme/po/*.mo ; do
    lang=`basename $mo .mo`
    filename="gpomme.mo"
    install -d %buildroot/%_datadir/locale/$lang/LC_MESSAGES
    install -m 644 $mo %buildroot/%_datadir/locale/$lang/LC_MESSAGES/$filename
done
install -m 644 %{S:2} %buildroot/%{kdedir}/share/autostart
install -m 644 %{S:3} %buildroot/%{kdedir}/share/config
# wmpomme
install -m 755 wmpomme/wmpomme        %buildroot/%_bindir
install -m 644 wmpomme/wmpomme.1      %buildroot/%_mandir/man1
install -m 644 icons/gpomme_32x32.xpm %buildroot/%_datadir/icons/wmpomme.xpm
%suse_update_desktop_file %buildroot/%_datadir/applications/gpomme-c.desktop
%suse_update_desktop_file %buildroot/%_datadir/applications/gpomme.desktop
# enable videoswitch
mkdir -p %buildroot/%_sysconfdir/pommed
ln -s /usr/bin/grandr %buildroot/%_sysconfdir/pommed/videoswitch
%if 0%{?suse_version} > 1020
%fdupes -s %buildroot
%endif
%find_lang gpomme

%post
%{fillup_and_insserv -n %name %name}

%preun
%stop_on_removal %name

%postun
%restart_on_update %name
%{insserv_cleanup}

%clean
rm -rf %buildroot

%files
%defattr(-,root,root)
%doc AUTHORS README TODO README.SuSE
%config(noreplace) /etc/pommed.conf
%config(noreplace) /etc/dbus-1/system.d/pommed.conf
%_sysconfdir/init.d/pommed
%dir %_sysconfdir/pommed
%config(noreplace) %_sysconfdir/pommed/videoswitch
%_sbindir/pommed
%_sbindir/rcpommed
%_mandir/man1/po*

%files -n gpomme -f gpomme.lang
%defattr(-,root,root)
%_bindir/gpomme
%_datadir/applications/*.desktop
%_datadir/icons/gp*
%_datadir/pixmaps/gp*
%_datadir/gpomme
%dir %{kdedir}
%dir %{kdedir}/share
%{kdedir}/share/autostart
%{kdedir}/share/config
%_mandir/man1/gpo*

%files -n wmpomme
%defattr(-,root,root)
%_bindir/wmpomme
%_datadir/icons/wm*
%_mandir/man1/wmpo*

%changelog
* Thu Jan 17 2008 lrupp@suse.de
- update to 1.14:
  + fix error handling in the audio sample loading code to properly
  report failure, preventing nasty segfaults later on in case the
  sound file is not available.
  + make goutte.wav the default beep sound, add click.wav and remove
  the KDE beep sound.
  + add an option to disable the beep on volume change
  + add the videoSwitch DBus notification
  + add support for LCD backlight control on the Intel 965GM
  found in the MacBook3,1
  + rework the inotify code to handle several events at once and to
  handle events with long filenames (longer than
  sizeof(struct inotify_event)); pommed could enter a busy-loop
  when receiving an inotify event with
  ie->len > sizeof(struct inotify_event)
  + wpomme: added video switch support
  + gpomme: added video switch support
  + do not expect at least 3 evdevs at startup
  + adds partial support for the new MacBook Santa Rosa (MacBook3)
  + fixes bug with disappearing event devices after suspend
  + external Apple USB keyboards are now supported
  + beep on volume change per default
  + rework the event management.
  Use epoll() for event polling instead of poll().
  + add secondary locations for the uinput device node.
  + pommed: add a beeper feature as a substitute to the missing PC
  Speaker. The feature is disabled by default, as not all
  machines need it and not everybody wants it.
- added gpomme.desktop and gpommerc to start gpomme via KDE
- added %%pre and %%post scripts for pommed
- use fdupes to save space
- use /usr/bin/grandr for videoswitch option
- added README.SuSE for applesmc kernel module
- fix lang files so gpomme is tranlated
* Mon Sep 17 2007 ro@suse.de
- created package from pommed (version 1.9)
openSUSE Build Service is sponsored by