File cryptsetup.spec of Package cryptsetup

#
# spec file for package cryptsetup
#
# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           cryptsetup
Url:            http://code.google.com/p/cryptsetup/
Version:        1.6.3
Release:        0
Summary:        Set Up dm-crypt Based Encrypted Block Devices
License:        SUSE-GPL-2.0-with-openssl-exception and LGPL-2.0+
Group:          System/Base

Source:         http://cryptsetup.googlecode.com/files/cryptsetup-%version.tar.bz2
Source1:        http://cryptsetup.googlecode.com/files/cryptsetup-%version.tar.bz2.asc
Source2:        baselibs.conf
Source3:        %{name}.keyring
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildRequires:  device-mapper-devel
BuildRequires:  e2fsprogs-devel
BuildRequires:  libgcrypt-devel
BuildRequires:  libselinux-devel
BuildRequires:  libtool
# 2.6.38 has the required if_alg.h
BuildRequires:  linux-glibc-devel >= 2.6.38
BuildRequires:  pkgconfig
BuildRequires:  popt-devel

%description
cryptsetup is used to conveniently set up dm-crypt based device-mapper
targets. It allows to set up targets to read cryptoloop compatible
volumes as well as LUKS formatted ones. The package additionally
includes support for automatically setting up encrypted volumes at boot
time via the config file /etc/crypttab.

%package -n libcryptsetup4
Summary:        Set Up dm-crypt Based Encrypted Block Devices
Group:          System/Base

%description  -n libcryptsetup4
cryptsetup is used to conveniently set up dm-crypt based device-mapper
targets. It allows to set up targets to read cryptoloop compatible
volumes as well as LUKS formatted ones. The package additionally
includes support for automatically setting up encrypted volumes at boot
time via the config file /etc/crypttab.

%package -n libcryptsetup-devel
Summary:        Set Up dm-crypt Based Encrypted Block Devices
Group:          Development/Libraries/C and C++
# cryptsetup-devel last used 11.1
Provides:       cryptsetup-devel = %{version}
Obsoletes:      cryptsetup-devel < %{version}
Requires:       glibc-devel
Requires:       libcryptsetup4 = %{version}

%description  -n libcryptsetup-devel
cryptsetup is used to conveniently set up dm-crypt based device-mapper
targets. It allows to set up targets to read cryptoloop compatible
volumes as well as LUKS formatted ones. The package additionally
includes support for automatically setting up encrypted volumes at boot
time via the config file /etc/crypttab.

%prep
%setup -q

%build
# cryptsetup build
%{?suse_update_config:%{suse_update_config}}
autoreconf -f -i
test -e po/Makevars || cp po/Makevars.template po/Makevars
%configure \
	    --disable-static --enable-shared \
	    --enable-cryptsetup-reencrypt \
	    --enable-selinux
make %{?_smp_mflags}

%install
make install DESTDIR=$RPM_BUILD_ROOT
install -d -m 755 $RPM_BUILD_ROOT/sbin
ln -s ..%{_sbindir}/cryptsetup $RPM_BUILD_ROOT/sbin
# don't want this file in /lib (FHS compat check), and can't move it to /usr/lib
rm -f $RPM_BUILD_ROOT/%_libdir/*.la
#
%find_lang %name --all-name

%pre

%post
test -n "$FIRST_ARG" || FIRST_ARG="$1"
#
# convert noauto to nofail and turn on fsck (bnc#724113)
#
marker="/var/adm/crypsetup.fstab.noauto_converted"
if [ "$FIRST_ARG" -gt 1 -a ! -e "$marker" ]; then
	echo "updating /etc/fstab ... "
	tmpfstab="/etc/fstab.cryptsetup.$$"
	sed -e '/^\/dev\/mapper\/cr_.*,noauto\s/{s/,noauto\(\s\)/,nofail\1/;s/ 0 0$/ 0 2/}' < /etc/fstab > "$tmpfstab"
	if diff -u0 /etc/fstab "$tmpfstab"; then
		echo "no change"
		rm -f "$tmpfstab"
		> "$marker"
	else
		cp "$tmpfstab" "$marker"
		mv "$tmpfstab" /etc/fstab
	fi
fi

%post -n libcryptsetup4 -p /sbin/ldconfig

%postun -n libcryptsetup4 -p /sbin/ldconfig

%files -f %name.lang
%defattr(-,root,root)
#ghost %verify(not md5 size mtime) %config(noreplace,missingok) /etc/crypttab
#ghost %verify(not md5 size mtime) %config(noreplace,missingok) /etc/cryptotab
/sbin/cryptsetup
%{_sbindir}/cryptsetup
%{_sbindir}/veritysetup
%{_sbindir}/cryptsetup-reencrypt
%_mandir/man8/cryptsetup.8.gz
%_mandir/man8/cryptsetup-reencrypt.8.gz
%_mandir/man8/veritysetup.8.gz

%files -n libcryptsetup4
%defattr(-,root,root)
/%{_libdir}/libcryptsetup.so.4*

%files -n libcryptsetup-devel
%defattr(-,root,root)
%_includedir/libcryptsetup.h
%{_libdir}/libcryptsetup.so
%{_libdir}/pkgconfig/*

%changelog
openSUSE Build Service is sponsored by