File libsigc++2.spec of Package libsigc++2

#
# spec file for package libsigc++2 (Version 2.2.7)
#
# Copyright (c) 2010 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

# norootforbuild


Name:           libsigc++2
%define _name libsigc++
BuildRequires:  gcc-c++ pkg-config
Version:        2.2.7
Release:        1
Group:          Development/Libraries/C and C++
License:        LGPLv2.1+
Summary:        Typesafe Signal Framework for C++
Url:            http://libsigc.sourceforge.net/
Source:         %{_name}-%{version}.tar.bz2
Source99:       baselibs.conf
AutoReqProv:    on
BuildRoot:      %{_tmppath}/%{name}-%{version}-build

%description
This library implements a full callback system for use in widget
libraries, abstract interfaces, and general programming. It is the most
complete library of its kind with the ablity to connect an abstract
callback to a class method, function, or function object. It contains
adaptor classes for connection of dissimilar callbacks and has an ease
of use unmatched by other C++ callback libraries.

%package devel
License:        LGPLv2.1+
Group:          Development/Libraries/C and C++
Summary:        Typesafe Signal Framework for C++
Requires:       %{name} = %{version} libstdc++-devel

%description devel
This library implements a full callback system for use in widget
libraries, abstract interfaces, and general programming. It is the most
complete library of its kind with the ability to connect an abstract
callback to a class method, function, or function object. It contains
adaptor classes for connection of dissimilar callbacks and has an ease
of use unmatched by other C++ callback libraries.

%prep
%setup -q -n %{_name}-%{version}

%build
# FIXME: Cannot autoreconf, bad templates:
#ACLOCAL="aclocal -I scripts" autoreconf -f -i
%configure --disable-static --with-pic
%{__make} %{?jobs:-j%jobs}

%check
export MALLOC_CHECK_=2 MALLOC_PERTURB_=$((${RANDOM:-256} % 256))
%{__make} check
unset MALLOC_CHECK_ MALLOC_PERTURB_

%install
%makeinstall
rm -f %{buildroot}%{_libdir}/*.la

%clean
rm -rf $RPM_BUILD_ROOT

%post -p /sbin/ldconfig

%postun -p /sbin/ldconfig

%files
%defattr (-, root, root)
%doc AUTHORS COPYING ChangeLog NEWS README TODO
%{_libdir}/*.so.*

%files devel
%defattr (-, root, root)
%{_libdir}/*.so
%{_libdir}/pkgconfig/*.pc
%{_libdir}/sigc++-2.0
%{_includedir}/sigc++-2.0/
%{_datadir}/devhelp/books/%{_name}-2.0
%doc %{_datadir}/doc/%{_name}-2.0
# Avoid BuildRequires on devhelp
%dir %{_datadir}/devhelp
%dir %{_datadir}/devhelp/books

%changelog
openSUSE Build Service is sponsored by