File libsigc++2.spec of Package libsigc++2

#
# spec file for package libsigc++2
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           libsigc++2
%define _name libsigc++
Version:        2.3.1
Release:        0
Summary:        Typesafe Signal Framework for C++
License:        LGPL-2.1+
Group:          System/Libraries
Url:            http://libsigc.sourceforge.net/
Source:         http://download.gnome.org/sources/libsigc++/2.3/%{_name}-%{version}.tar.xz
Source99:       baselibs.conf
BuildRequires:  gcc-c++
BuildRequires:  pkg-config
BuildRoot:      %{_tmppath}/%{name}-%{version}-build

%description
This library implements a full callback system for use in widget
libraries, abstract interfaces, and general programming. It is the most
complete library of its kind with the ability to connect an abstract
callback to a class method, function, or function object. It contains
adaptor classes for connection of dissimilar callbacks and has an ease
of use unmatched by other C++ callback libraries.

%package -n libsigc-2_0-0
Summary:        Typesafe Signal Framework for C++
Group:          System/Libraries
Provides:       %{name} = %{version}
Obsoletes:      %{name} < %{version}

%description -n libsigc-2_0-0
This library implements a full callback system for use in widget
libraries, abstract interfaces, and general programming. It is the most
complete library of its kind with the ability to connect an abstract
callback to a class method, function, or function object. It contains
adaptor classes for connection of dissimilar callbacks and has an ease
of use unmatched by other C++ callback libraries.

%package devel
Summary:        Typesafe Signal Framework for C++
Group:          Development/Libraries/C and C++
Requires:       libsigc-2_0-0 = %{version}
Requires:       libstdc++-devel

%description devel
This library implements a full callback system for use in widget
libraries, abstract interfaces, and general programming. It is the most
complete library of its kind with the ability to connect an abstract
callback to a class method, function, or function object. It contains
adaptor classes for connection of dissimilar callbacks and has an ease
of use unmatched by other C++ callback libraries.

%prep
%setup -q -n %{_name}-%{version}

%build
# FIXME: Cannot autoreconf, bad templates:
#ACLOCAL="aclocal -I scripts" autoreconf -f -i
%configure --disable-static --with-pic
make %{?_smp_mflags}

%install
%make_install
rm -f %{buildroot}%{_libdir}/*.la

%check
export MALLOC_CHECK_=2 MALLOC_PERTURB_=$((${RANDOM:-256} % 256))
make check
unset MALLOC_CHECK_ MALLOC_PERTURB_

%post -n libsigc-2_0-0 -p /sbin/ldconfig

%postun -n libsigc-2_0-0 -p /sbin/ldconfig

%files -n libsigc-2_0-0
%defattr (-, root, root)
%doc AUTHORS COPYING ChangeLog NEWS README TODO
%{_libdir}/libsigc-2.0.so.*

%files devel
%defattr (-, root, root)
%{_libdir}/libsigc-2.0.so
%{_libdir}/pkgconfig/*.pc
%{_libdir}/sigc++-2.0
%{_includedir}/sigc++-2.0/
%{_datadir}/devhelp/books/%{_name}-2.0
%doc %{_datadir}/doc/%{_name}-2.0
# Avoid BuildRequires on devhelp
%dir %{_datadir}/devhelp
%dir %{_datadir}/devhelp/books

%changelog
openSUSE Build Service is sponsored by