File python-fsspec.spec of Package python-fsspec

#
# spec file for package python-fsspec
#
# Copyright (c) 2020 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


%{?!python_module:%define python_module() python-%{**} python3-%{**}}
%define         skip_python2 1
Name:           python-fsspec
Version:        0.8.5
Release:        0
Summary:        Filesystem specification package
License:        BSD-3-Clause
URL:            https://github.com/intake/filesystem_spec
Source:         https://files.pythonhosted.org/packages/source/f/fsspec/fsspec-%{version}.tar.gz
BuildRequires:  %{python_module base >= 3.6}
BuildRequires:  %{python_module setuptools}
BuildRequires:  fdupes
BuildRequires:  python-rpm-macros
Suggests:       python-adlfs
Suggests:       python-aiohttp
Suggests:       python-pyarrow
Suggests:       python-pygit2
Suggests:       python-dropboxdrivefs
Suggests:       python-dropbox
Suggests:       python-dask
Suggests:       python-distributed
Suggests:       python-gcsfs
Suggests:       python-paramiko
Suggests:       python-requests
Suggests:       python-s3fs
Suggests:       python-smbprotocol
BuildArch:      noarch
# SECTION test requirements
BuildRequires:  %{python_module aiohttp}
BuildRequires:  %{python_module cloudpickle}
BuildRequires:  %{python_module distributed}
BuildRequires:  %{python_module fusepy}
BuildRequires:  %{python_module gcsfs}
BuildRequires:  %{python_module notebook}
BuildRequires:  %{python_module numpy}
BuildRequires:  %{python_module panel}
BuildRequires:  %{python_module paramiko}
BuildRequires:  %{python_module pyftpdlib}
BuildRequires:  %{python_module pytest}
BuildRequires:  %{python_module python-snappy}
BuildRequires:  %{python_module requests}
BuildRequires:  %{python_module s3fs}
BuildRequires:  %{python_module smbprotocol}
BuildRequires:  %{python_module zstandard}
# cannot test git and http in the same installation (?)
# BuildRequires:  %%{python_module pygit2}
# BuildRequires:  git-core
# /SECTION
%python_subpackages

%description
A specification for pythonic filesystems.

%prep
%setup -q -n fsspec-%{version}

%build
%python_build

%install
%python_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}

%check
# test_basic relies on speed of FS and timeouts in OBS
# test_not_cached needs sockets
%pytest -rfEs  -k 'not test_basic and not test_not_cached'

%files %{python_files}
%doc README.md
%license LICENSE
%{python_sitelib}/*

%changelog
openSUSE Build Service is sponsored by