File python-nautilus.spec of Package python-nautilus
#
# spec file for package python-nautilus
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: python-nautilus
%define _name nautilus-python
Version: 1.0
Release: 1
License: GPLv2+
Summary: Python bindings for Nautilus
Group: Development/Libraries/Python
Url: http://git.gnome.org/cgit/nautilus-python/
Source: %{_name}-%{version}.tar.bz2
BuildRequires: gtk-doc
BuildRequires: python-devel
BuildRequires: pkgconfig(libnautilus-extension)
BuildRequires: pkgconfig(pygobject-2.0)
Requires: python-gobject
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%description
This package contains bindings to write Nautilus extensions with Python.
It allows writing menu, property pages and column providers extensions,
so that Nautilus functionality can be easily extended.
%package devel
License: GPLv2+
Summary: Python bindings for Nautilus - Development Files
Group: Development/Libraries/Python
Requires: %{name} = %{version}
%description devel
Development files needed for writing Nautilus Python extensions
This package contains bindings to write Nautilus extensions with Python.
It allows writing menu, property pages and column providers extensions,
so that Nautilus functionality can be easily extended.
%prep
%setup -q -n %{_name}-%{version}
%build
%configure --disable-static \
--enable-gtk-doc
make %{?jobs:-j%jobs}
%install
%makeinstall
# New dir where python extensions get installed. It's not created by make
# install (bgo#638890).
test ! -d %{buildroot}%{_datadir}/nautilus-python/extensions
mkdir -p %{buildroot}%{_datadir}/nautilus-python/extensions
find %{buildroot} -type f -name "*.la" -delete -print
%clean
rm -rf %{buildroot}
%files
%defattr(-,root,root)
%doc AUTHORS ChangeLog COPYING NEWS README
%{_libdir}/nautilus/extensions-3.0/libnautilus-python.so
%dir %{_datadir}/nautilus-python/extensions
%files devel
%defattr(-,root,root)
%{_datadir}/doc/nautilus-python/
%{_datadir}/gtk-doc/html/nautilus-python/
%{_libdir}/pkgconfig/nautilus-python.pc
%changelog