File rke.spec of Package rke
#
# spec file for package rke
#
# Copyright (c) 2025 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
Name: rke
Version: 1.8.3
Release: 0
Summary: Rancher Kubernetes Engine
License: Apache-2.0
URL: https://github.com/rancher/rke
Source: rke-%{version}.tar.gz
Source1: vendor.tar.gz
BuildRequires: go >= 1.22.8
%description
RKE is a fast, versatile Kubernetes installer that you can use to install
Kubernetes on your Linux hosts.
Rancher Kubernetes Engine (RKE) is a CNCF-certified Kubernetes distribution
that runs entirely within Docker containers. It works on bare-metal and
virtualized servers. With RKE, the installation and operation of Kubernetes is
both simplified and easily automated, and it’s entirely independent of the
operating system and platform you’re running.
%prep
%autosetup -p 1 -a 1
%build
go build \
-mod=vendor \
-buildmode=pie \
-ldflags="-X main.Version=%{version}"
%install
# Install the binary.
install -D -m 0755 %{name} "%{buildroot}/%{_bindir}/%{name}"
%files
%doc README.md
%license LICENSE
%{_bindir}/%{name}
%changelog